Freedom Force

Freedom Force

stpk Mar 4, 2016 @ 4:33pm
Working on Windows 10
I read in someone else's thread about changing the compatibility to Win 98 to get the game to work in Windows 8. They recommended starting outside of Steam.

I changed compatibility to Win 98 and it works on my Lenovo laptop running Windows 10. I can start it in Steam and even use the Steam controller.
< >
Showing 1-8 of 8 comments
MoonSpirit Mar 5, 2016 @ 11:44am 
Sorry to disappoint, but I just did that, and I still have the same problems everyone is addressing.
stpk Mar 5, 2016 @ 1:53pm 
Sorry it didn't work for you MoonSpirit. I just tried playing again and it is still working on my machine with mouse and keyboard in Windows 10. For some reason the Steam controller is no longer responding though. I'd recommend anyone to give it a try, it may work for them.
Last edited by stpk; Mar 5, 2016 @ 1:54pm
Muzakprime Mar 26, 2016 @ 7:15pm 
I simply have to go open the local files tab for the game, open properties on the application and run it through the troubleshooter. Works just fine for me, though I have to do this each time I want to open the game..
jonjj7 Apr 7, 2016 @ 6:56pm 
Here's my guide to getting the game running in Windows 10. I found 3 methods that worked for me. Hopefully they help someone else.

https://www.youtube.com/watch?v=-dMxWzZ1LQo
Nightstar1441 Apr 26, 2016 @ 10:22am 
Thank you jonjj7 - that video was very helpful. I owned the discs of Freedom Force and they no longer work since I am now on Windows 10 so I was considering adding it via Steam/GOG. It's nice to know there are some fixes to make this work as I really do enjoy this game
ReZoMbiE May 18, 2016 @ 8:53am 
In my case checking "Run this program as an administrator" helped. Thanks for the video guide!
craig.russell535 Feb 22, 2020 @ 12:50pm 
Additional solution to getting Freedom Force to work on Windows 10
====================================================
I bought the Steam version, and it had all the problems everyone has reported with the left and right mouse buttons. I tried "Compatibility Settings", "Run as Administrator" and the GOG version of the fforce.exe. But none of these fixed the problem for me, but fortunately I did find a solution.

(1) Buy GOG version
This fixed the problems with the left and right mouse buttons, but using the mouse to rotate the view or using the mouse wheel to zoom was painfully slow. The game was unplayable.

(2) Install [url=dege.freeweb.hu/dgVoodoo2/dgVoodoo2.html
] dgVoodoo 2 [/url]
Copied D3D8.dll, D3D9.dll, D3DImm.dll, DDraw.dll, dgVoodooCpl.exe and dgVoodoo.conf into Freedom Force game folder. This would be "C:\Program Files (x86)\GOG Galaxy\Games\Freedom Force" since this is for the GOG version. But the screen was extremely dark. Playable, but too dark.

(3) Turned on "Inherited Color Profile in full screen mode" checkbox in dgVoodoo.
When launched the game picked up the brightness, contrast and gamma settings from the Windows Desktop, and it looked great.

Problem solved!!! :-)

s0da72 Sep 13, 2020 @ 1:37pm 
It's a good video listed above, but it did not work for me until I also selected a video resolution in the game that worked which is not mentioned in the video (unless I missed it). Originally I had 1920x1080 which did not work, after I reduced it to 1280x720 it finally started working. The sound also seems to go out when you change the resolution, but the video did explain how to set that back at the end.
< >
Showing 1-8 of 8 comments
Per page: 1530 50