BioShock 2

BioShock 2

View Stats:
BioShock 2 > General Discussions > Topic Details
How to fix Bioshock 2 crashes
Lately people have seem to have been having trouble getting Bioshock 2 to work. If the game is crashing on you do the following.
1.Unistall GFWL from your computer and redownload the latest version here:
2.Unistall Bioshock 2 and then reinstall through Steam (Obviously).
3.Download BS2 version 1.5 from here and place it in C:\Program Files (x86)\Steam\steamapps\common\BioShock 2
4.Install the patch and make sure it installs, when you run the game and get to the menu you should see v1.5 in the lower left hand corner
5.Delete any corrupted saves located in the local BS2 folder on your comp. (Essentially all saves are considered corrupted at this point so just delete the folder)
6.Right click on BS2 in your library, go to properties, set launch options and paste "-dx9" BE SURE TO INCLUDE THE -
Assuming the problem is not your computer you should be able to run the game just fine from there. I can vouch for myself as after following these steps I was able to play for two hours with no problems at all before quitting. If you have any issues though or want to confirm that it worked go right ahead.
Last edited by El Pollo Diablo Intolerante; Mar 20, 2013 @ 10:36pm
< >
Showing 1-15 of 176 comments
Dreamweaver Mar 24, 2013 @ 4:19pm 
so u mean i have to restart from the begining..... D: i was like 5/8 done....
Last edited by Dreamweaver; Mar 24, 2013 @ 4:20pm
Dreamweaver Mar 24, 2013 @ 6:04pm 
it says im missing the titleupdate.log
Batophobia Mar 24, 2013 @ 8:08pm 
Before doing all these steps you can try validating your files with steam first.
друг Mar 24, 2013 @ 8:58pm 
Dreamweaver Mar 24, 2013 @ 9:21pm 
Originally posted by Batophobia:
Before doing all these steps you can try validating your files with steam first.

BUT im still missing the log file help plz

Last edited by Dreamweaver; Mar 24, 2013 @ 9:22pm
Dreamweaver Mar 25, 2013 @ 12:20pm 
can i update with bioshock 2 game instead??
Boraean Mar 25, 2013 @ 4:50pm 
Worked for me - played 4 hours straight. Only slight hiccup was installing the patch - got an error message that required the following command to be run:
"C:\Program Files (x86)\Steam\steamapps\common\setup.exe" /f "C:Program Files (x86)\Steam\Steamapps\common\bioshock2"

Note that the bit before /f is where the patch was saved and the bit after /f is where my game install is. Patch worked when I ran this - on Win 7 the run window is accessed via the Start menu.
Last edited by Boraean; Mar 25, 2013 @ 4:51pm
Dreamweaver Mar 25, 2013 @ 6:55pm 
Im not getting it to work i placed the steam folder in my f drive and it doesn't work
Boraean Mar 26, 2013 @ 12:43pm 
Damn - game has started crashing on level transition :(

Manually reinstalling the patch again corrected the error :)
Last edited by Boraean; Mar 26, 2013 @ 4:43pm
Freaknugget Mar 26, 2013 @ 9:05pm 
Not working for me. followed directions perfectly but the installer still gets this error "Launching Title Update: "C:\Program Files (x86)\Steam\SteamApps\common\BioShock 2\setup.exe" /selflaunch
Could not find game install folder"
Lord Volund Mar 26, 2013 @ 9:26pm 
Pollo, thank you sir! And a nod to Boraean for the syntax for non-standard installation paths. We're golden.
|BC| Urthh Mar 27, 2013 @ 11:57am 
Didnt work for me my game still locks up when LIVE is connecting.
Red Kauxinim Mar 27, 2013 @ 2:39pm 
OMG.. IT WORKED *---------* thank you *-* The sad part is that I have to start the game at the beginning .. I was like 7/8 done D:
Boraean Mar 27, 2013 @ 4:35pm 
@ Freaknugget The patch can't find your game launcher - look at my first post and follow the instruction to get it to work.
socharis Mar 27, 2013 @ 7:53pm 
GFWL is pure, undiluted evil. It always has been, it always will be.
Last edited by socharis; Mar 27, 2013 @ 7:54pm
< >
Showing 1-15 of 176 comments
Per page: 15 30 50

BioShock 2 > General Discussions > Topic Details
Date Posted: Mar 20, 2013 @ 10:29pm
Posts: 176