Mark of the Ninja: Remastered

Mark of the Ninja: Remastered

View Stats:
Papacoon Oct 9, 2018 @ 12:11pm
Green screen and game is not being shown properly
I get something like this but with a green colour on top of it. I am using antergos with mesa 18.2.2 and kernel 4.18.12
Last edited by Papacoon; Oct 9, 2018 @ 12:11pm
< >
Showing 1-15 of 15 comments
BloodScourge Oct 9, 2018 @ 1:27pm 
Same thing here (Arch Linux, Kernel 4.18.12, Mesa 18.2.2; Intel Core i7-4790K, 16 GB of RAM, AMD Radeon RX 580 8GB):
- Videos (intro, main menu background) are green-tinted.
- Menus: items are collapsed together but navigation works.
- In-game: characters are invisible inside buildings or behind handrails, rooftops... etc. There is some UI flickering too.
tengwarscribe Oct 9, 2018 @ 2:01pm 
Same problems on Linux Mint 19.

Kernel 4.15.0
Mesa 18.3.0
AMD A10-5800K
AMD Radeon RX 560 4GB
Same problem here:
Manjaro
Linux 4.19rc7
Mesa 18.2.2
LLVM 7.0.0

AMD Ryzen 1700 with AMD R9 Nano
Same here: AMDGPU with mesa 18.2.1 and llvm 7.0.0
gowkaizer Oct 9, 2018 @ 4:43pm 
Manjaro Linux with Intel graphics, nothing comes up, the game just shuts down.

Mark of the Ninja original and Shank work.

Manjaro
Linux 4.19rc7
Mesa 18.2.2
LLVM 7.0.0
Last edited by gowkaizer; Oct 9, 2018 @ 4:54pm
bizx Oct 9, 2018 @ 5:17pm 
+1
ArchLinux -- AMD RX480
Kernel 4.18.12
Mesa 18.2.2
LLVM 7.0.0

original working fine.
Klei-JoeW  [developer] Oct 9, 2018 @ 5:21pm 
Hey everybody. Our linux programmer is currently out of the office, but he'll check it out as soon as possible, sorry for the inconvenience.
bizx Oct 9, 2018 @ 5:24pm 
As a side note, the remastered edition seems to be doing window management much better! It doesn't lock focus and refuse to let me alt+tab out like the original. So I'm already super stoked about actually being able to play this on a multi-monitor setup.

(And thanks for acknowleding the thread)
InfHor1Zy Oct 9, 2018 @ 7:46pm 
I have same issue, I have laptop with manjaro installed (mesa driver), the game won't start and immediately down. my desktop with WINDOWS runs fine.
Last edited by InfHor1Zy; Oct 9, 2018 @ 9:19pm
SilverSynch Oct 9, 2018 @ 8:54pm 
Also happening my Arch install. OpenGL renderer string: AMD Radeon (TM) RX 470 Graphics (POLARIS10, DRM 3.26.0, 4.18.10-arch1-1-ARCH, LLVM 8.0.0).
SilverSynch Oct 9, 2018 @ 8:58pm 
Additional, unrelated Issue: Running the game from the command line causes it to stop and then query Steam to run it instead (understandable, pretty standard, not an issue). However, Remastered accidentially queries Steam to run the original edition. This happens even if the original is not installed.
Last edited by SilverSynch; Oct 9, 2018 @ 8:59pm
TheMaxus Oct 10, 2018 @ 3:25am 
Seems like this issue only affects AMD graphics card users because game runs fine on my Ryzen 5 1600X and GTX960 machine under Arch Linux
Last edited by TheMaxus; Oct 10, 2018 @ 3:25am
AciD Oct 12, 2018 @ 12:11am 
Same here on Debian buster, mesa 18.2.0-1, AMD Radeon HD 7950, Ryzen 5 1600, kernel 4.18.0.
Last edited by AciD; Oct 12, 2018 @ 12:12am
FortyThree Oct 13, 2018 @ 5:32am 
Hi, same here:
Custom gnu/linux distro, 3D drivers: git version, no older than a week ("state-of-the-art" AMD 3D drivers), native x11/GL/vulkan (not wayland).

GPU AMD tahiti xt
Last edited by FortyThree; Oct 13, 2018 @ 5:38am
< >
Showing 1-15 of 15 comments
Per page: 15 30 50