DEAD OR ALIVE 6

DEAD OR ALIVE 6

View Stats:
DoA6 AMD Lost Paradise Crash Fix
I fixed the AMD Crash for DoA6 in Lost Paradise Stage.
Ok I fixed it. So here we go step by step.
I am running an AMD RX460 GPU, an A10-7860k CPU and Windows 10 OS.

1. Go to start menu and type in search GRAPHICS SETTINGS select it.

2. Then when it opens select BROWSE.

3. Locate your DOA6.EXE game file. Mine is located in (this pc>local disk (C:)>program files (x86)>steam>steamapps>common>Dead or alive 6)

4. Left click Doa6.exe once, and then select ADD.

5. Underneath the BROWSE you should now see DoA6 left click on it once.

6. Select OPTIONS and choose HIGH PEDFORMANCE.

7. Now save it and close GRAPHICS SETTINGS.

8.locate Doa6.exe target. Once again mine is located in (this pc>local disk (C:)>program files (x86)>steam>steamapps>common>Dead or alive 6)

9. Right click the DoA6.exe and go to properties.

10. Select COMPATABILITY tab.

11. From here you want to put a check mark in the box next to *Run the program in compatability for*, and then select windows 8.

12. Apply settings DO NOT CLICK OK YET.

13. Next you want to select *Change high DPI settings*.

14. Then put a check mark in the box next to *Use this setting to fix scaling problems for this program instead of the one in settings*.

15. Then underneath *Use the DPI that's set for my main display when*, then select *I open this program*. Then select OK.

16. (For this next part make sure you're using AMD Radeon Settings Version 19.2.3 this is what I'm using it could work for 19.1.1 but that's not what I'm using)

17. Next open your AMD Radeon Settings.

18. Select the GAMING tab.

19. Select DEAD OR ALIVE 6

20. Make sure your settings match mine.

Anti-aliasing Mode:
-Use application settings (Off in game)

Anti-aliasing Method:
-Multisampling (Off in game)

Morphological Filtering:
-Off

Anisotropic Filtering Mode:
-Use application settings (Off in game)

Texture Filtering Quality:
-Performance

Surface Format Optimization:
-On

Wait for Vertical Refresh:
-Off, unless application specifies (Off in game, unless your frames are able to be maintained, never dropping below your monitors refresh rate)

OpenGL Triple Buffering
-Off

Shader Cache:
-AMD optimized

Tessellation Mode:
-Override application settings

Maximum Tessellation Level
-Off

Frame Rate Target Control:
-On [Set to your monitors maximum refresh rate - EX: 60 is using 60Hz, 75 is using 75Hz etc..] Mine is set to 60.

21. Restart Computer.

22. Load up the game and go to training (yes it works online too this is just faster to get to) select your fighters, then select Lost Paradise stage and if all went well you should be enjoying DOA6 As an AMD User. (If your game is lagging up a bit , and NOT crashing, then lower your in game graphics settings.)
Last edited by HellHoKitty; Mar 5 @ 2:16pm
< >
Showing 1-15 of 22 comments
Duck Mar 5 @ 2:31pm 
... wow, it actually worked. Good work!

After some fiddling, setting Frame Rate Target Control in Radeon Settings to 60 and setting DoA6 to high performance in graphic settings has been enough to let me play on the stage without an issue.

I'm on R390 and i5-3570K.
Last edited by Duck; Mar 5 @ 4:13pm
Red Mar 5 @ 2:41pm 
All I did to fix the crash was to go to AMD Radeon Settings>GAMING>GLOBAL and change GPU workload to compute. Kinda weird to see a fix that touches so many things but not that one option.
Duck Mar 5 @ 2:45pm 
Originally posted by Red:
All I did to fix the crash was to go to AMD Radeon Settings>GAMING>GLOBAL and change GPU workload to compute. Kinda weird to see a fix that touches so many things but not that one option.

The problem with this solution was that the 'GPU workload' option was only available for certain AMD cards. AMD users with cards that didn't have this feature were SoL until now.
Red Mar 5 @ 2:46pm 
Nice! Completely forgot that some AMD cards lacked that option. Good to know that more people will be able to play this now.
Hued Mar 5 @ 3:05pm 
I am already failing on Step 1. Not finding anything by searching GRAPHICS SETTINGS.
Susvin Mar 5 @ 3:09pm 
there is a chinese guide about this, but is in chinese obviously, since we don't have anyone that can pin this thread maybe someone should made a guide about this fix
Duck Mar 5 @ 3:13pm 
Originally posted by Hued:
I am already failing on Step 1. Not finding anything by searching GRAPHICS SETTINGS.

Right click background -> display settings -> scroll down until you find the link to Graphics settings. At least on Windows 10.
Hued Mar 5 @ 3:25pm 
Originally posted by Duck:
Right click background -> display settings -> scroll down until you find the link to Graphics settings. At least on Windows 10.
:2018bestaward:
LCFX Mar 5 @ 3:38pm 
Tried with Radeon 19.1.1 and from step 8, it works!

Originally posted by Duck:
... wow, it actually worked. Good work!

After some fiddling, it still seems to work even when I'm 1) not using the DPI option, 2) setting Texture Filtering Quality to Standard, and 3) setting Tessellation Mode to AMD optimized.

I'm on R390 and i5-3570K.
So ... using only "Windows 8 compatibility mode" should be enough?
Last edited by LCFX; Mar 5 @ 3:38pm
Duck Mar 5 @ 3:51pm 
Originally posted by LCFX:
Tried with Radeon 19.1.1 and from step 8, it works!

Originally posted by Duck:
... wow, it actually worked. Good work!

After some fiddling, it still seems to work even when I'm 1) not using the DPI option, 2) setting Texture Filtering Quality to Standard, and 3) setting Tessellation Mode to AMD optimized.

I'm on R390 and i5-3570K.
So ... using only "Windows 8 compatibility mode" should be enough?

I did that + set DoA6 to high performance + set DoA6's FPS target control to 60 in the radeon settings.

Edit: It seems that you do not need to set the game to compatibility mode. Still worked when I turned it off.
Last edited by Duck; Mar 5 @ 4:09pm
Hued Mar 5 @ 4:01pm 
Came back to say that there may be a lot of superfluous steps to this. Has anyone tried only doing this?
Tessellation Mode: -Override application settings Maximum Tessellation Level -Off

I did a bunch of troubleshooting and I believe this is the one setting that is actually fixing the crash.
LCFX Mar 5 @ 4:04pm 
Originally posted by Hued:
Came back to say that there may be a lot of superfluous steps to this. Has anyone tried only doing this?
Tessellation Mode: -Override application settings Maximum Tessellation Level -Off

I did a bunch of troubleshooting and I believe this is the one setting that is actually fixing the crash.

I tried every combination, this is the solution, Tessellation Level "OFF" is enough. (Using custom profile for this game with only that change).
Duck Mar 5 @ 4:08pm 
Originally posted by Hued:
Came back to say that there may be a lot of superfluous steps to this. Has anyone tried only doing this?
Tessellation Mode: -Override application settings Maximum Tessellation Level -Off

I did a bunch of troubleshooting and I believe this is the one setting that is actually fixing the crash.

For me, I was able to run with tessellation set to 'AMD optimized' but with Frame Rate Target Control set to 60.

Other than that, only other thing I kept from OP is keeping the setting DoA6 to high performance in graphics options.
Hued Mar 5 @ 4:09pm 
Noticed that sometimes the floor fails to render properly on this stage, so something certainly is up which Team Ninja needs to fix, but at least disabling Tessellation prevents the video card from crashing.
LCFX Mar 5 @ 4:13pm 
Originally posted by Duck:
Originally posted by Hued:
Came back to say that there may be a lot of superfluous steps to this. Has anyone tried only doing this?
Tessellation Mode: -Override application settings Maximum Tessellation Level -Off

I did a bunch of troubleshooting and I believe this is the one setting that is actually fixing the crash.

For me, I was able to run with tessellation set to 'AMD optimized' but with Frame Rate Target Control set to 60.

Other than that, only other thing I kept from OP is keeping the setting DoA6 to high performance in graphics options.

I'm using an AMD RX 470, maybe Tessellation works differently according to the card "generation" ? For now Tessellation Level Off did the trick.
< >
Showing 1-15 of 22 comments
Per page: 15 30 50

Date Posted: Mar 5 @ 1:54pm
Posts: 22