La-Mulana 2

La-Mulana 2

View Stats:
La-Mulana 2 > General Discussions > Topic Details
Cryostasis Jul 30, 2018 @ 2:28pm
PS4 Controller Temporary Solution
Since I doubt I'm the only one having issues with using a PS4 controller to play right now, I've found a temporary workaround that should keep you going until this (hopefully) gets patched.

You'll need a controller to keyboard input mapper (I use Xpadder personally, though I believe Joytokey would work just as well, and is free, ymmv)

Process:
- Open your key bindings file (C:\Users\[Your Username]\AppData\LocalLow\NIGORO\LaMulana2\Config\keyconfig.xml)
- Open keyconfig.xml in notepad and set all elements which fall between <joyname1></joyname1> to null. Just to be perfectly clear, the line should read <joyname1>null</joyname1> in all cases.
- Map all your controller inputs to their appropriate keyboard inputs in Xpadder.

That's pretty much it, hopefully that resolves a headache or two out there.
< >
Showing 1-15 of 18 comments
Eduardo Jul 30, 2018 @ 3:12pm 
You can use Steam's PS4 controller support via big picture mode. Works for me. Are you using Windows 10?
Raeven Jul 30, 2018 @ 3:16pm 
I normally use DS4windows, but here it acted up. So I turned it off completely and went into the steam settings and just enabled the playstation controller support. That's it, that fixed it entirely.
Death of Rats Jul 31, 2018 @ 6:32am 
Originally posted by Eduardo:
You can use Steam's PS4 controller support via big picture mode. Works for me. Are you using Windows 10?

steam's default ps4 mode didn't work when i tried it, how did you get it to work?
Eduardo Jul 31, 2018 @ 7:28am 
Originally posted by Death of Rats:
Originally posted by Eduardo:
You can use Steam's PS4 controller support via big picture mode. Works for me. Are you using Windows 10?

steam's default ps4 mode didn't work when i tried it, how did you get it to work?
I simply turned off all other controller profile software like Raeven said above, and then went into the Steam settings for big picture. Worked like a charm. Using any other profile made the game less playable.
Skipants Jul 31, 2018 @ 8:35am 
This worked well for me, thanks! The controller worked fine until later when I found an item that was impossible to use with the analog stick and needed the d-pad, which the game didn't map properly. So this was a good workaround for that.

Instead of XPadder I just mapped my controller buttons to their corresponding keyboard keys in Big Picture. (Cross -> Z, Square -> X, etc.)

One thing that happened was, I reopened the game and it seemed like some keypad keys got remapped automatically. Either that or I missed a couple "null"s. My character wouldn't stop looking up. I just re-edited the config file and added the "null"s again and it worked. I also added "null"s to "joyname2" blocks for good measure.

Also -- don't forget to backup your original config file. Though I'm sure (I hope) you can delete it and the game will remake it.
Last edited by Skipants; Jul 31, 2018 @ 8:36am
Eduardo Jul 31, 2018 @ 9:12am 
Originally posted by Skipants:
This worked well for me, thanks! The controller worked fine until later when I found an item that was impossible to use with the analog stick and needed the d-pad, which the game didn't map properly. So this was a good workaround for that.

Instead of XPadder I just mapped my controller buttons to their corresponding keyboard keys in Big Picture. (Cross -> Z, Square -> X, etc.)

One thing that happened was, I reopened the game and it seemed like some keypad keys got remapped automatically. Either that or I missed a couple "null"s. My character wouldn't stop looking up. I just re-edited the config file and added the "null"s again and it worked. I also added "null"s to "joyname2" blocks for good measure.

Also -- don't forget to backup your original config file. Though I'm sure (I hope) you can delete it and the game will remake it.
I'm glad you were able to get it to work. That's weird, though. Directional controls work fine here. Sure, they're a tad twitchy, but work.
Mezzo Jul 31, 2018 @ 10:47am 
No controller problems. I don't run any 3rd party software. Just wired in my PS4 controller, put Steam in Big Picture mode. Enabled PS4 controller support. Everything works just fine.
Kitusss Jul 31, 2018 @ 10:56am 
You actually don't even need Big Picture enabled! Just go to Steam>Settings>Controller, make it so Steam sees you have a PS4 controller plugged in (you can even change the light color/intensity), launch the game and it'll work flawlessly.
SamuraiCaveman Jul 31, 2018 @ 11:11am 
I'm not sure if that was related to the problem but my PS4 controller was registered twice in my devices & printers. I uninstalled both and then reconnected the controller so it would only show up once. That by itself didn't fix it but I was then able to create a custom key mapping in the Steam controller settings by assigning all the relevant keyboard keys to the gamepad, which finally let me use it in-game.
Death of Rats Jul 31, 2018 @ 11:33am 
It seems to vary from person to person, because steam recognizes my ps4 controller, other games recognize it perfectly, but when I launch La Mulana 2, nothing. I have to unplug and replug it in in order to get it to 'work', but even then the dpad is still messed up. I'll check and see if it's doing what SamuraiCaveman says theirs was doing though.
Last edited by Death of Rats; Jul 31, 2018 @ 11:36am
Skipants Aug 2, 2018 @ 7:35am 
Originally posted by Eduardo:
I'm glad you were able to get it to work. That's weird, though. Directional controls work fine here. Sure, they're a tad twitchy, but work.

Strange -- it was really messed up for me; my left d-pad was bound to "down/crouch" and my right d-pad was bound to "up/look-up". And I couldn't rebind them in the "System Controls" menu -- I had to use OP's fix.
Kain Aug 3, 2018 @ 2:16am 
Originally posted by Eduardo:
You can use Steam's PS4 controller support via big picture mode. Works for me.
Yeah, its even works with my DS3.
danmaku Aug 3, 2018 @ 8:49pm 
Originally posted by Eduardo:
You can use Steam's PS4 controller support via big picture mode. Works for me. Are you using Windows 10?

It works for me too. Only issue is the controller not working after alt-tabbing or alt-entering
Royal Fool Aug 6, 2018 @ 3:59am 
Originally posted by SpARaeven:
I normally use DS4windows, but here it acted up. So I turned it off completely and went into the steam settings and just enabled the playstation controller support. That's it, that fixed it entirely.
Same here. Had to fiddle with it a bit but it does work.
Lyles Aug 7, 2018 @ 2:22am 
I had problem with steam detecting the controller. So i just install the driver provided with DS4windows ( ScpDriver.exe). After that steam recognized the controller and works flawlessly without any additionnal settings.
I wish we had the abilty to control light color and dim like that with the ps4 !
< >
Showing 1-15 of 18 comments
Per page: 15 30 50

La-Mulana 2 > General Discussions > Topic Details
Date Posted: Jul 30, 2018 @ 2:28pm
Posts: 18