Team Sonic Racing™

Team Sonic Racing™

View Stats:
 This topic has been pinned, so it's probably important
SEGA CUBERZ  [developer] May 21, 2019 @ 7:09am
Bug Reporting Thread – 21st May 2019
Hi Sonic fans,

Team Sonic Racing is out now! We hope you have a great time playing it.

As ever, we've aimed to bring you the best experience possible but if you encounter any bugs or problems, please add them to THIS THREAD.
Adding your system specs will help our QA team identify bugs and squash them as soon as possible (using dxdiag should do the job).

Enjoy Team Sonic Racing and thank you for all your support!

-SEGA CUBERZ
< >
Showing 706-720 of 767 comments
Originally posted by Loop^FoRtUnE <3:
always crashing stopped working on hunted castle in single player

Same can no longer play the game, cannot go beyond stage 4-4! Any ideas anyone?
Originally posted by Loop^FoRtUnE <3:
always crashing stopped working on hunted castle in single player
for this one...try using Sonic...and only Sonic. I also had crashes there...unless I run it as Sonic
Angyworker May 22, 2020 @ 6:20am 
sega is dead. and the movie sucked too
Originally posted by Angyworker:
sega is dead. and the movie sucked too

lol even my son said it was crap
Originally posted by Sylph:
Originally posted by Loop^FoRtUnE <3:
always crashing stopped working on hunted castle in single player
for this one...try using Sonic...and only Sonic. I also had crashes there...unless I run it as Sonic
tried this and still CTD
Crashed May 23, 2020 @ 8:10am 
Originally posted by Jackknife Johnny (>NUTTER<):
Originally posted by Sylph:
for this one...try using Sonic...and only Sonic. I also had crashes there...unless I run it as Sonic
tried this and still CTD
Try verifying game files (via Steam), deleting Denuvo keys (small random number file(s) in Steam\userdata\<your id>\785260\), and updating graphics drivers from the manufacturer's website.
Originally posted by Crashed:
Try verifying game files (via Steam), deleting Denuvo keys (small random number file(s) in Steam\userdata\<your id>\785260\), and updating graphics drivers from the manufacturer's website.

Thanks for helping but unfortunately it didn't make any difference.
Dizzy Cat Jun 9, 2020 @ 11:38am 
I notice a cracked version of the game is doing the rounds, I am curious to know whether removing Denuvo has also alleviated the micro-stutters?
Rings Jun 9, 2020 @ 3:05pm 
Originally posted by Armitage Shanks:
I notice a cracked version of the game is doing the rounds, I am curious to know whether removing Denuvo has also alleviated the micro-stutters?
How do you know denuvo is removed and not simply bypassed?
Crashed Jun 9, 2020 @ 3:09pm 
Micro-stutters are caused by running with uncapped FPS. I've looked at a frame time graph and seen a very steady frame time.

Check out https://www.pcgamingwiki.com/wiki/Team_Sonic_Racing#Laggy_and_stuttery_gameplay for a means to fix it.
Last edited by Crashed; Jun 9, 2020 @ 3:20pm
Dizzy Cat Jun 10, 2020 @ 8:10am 
Originally posted by Rings:
Originally posted by Armitage Shanks:
I notice a cracked version of the game is doing the rounds, I am curious to know whether removing Denuvo has also alleviated the micro-stutters?
How do you know denuvo is removed and not simply bypassed?

No idea mate - just curious.
Dizzy Cat Jun 10, 2020 @ 8:12am 
Originally posted by Crashed:
Micro-stutters are caused by running with uncapped FPS. I've looked at a frame time graph and seen a very steady frame time.

Check out https://www.pcgamingwiki.com/wiki/Team_Sonic_Racing#Laggy_and_stuttery_gameplay for a means to fix it.

Yep - I've played with various v-sync options.
There is something "off" about the game at times.
Without being a technician though, it's really difficult to pinpoint the issues.
I know how to tweak using NVidia CP - but that's about it.
Sieron Satori Sep 18, 2020 @ 7:47am 
Apparently, the music at the intro is playing at... 2x speed, 2.5x speed, or 3x speed.
The video is at normal speed though.
Crashed Sep 18, 2020 @ 8:49am 
Originally posted by Sierota Satori:
Apparently, the music at the intro is playing at... 2x speed, 2.5x speed, or 3x speed.
The video is at normal speed though.
Try setting your Windows audio rate to 48000.
Sieron Satori Sep 18, 2020 @ 11:23am 
Originally posted by Crashed:
Originally posted by Sierota Satori:
Apparently, the music at the intro is playing at... 2x speed, 2.5x speed, or 3x speed.
The video is at normal speed though.
Try setting your Windows audio rate to 48000.

Ah. Thank chu. It was set to 96000 Hz.
Woopsies.
< >
Showing 706-720 of 767 comments
Per page: 1530 50