Bejeweled 3

Bejeweled 3

View Stats:
Bejeweled 3 > General Discussions > Topic Details
Toff Sep 2, 2013 @ 5:29pm
[Solution] No 3D acceleration in Windows 8+
In order to have the game use 3D acceleration natively without the files below, your display resolution must be equal to or above 1600x1024. If your monitor does not support such resolutions, read below:

The lack of proper hardware acceleration for DirectDraw in Windows 8 causes Bejeweled to only work in software mode saying that your graphics card is unsupported when you try to enable 3D acceleration. Here's how to make it work in Windows 8+:

1. Download the latest version of WineD3D from here[fdossena.com].
2. Unpack the following 3 files from the archive into the game's installation directory
- ddraw.dll
- libwine.dll
- wined3d.dll

Enjoy. :B1:

Since WineD3D is in active development, the latest version may contain bugs. In that case, older versions might work better for you depending on your card. For Nvidia users 1.7.52 was the stable release, AMD users reported 1.9.21 worked for them.

Files in the archive are compiled from the latest WineD3D DirectDraw Library. This is essentially a DirectDraw emulator that translates DirectDraw calls to OpenGL.
Last edited by Toff; Mar 27 @ 12:52pm
< >
Showing 1-15 of 77 comments
N0quarter Oct 6, 2013 @ 8:25am 
It doesn't work man =/ I just get a freeze.
Toff Oct 6, 2013 @ 9:00am 
I edited the first post. Apparently it's broken for AMD cards, but I believe earlier versions should work just fine for Bejewelled, try it.
N0quarter Oct 6, 2013 @ 1:17pm 
=/ With 1.3.30 and 1.3.31 I get: "This app needs DirectX to run". With 1.6 it crashes. Anyway thanks for trying to help me.
[GC]Vole Oct 20, 2013 @ 10:08am 
Nope, not working here either. win7, gtx 550ti. doesn't crash but still says 3d can't be enabled as i don't meet the minimum requirements

thanks OP for trying.
Dean Demon Oct 21, 2013 @ 3:34am 
Originally posted by GCVole:
Nope, not working here either. win7, gtx 550ti. doesn't crash but still says 3d can't be enabled as i don't meet the minimum requirements

thanks OP for trying.
This used to be the case with some drivers around a year ago, recent drivers have solved the issue as i used to get the same thing happen to me, i'm running W7 Pro 64 bit GTX 650 Ti Boost and driver 331.40 and works great.
SandsOfArrakis Nov 2, 2013 @ 5:00am 
Running the game on Windows Pro 8.1 64-bit with a Radeon 6650M on my laptop. Game runs with 1920x1080 res and all options, including hardware acceleration, enabled :)

It uses the 9.12.8.0 driver version, dated 11-2-2013. Digitally signed by Microsoft.
Toff Nov 2, 2013 @ 5:21am 
SandsOfArrakis, just to confirm, are you using the files provided in the first post?
Last edited by Toff; Nov 2, 2013 @ 5:41am
N0quarter Dec 29, 2013 @ 7:33pm 
hey wanted you to know that with 13.12, I'm playing the game perfectly now, with 3D acceleration and everything. FIrst uninstalled drivers, then passed Driver Fusion.
Illiuminatum Mar 8, 2014 @ 9:31am 
It fixed it for me, W8.1 Pro, GTX 780 here :)
DeviantXS Mar 8, 2014 @ 11:54am 
I can't get it to work, I tried literally everything. Including installing beta drivers and rolling back to the original. The game simply refuses to load up my GPU. Which is an AMD Radeon HD 7600 Series.
bfRheostat Mar 8, 2014 @ 2:35pm 
Unfortunately, that trick doesn't work for me. Thank you for your effort. :happy:
Last edited by bfRheostat; Mar 8, 2014 @ 2:35pm
SpaceGoat Mar 11, 2014 @ 12:07pm 
I also can't get this to work. AMD 7670M with latest beta drivers.
bfRheostat Mar 11, 2014 @ 6:12pm 
Razzile, If you see an error report window constantly, use compatibility modes to open the game somehow (one of them done the trick on my rig), check the resolution (it have to be 800x600, mine was 1024 and it wasn't even 1024x768 in fact), and switch the graphics mode to windowed and never ever touch the graphics options again (until 3D acceleration problem solved -however, probably they won't patch the game).

So many paranthesis usage, right? :D::sweat:
Last edited by bfRheostat; Mar 11, 2014 @ 6:13pm
SpaceGoat Mar 11, 2014 @ 11:09pm 
well I fixed the fatal error window by opening regedit > HKEY_CURRENT_USER > Software > SteamPopCap > Bejeweled 3. I then edited the value ScreenMode from 0 to 1 and I haven't had any crashes since. I still can't enable 3D mode or high graphics however :/
bfRheostat Mar 11, 2014 @ 11:23pm 
And they want 20 bucks for this game. I'm happy to obtained it with a convenient price.
< >
Showing 1-15 of 77 comments
Per page: 15 30 50

Bejeweled 3 > General Discussions > Topic Details