View Stats:
BioShock > General Discussions > Topic Details
Fanta Nov 1, 2012 @ 12:16pm
Fix for Bioschock crash on start on OLEAUT32.dll
If like me you see the game crashing on start, with the signature here below, first thing to try is to plug a jack in the microphone, and start the game again. It worked for me, no need to install anything else.

Problem signature:
Problem Event Name: APPCRASH
Application Name: bioshock.exe
Application Version:
Application Timestamp: 474f5a3a
Fault Module Name: OLEAUT32.dll
Fault Module Version: 6.1.7601.17676
Fault Module Timestamp: 4e58702a
Exception Code: c0000005
Exception Offset: 00004971
OS Version: 6.1.7601.
Locale ID: 1040
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

Read our privacy statement online:

If the online privacy statement is not available, please read our privacy statement offline:
< >
Showing 1-15 of 23 comments
ManoBird Nov 12, 2012 @ 12:13pm 
WTH?? it actually worked D: Thank you pal!
Cheqers Nov 15, 2012 @ 7:43am 
Wow! Thankyou so much Fanta! I can't believe that of all things worked!
SeymourSan Nov 17, 2012 @ 3:27pm 
Great fix, thank you for that!
Fanta Nov 19, 2012 @ 12:32pm 
You are welcome
timX34 Nov 20, 2012 @ 5:26am 
WTF !!! that really work (@)_(#) !!! thank you fanta, you're so fanta-stick lool

EDIT : the problem is we always need to put a jack in microphone, or lose all setting of game :( that so bad
Last edited by timX34; Nov 20, 2012 @ 5:32am
Theokritos Nov 25, 2012 @ 3:14pm 
Thank you for the work-around. Do you know if the vendor is working on a patch to actually fix this issue so folks can play the game without a plug in the microphone slot?
Silent_Cover Mar 1, 2013 @ 5:48am 
Thankyou!Great Help!
mradtke Mar 20, 2013 @ 11:25am 
Thank you for Help.
FrickYeahWhatShutUp Mar 24, 2013 @ 11:17pm 
Thanks heaps!
[1929]Schematic May 3, 2013 @ 7:46pm 
Wow, amazing thanks. It even works with my USB combo mic/headset. Nonetheless, would be great to get this actually fixed...
sandrante1 May 6, 2013 @ 3:01am 
thank u for this great trick!
didn't know what to do, i already contacted 2k support and everything...
Killhunger May 9, 2013 @ 1:34am

What it says:

Bioshock is crashing to the desktop on Windows 7 and Windows Error Reporting says the faulting module is OLEAUT32.dll. How do I fix this?

The solution is to navigate into the Steam files, find the Bioshock.exe and run it in compatibility mode for Vista SP 2. Running it in compatibility mode for any other version of Windows has no effect.
Drama King Mar 22, 2014 @ 8:35am 
Holy♥♥♥♥♥♥ I don't know how can it be, but it works!
TopShelfSniper Mar 26, 2014 @ 5:12pm 
LMAO..that worked for me too. I have had this for over a year, and played it once. Probably had headphones on too. Thanks!!
dHeat Aug 25, 2014 @ 7:39pm 
Can't believe it actually worked. How can something so simple mess with such great game. Thanks.
< >
Showing 1-15 of 23 comments
Per page: 15 30 50

BioShock > General Discussions > Topic Details