BioShock

BioShock

View Stats:
BioShock > General Discussions > Topic Details
macol90 Oct 24, 2012 @ 11:38pm
Fix Bioshock crashes in Windows 7 x64 - Works for a lot of people!
After trying a bunch of "compatibility" solutions in Windows 7, I found that disabling all other audio "Playback" devices, except for my main speakers, worked like a charm!

I'm sharing this because I found this solution on another site and the post went through a long list of things to do, including changing .ini files! A lot of the users agreed it worked but I figured "what if it's just a hardware issue and Bioshock is just getting confused?"

Go to: Control Panel -> Sound -> "Playback" tab -> Right click on any devices not connected to your main speakers -> Disable

You can re-enable them at any time, but more than likely you never use them. For me the culprits were my SB Audigy "Digital Audio Interface" (I don't have digital connectors to my speakers, but you might!) and "NVIDIA High Definition Audio", which is connected to my TV but I never use anyway...

I hope this helped!
Cheers!

PS - Some say that this only works if you start a new game... it's worth a try!
Last edited by macol90; Jun 26, 2015 @ 3:15am
< >
Showing 1-15 of 31 comments
Zakk Oct 27, 2012 @ 3:08pm 
IT HELPED AND IT WORKED !!!! THANK YOU SO MUCH :D *
willow625 Oct 29, 2012 @ 9:31pm 
It worked for me too. :-)
Verdigris Oct 30, 2012 @ 1:41am 
I will try this next time I load it up, but since my main speakers are my tv, that feels a little wonky. Hopefully this will pay off! I gave up in frustration trying other things before coming here.
macol90 Oct 30, 2012 @ 2:57am 
I'm happy to see this is helping some people! I hope more post positive results.

I should have made the subject line less specific because I'm sure this will work in other versions of Windows 7. Maybe even Vista!

@CooperM - Keep in mind that this should apply to whatever device is connected to the speakers being used to play the game. They'll probably be connected to the device labeled "default". Keep in mind that disabling other devices is temporary. In most cases you can re-enable them without restarting.
BlckEagle89 Oct 31, 2012 @ 11:05pm 
in the case that the problem remain, disabled the HDMI in stereo in case that you have one, taht worked for me
jjonman Dec 11, 2012 @ 9:15am 
Thank you for this. It worked for me. I use my tv as my monitor/speakers so I just disabled everything except hdmi audio and the game booted up instead of giving me the Bioshock.exe crash error.
I am on Windows 8 Pro x64.
THIS DID NOT WORK for me. HOWEVER i did find a SOLUTION THAT WORKS for me
http://www.consideritfixed.com/2009/10/how-to-run-bioshock-with-windows-7.html
basically try running it in windows vista compatibility mode. :) :)
M.I.R. Dec 15, 2012 @ 2:24pm 
No solution working for me. I bought it some time ago in action with thought on playin it on new PC. Now I have new PC and Bioshock freezes even before menu. And when I get to the menu, it freeze on the load. It sucks :(
Win7 64-bit, Core i5,GB, GT650M.
Nik Dec 16, 2012 @ 11:05am 
Originally posted by M.I.R.:
No solution working for me. I bought it some time ago in action with thought on playin it on new PC. Now I have new PC and Bioshock freezes even before menu. And when I get to the menu, it freeze on the load. It sucks :(
Win7 64-bit, Core i5,GB, GT650M.
У меня абсолютно такая же проблема. Игра зависает на меню или во время загрузки. Ни один из предложенных вариантов не помог.
у меня Win7 64-bit, Core i5, GT630M.
Verdigris Dec 16, 2012 @ 6:50pm 
I did have some issues still but it seems to be working fine if I pipe my sound through headphones. Just gotta remember to not play alone at night in the dark.
M.I.R. Dec 17, 2012 @ 4:32pm 
I tried it with laptop speakers, headphones, 5.1 speakers through jack, with bluetooth audio... I tried disabling all the devices. I tried literarly everything. Now I deleted the game. Don't have patience for this..
101truk Dec 21, 2012 @ 6:38am 
DUDE YOUR THE BEST !! followed your instructions ( windows 8 ) and my problems was SB Audigy "Digital Audio Interface also , THANX MAN !!!!
[BAWS] Trotsky79 Mar 16, 2013 @ 4:54pm 
This helped!! Thanks man.
Raskitoma Mar 18, 2013 @ 9:18pm 
Hey guys, this is the real solution!!! It worked for me (windows 8 pro x64)
Raskitoma Mar 18, 2013 @ 9:19pm 
BTW it would be great if some mod or op make this part of a sticky post or something like a solution post!!!!
< >
Showing 1-15 of 31 comments
Per page: 15 30 50

BioShock > General Discussions > Topic Details