Majesty Gold HD

Majesty Gold HD

View Stats:
Is Majesty Gold HD this slow?
Can't remember when I played years ago the original one that it was so slow! I'm playing at 1 fps with default speed and 2 fps with max speed game in my i7 with Windows 8.1 aside from the crashes, had 2 in a hour of gaming. There's any fix to that?
Last edited by Durma bem, Prince o Gato; Oct 10, 2014 @ 10:06am
< >
Showing 31-45 of 49 comments
Thraka Dec 1, 2014 @ 11:55am 
I can't do that though, alt-tab causes the game screen to get messed up :(
Two Gun Bob Dec 24, 2014 @ 8:56pm 
It worked for me just by starting in window mode (using parm -w).

For those looking for an easy way, in your steam library right click on the game. Choose properties. a pop-up box should appear. Near the bottom of the General tab, click the button to Set Launch Options. In the text box, type in your exec parameter. I only used -w and it was much improved. You can also try the suggestions from earlier in this thread, -useddblit
and -blitmovietobackground. Be sure to use the dash. Steam will keep those until you change them. Praise Gaben.
evilstormer Jan 24, 2015 @ 8:46am 
Hi guys, I run Windows 8.1 x64 on AMD FX 6 core CPU, AMD GPU. Had this terrible slow game speed either. All the startup parameters did not work for me, and I didn't even check the windowed mode because I loathe it.

HOW I FIXED IT:

0) I did NOT use affinity to one CPU only
1) edited Documents\My Games\MajestyHD\MajXPrefs parameter PixDepth from 16 (16 bit is ugly!) to my actual Desktop Bit Depth, which is 32 in my case.
2) ???????
3) PROFIT!

Even Alt-Tab switching to desktop works fine and doesn't kill the colours now.
Hope it helps.
Last edited by evilstormer; Jan 24, 2015 @ 8:54am
Thraka Jan 24, 2015 @ 10:09am 
AHHHHHH!!! Thanks for pointing out that file... For me it's not just that setting. That setting does increase the speed a bit but playing full resolution for me 1920x1080 (native) is still very slow.

This combination worked for me:
  • PixWidth/PixHeight match native resolution (use the in game changer if you want, if you do that, PixDepth will be reset to 16 and you'll need to change the config file again)
  • PixDepth 32
  • BlitMode 1
  • IntroVideo 0

I think there is definitely something with the intro videos being on that screws it up. Maybe because of the resolution shift in showing videos at the 600x800 or whatever it is, and then going to the game resolution. This combination makes the characters zoom all around the screen when I have the game at full speed.

I tried every combination to see if it is a specific setting, for me, all of these settings makes the ultimate difference.
Last edited by Thraka; Jan 24, 2015 @ 10:12am
Nyx Mar 12, 2015 @ 9:53pm 
Originally posted by Volk Thraka Neo:
AHHHHHH!!! Thanks for pointing out that file... For me it's not just that setting. That setting does increase the speed a bit but playing full resolution for me 1920x1080 (native) is still very slow.

This combination worked for me:
  • PixWidth/PixHeight match native resolution (use the in game changer if you want, if you do that, PixDepth will be reset to 16 and you'll need to change the config file again)
  • PixDepth 32
  • BlitMode 1
  • IntroVideo 0

I think there is definitely something with the intro videos being on that screws it up. Maybe because of the resolution shift in showing videos at the 600x800 or whatever it is, and then going to the game resolution. This combination makes the characters zoom all around the screen when I have the game at full speed.

I tried every combination to see if it is a specific setting, for me, all of these settings makes the ultimate difference.

This works as a charm on my Win 8.1. Thanks!!
mafilux Apr 23, 2015 @ 11:39am 
I used to have an issue with Starcraft, that had to do with the explorer itself, so this solution may work with Majesty as well.

Open notepad, type in:

taskkill /f /IM explorer.exe
C:\"Program Files (x86)"\steam\steamapps\common\"Majesty HD"\MajestyHD.exe
explorer.exe

and then save it as Majesty.bat. Make sure that it doesnt save as Majesty.bat.txt

Double click this file to run the game and see if it works!

This is a colour fix for Broodwar, but if it is a graphical bug it might work here too. After you close the game, there may not be a desktop. To rectify this open the task manager (CTRL+alt+delete) and right click on an open space under applications, and then click new task. Then simply type in explorer.exe and press enter and your desktop will resume as normal The last line "explorer.exe" in the file should re open the explorer automatically however.
Last edited by mafilux; Apr 23, 2015 @ 11:51am
Thraka Apr 23, 2015 @ 1:35pm 
My solution should work fine. I've done it for a few friends and they all run good now. Remember this is some sort of enhanced version of the exe, it's not the exact exe from the old version. So that old explorer bug with age of empires and starcraft shouldn't apply here.
Last edited by Thraka; Apr 25, 2015 @ 1:01pm
mafilux Apr 23, 2015 @ 6:10pm 
Originally posted by Volk Thraka Neo:
My solution should work fine. I've done it for a few friends and they all run good now. Remember this is some soft of enhanced version of the exe, it's not the exact exe from the old version. So that old explorer bug with age of empires and starcraft shouldn't apply here.

Yeah, just thought I'd throw it in here in case it does help some one out.
Wartom May 10, 2015 @ 1:32am 
This happens to me too. For some reason this works for me: Start the game, start a map, let the game run for about 10-15 minutes. Everything will then eventually speed up normally. The game should now work as it should until you quit the program.
【TOFU】 Jun 6, 2015 @ 6:33pm 
For those playing on a laptop with nvidia graphics card and failed to solve the problem of slowness even after have done what [Volk] Thraka [Neo] said. I solved the problem doing what [Volk] Thraka [Neo] said AND disabling nvidia graphics card in the device manager, leaving only the integrated card. In my case it solved. I hope it works for those who were unable to solve this problem! The game is now running perfectly on full screen in Windows 8.1. Thank you very much for your help [Volk] Thraka [Neo] and to all who have worked to help!
Thraka Jun 7, 2015 @ 1:16pm 
Roes, the NVIDIA control panel has the ability to force integrated or nvidia based on the program you run. You should never have to disable it in device manager. Just configure it specifically to run the integrated graphics whenever you run the majesty executable.
Last edited by Thraka; Jun 7, 2015 @ 1:17pm
Ravage1505 Sep 26, 2015 @ 3:34am 
Originally posted by ziembus:
I have found a solution. TYou have to make the game use only one core of your CPU. After you start the game, open up the task manager, go to details, find majestyHD.exe, Right Click it, select "Set Affinity" and choose only "CPU 0". Turn off everything else. After that the game is Blazing fast. Enjoy!

This worked really well for me on Win10 -- game was stuttering until I tried this. Thanks Ziembus
Originally posted by Ravage1505:
Originally posted by ziembus:
I have found a solution. TYou have to make the game use only one core of your CPU. After you start the game, open up the task manager, go to details, find majestyHD.exe, Right Click it, select "Set Affinity" and choose only "CPU 0". Turn off everything else. After that the game is Blazing fast. Enjoy!

This worked really well for me on Win10 -- game was stuttering until I tried this. Thanks Ziembus
Also worked for me on Win10 -- games were starting out at normal speed, but as soon as the first wave of monsters spawned it would always slow to a crawl. Now with CPU 0 only there are no issues. Thanks Ziembus.
Metalsand Mar 31, 2016 @ 7:53pm 
I haven't seen anyone mention steam overlay, but for my case, I used
-useddblit -blitmovietobackground as the launch parameters, but I did not have a framerate fix until I disabled the Steam overlay option (and the VR Theatre one just to be safe).
Last edited by Metalsand; Mar 31, 2016 @ 7:53pm
Dorgath Apr 1, 2016 @ 6:59pm 
That's because the Steam overlay is fairly recent (and I think only with beta).
< >
Showing 31-45 of 49 comments
Per page: 15 30 50