The Elder Scrolls V: Skyrim

The Elder Scrolls V: Skyrim

View Stats:
Nax_o Sep 13, 2013 @ 5:16am
Dragonborn complete - surrounded by annoying green cloud [SOLVED]
Plotline completed for Dragonborn. Apparently i got myself some kind of active effect that surrounds my character in a constant green cloud that looks like flies. Apparently a 'blessing' from the god of knowledge.

Anyone know what this is? i want to get rid of it as it's destroying my game experience completely. I have checked whatever items or blessings i have and made changes but i can't figure out what this is.
Last edited by Nax_o; Sep 14, 2013 @ 12:58am
< >
Showing 1-13 of 13 comments
Vahlok Sep 13, 2013 @ 5:21am 
I'm not sure, but that sounds like the Ebony armor you get as a reward from some Daedra quest. If that's the effect I'm thinking of, it's a poison cloud effect, but it's supposed to show up when you're sneaking.
Nax_o Sep 13, 2013 @ 5:23am 
Not that. use my own made armor sets.

hmm... The graphic 'look' of the cloud is that of Hermaus Mora. i think i got it after selecting a perk after reading a black book. But thats as far as i know. I have now re-arranged those perks by going back to the Hermaus Mora worlds but it did not have any effect.
Vahlok Sep 13, 2013 @ 5:37am 
Can you craft your specific armor again? Sounds like you have the skill/perk to do so.
I don't know if you have already tried that. Also the blessing I got from Hermaus Mora was the one for might. So none of those effects ever showed up and I'm guessing you probably chose a different blessing. The thing is, I got to use the black book only once, then it vanished.
**oh, the ebony armor reward comes from Boethia quest where you have to kill a follower then kill the champion who's wearing it**
Last edited by Vahlok; Sep 13, 2013 @ 5:39am
Nax_o Sep 13, 2013 @ 5:43am 
Yes i can. but shouldn't the armor related blessings be gone when i change set?. i recently changed from my Light dragon set to another one to test it so it shouldn't be armor set related.
Vahlok Sep 13, 2013 @ 5:54am 
It sure seems if you change armor set that the effect would be gone. But, if for some reason the effect seems to be attached to you directly and not your armor then I don't know what that would be. Except probably that your character has been poisoned and that's the effect I recall getting from time to time. But it never lingered on me.
If I were in such a situation, I'd go to one of the shrines to be cured of it .. that is assuming the blessing can remove it which they normally do. But if you're still stuck with the effect, it's leading me to think it's a glitch tied to the mod.
Nax_o Sep 13, 2013 @ 5:55am 
Used cure disease. Checked active effects -> basicaly the perks i took from the black book missions are there. they can be re-aligned but not removed. hmm...
Vahlok Sep 13, 2013 @ 6:06am 
Using a cure disease potion doesn't work in some cases (such as vampirism). Well that's how it was for me. I had to get to a shrine to remove it.
But if your effect is attached to you because of the black book and you really need to get rid of the effect ... I would suggest reloading your game to a time previous to getting the blessing and try a different blessing.
IF going back doesn't remove the affect, then it is a glitch in the code that's been overlooked.
The book itself should have only been used once, then vanish. That's what it did with me and I don't run any mods. The blessing was a "one time good deal".
Last edited by Vahlok; Sep 13, 2013 @ 6:07am
Nax_o Sep 13, 2013 @ 6:09am 
Can't go back as it's so long ago. It took me awhile to understand that the cloud is permanent.

I do run mods (realistic battles) so maybe that's what causing it.
Vahlok Sep 13, 2013 @ 6:18am 
Originally posted by heikkito:
Can't go back as it's so long ago. It took me awhile to understand that the cloud is permanent.

I do run mods (realistic battles) so maybe that's what causing it.

I realize that reloading an earlier time is a pain in the keester, because I have neglected to get to a shrine before becoming a full blood vampire. I didn't want that situation hindering me so I reloaded an earlier time and lost something like 4 or 5 levels of experience. That was a lot of game time to me.
Since you're running mods, I don't know what kind of negative affect that's going to have on your progress or your game. I once considered using mods, but when I read about the diverse problems people are having with them (for various reasons), I chose not to use them.
Nax_o Sep 13, 2013 @ 12:40pm 
Here is a screenshot of what it looks like. I am stumped at what this is and how to get rid of it.
Vahlok Sep 13, 2013 @ 3:07pm 
Well, that's not the effect I visualized. It does look like a spriggan swarm.
wowszer Sep 13, 2013 @ 3:55pm 
Follow grimus's advice, there is a link by Master Dan. Very good advice in there. Thatvtype of effect can vary btw, sometimes just eyes are affected for example.
Last edited by wowszer; Sep 13, 2013 @ 3:56pm
Nax_o Sep 14, 2013 @ 12:58am 
opened up the console and hit 'player.addspell 9aa38' and then 'player.removespell 9aa38'

That finally did it.

Wow. It's been awhile since i was able to marvel the beauty of this game without having something floating around in my view.

Thanks for the help. i did not even know what to look for when trying to solve this!
< >
Showing 1-13 of 13 comments
Per page: 15 30 50

Date Posted: Sep 13, 2013 @ 5:16am
Posts: 13