The Elder Scrolls V: Skyrim

The Elder Scrolls V: Skyrim

Statisztikák megnézése:
Geck/Creation kit Help!
I tried to edit HH .45 auto ammo into the wasteland, and i have this mod, called "dlc weapon integration", which adds the .45 auto pistol ( this is the weapon im having problems with) to npcs, along with ammo to them. I edited a weapon package i believe is called: "dlc02 with ammo .45 auto pistol, and i just wanted the ammo in containers, not the weapons, or caings, so i deleted both from the package, leaving only .45 auto ammo in it. This was pretty stupid, since the enemies ( or allies) that are supposed to have this gun, spawn unarmed, and on their corpse they have .45 ammo, but again, no ammo. Is there any way to undue this, since my esp. has been saved? i need help, and there are no tutorials or video on lev. items and lists, so i ♥♥♥♥ed up, big time. im sorry that i posted on skyrim discussion, but i posted both on nexus forums, and FNV forums and in a week ive yet to get any reply. The creation Kit functions very similarily so anyone knowlegeble in both, or just one of these kits would help me tremendously!
< >
18/8 megjegyzés mutatása
Luckily for you, I know both gecks and the Skyrim creation kit quite well. From your description of the problem it sounds like you altered an item list and not actually deleted the weapon from the game.

Many actors and containers often refer to the same levelled items list. Altering one would cause the effect you described.

Unfortunately the gecks undo feature is pretty limited, but if you can find the levelled item list you altered it should be as simple to fix as opening it and dragging the missing item from the weapons list back into it...

I hope that helps
Legutóbb szerkesztette: {NOC}JURY; 2013. jún. 13., 16:37
yes it does, thank you. So do you think i should just add the weapon to the same aforementioned leveled item list as it previously was? i dont want to do any other ill effects by "dragging" the standalone weapon to another lev. list. Would it delete the standalone ( in the sense that no other items besides the weapon itself is in it) weapon? or should i "copy" the weapon to the missing one? how does "dragging" work?
Dragging the item back into the list will effectively just undo your original change by restoring the list. (Although it’s not recommended best practice as you leave the files in a dirty state. But that’s only relevant if you do a tonne of modding)

To do this, find the levelled item list you changed (using the same method you used before) and open it

Then, in the object window, expand the items list then the appropriate weapons object list (from memory I think that should be the weapon1h object list in NV, it might not be that but you should find it easily enough just looking through the various weapons sub catigories)

Find the weapon you’re looking for then simply left click and drag it into the list window you opened earlier (just like moving a file in windows)

This will only have the effect of making the item reference appear on the levelled item list. It will NOT move, or otherwise effect the weapons route file.

once you've done this, save the esp, and things should be back to normal.

Have Fun XD
Legutóbb szerkesztette: {NOC}JURY; 2013. jún. 13., 17:11
ill try that, and post results back here.
what do you mean by "dirty state"?
i tried it, and saved, but i tested it in-game, and it didnt seem to work. it seems that the changes i made were not saved. i should have maybe made my ammo integration plugin the active file instead of the mod. No idea what happened.
hi, files are recorded as being in a "dirty state" when a change has been recorded even when no actual change has occurred. These should be avoided as they can cause conflicts between mods. (But that unlikely to happen in this case)

You need to set the esm with the error in as the active file & ensure that you are editing the correct levelled item list as before to get the weapon back in. if you have another esm that does the same thing, you will have to do it on that one as well

If you want to add a container that has just ammo in, you will need to remove the levelled item list at the containers top level and place a loot ammo levelled item list in at that same level.

Its probably safer to create a new container and place an levelled ammo loot list within it and place it into the game through the world editor.

I hope that helps
i thought you couldnt set esm as an active file, only .esps. i made the changes to the correct list, to my screwed up plugin and the mod plugin, and it still wont appear. The thinh is that i am stationed outside of bonnie springs, to test it, and one of the guys only spawns with the .45 ammo, even after changes. Should i wait a few in-game hours for leveled item list to refresh, or is the screw-up stuck in my save game?
< >
18/8 megjegyzés mutatása
Laponként: 15 30 50

Közzétéve: 2013. jún. 13., 15:58
Hozzászólások: 8