The Elder Scrolls V: Skyrim

The Elder Scrolls V: Skyrim

View Stats:
Ilja Mar 22, 2015 @ 10:28am
Help thread: Creation Kit\Workshop update problem
About the problem

There was a Creation Kit\Workshop update that raised the size limit from mods in Skyrim Workshop. This has messed up mod subscriptions and caused problem among players.

Skyrim version itself has not been changed and there have not been changes to Skyrim gaming engine. Mod problems with other sources than Workshop are not related to Creation Kit\Workshop update.

What happened during the update?
  • The previous size limit of mods was lifted. Workshop can now handle larger mods than before.

  • Managing of Workshop mods was changed from Skyrm launcher to Steam.

  • New: Steam had previously changed it's API. Skyirm was still using the old API function and Bethesda moved to fix the matter, as expected by Steam.

  • New: Current version will support master files being uploaded to Workshop.

  • New: Unofficial patches are now available in Workshop.

Moving mod managing from launcher to Steam seem to be the main reason causing problems to games that use mod subscription from Workshop. Your old subscriptions are pointing to wrong location and need to get directed properly.

Try this first

Refresh Your Steam Files
https://support.steampowered.com/kb_article.php?ref=3134-TIAL-4638&l=english

Do this to fix the possible probelm with Steam client update
- From Steam client: Steam > Check for Steam Client Updates...
- Restart the client.

Do this to fix the Workshop subscription problem
- Favorite mods you had been subscribed to, or write them up.
- Unsubscribe from all your mods in Skyrim Workshop.
- Open your default launcher Data Files view and delete all Skyrim Workshop mods from there.
- Subscribe to your mods again. Make sure that you subscribe to all mods that you had in your ongoing game, or your save may not work properly.
- Run LOOT to sort your load order.

LOOT
https://loot.github.io/

0 byte downloads?
Arthmoor has presented a fix for that in here.

[Skyrim] Fixing Phantom Workshop Downloads AFK Mods
http://afkmods.iguanadons.net/index.php?/topic/4251-skyrim-fixing-phantom-workshop-downloads/

If Workshop lacks mods from your list
See if they are available in Skyrim Nexus. Game does not know or care where the script data is coming from, as far it is there.

Skyrim Nexus - mods and community
http://www.nexusmods.com/skyrim/?

If you are unfamiliar with Nexus, then see the playlist below.

Nexus Mod Manager: Beginner's Guide (YouTube playlist) by Gopher
https://www.youtube.com/playlist?list=PLE7DlYarj-DdGbu7-Chui4ZQuZZCGbpWl

If missing mod data is not found from Workshop or Nexus
- If missing mod was not using scripts, then you can likely keep playing your game.
- If missing mod was using scripts, then it is recommended that you start a new game.

Trouble after you have parsed missing data
- Backup your save files.
- Use this tool to clean your save. Follow instructions from the description page and do not do anything else.

Save game script cleaner by Hadoram
http://www.nexusmods.com/skyrim/mods/52363/?

If you are unsure what to do, then ask from below. Please be patient, if you do not get answer right away. Someone will try to help you eventually, but we can't be here 24/7. :)

Resources
I have also made a blog post about this matter. It may be more clear than this troubleshooting post. I was urged to raise it from comments to OP, so here you go.

Blog post: State of Skyrim Workshop
https://iljasuvanto.wordpress.com/2015/07/06/state-of-skyrim-workshop/

Credits
- Trigger, who reminded that using the Favorite is a good way to track mods you had subscribed to.
- Roscaria, for pointing to the Client update.
- grimus, for keeping the coffee pot hot.

Changes
15.07.2016
- Renamed, because Steam censored short term for Creation Kit.
06.02.2016
-- Fixed: Bunch of typos. English is not my first language. You guys should really point out, when I make mistakes.
01.02.2016
- Added: Chapter "Try this first" and link to steam://flushconfig instructions
- Removed: Chapter "Community request" as obsolete.
15.01.2016
- Updated post, removed old data, added links and cleaned the look. Problem is still unsolved.
Last edited by Ilja; Jul 15, 2016 @ 7:39am
< >
Showing 1-15 of 308 comments
men_1970 Mar 22, 2015 @ 12:27pm 
Thanks for the post. Maybe I'll try the tip with just the mods that keep getting dropped - at least until I'm done with my current playthrough. I have a lot of mods...
Ilja Mar 22, 2015 @ 1:02pm 
We have had many questions about this during last days. I thought it best to write a solid post about it.
Nazenn Mar 22, 2015 @ 9:59pm 
Side note/mini rant : Bethesda should have made this thread instead of making a singular tiny post in one singular thread out of the hundreds that have been made since the update.

Main point: THANK YOU very much Ilja for putting the work that you do into the community and making sure that this sort of information does actually get spread around and is easily accessable.
Ilja Mar 23, 2015 @ 1:13am 
It was late and I did few silly typos there. Hopefully I fixed them.

My original advice was to write up subscribed mods. In one thread, Trigger popped in and told peoples to use Favorite- button instead. And I felt silly. :D

Nothing to add here. I am basically just bumpin the post a bit, because problem still seems to remain.
MorevalaR Mar 23, 2015 @ 4:20am 
Still non of the advices from above doesn`t helped to me..
I deleted all mods and resubscribed them, but they download and don`t install. Not appeared in the list..
Uncle64[SwE] Mar 23, 2015 @ 4:41am 
I did se one thing.
If you have mods inactive and dont use them, the game/steam or what ever. Can activate those mods you have inactivated.
Strange since it was some mods that are not from Workshop.

And one Bump, nice post Ilja :)
Savick Mar 23, 2015 @ 9:19am 
I did this before seeing this post and it took a couple of hours to sort it all out. I'm glad to see someone is helping with the problem. I had problems with both my Workshop and Nexus mods. I use SKSE to launch the game so I didn't see that my mods wern't updating. It caused a lot of problems with my Nexus mods load order because the patch checked them off in the Data Files. Anyway, my level 47 character got really wonky and now I'm having to go back to a much earlier save. But all is good now. I only wish there had been some sort of warning about all of this. It would have saved some heartache for some players.

On a good note. Looking at all my "Favorited" mods allowed me to see some that I had a while back that I loved but took out because of other mods. Anyway, I have a couple of them back in now.
MorevalaR, you might want to try a 3rd party Mod Organizer to enable the mods. The following webpage has 2 (two) downloads, NMM and MO :
http://www.nexusmods.com/skyrim/mods/1334/?tab=2&navtag=http%3A%2F%2Fwww.nexusmods.com%2Fskyrim%2Fajax%2Fmodfiles%2F%3Fid%3D1334&pUp=1
  • NMM, Nexus Mod Manager, is the one found in the top row of any page on the Nexus, "Install NMM (0.53.7)".
  • While this specific page is about the Mod Organizer made by one of the modders.
If the Steam Launcher keeps on disabling the mods annyway, a workaround is to install SKSE of which the launcher skips that first loadingscreen where Worshop Mods are checked (Unchecked in this case). You can find it at http://skse.silverlock.org/
Read the README carefull, the loose files must not be installed in the Datafolder where regular mods go. Ofcourse the Datafolder can be merged with your exisiting Datafolder. Being a tool, the loose files from SKSE must be placed into the Skyrim directory. You don't need the scr-folder.
Then copy the "skse_loader" from the Skyrim directory to desktop and use that to launch your game. Your mods won't be disabled at the start of a gamesession.

On the Nexus you'll find a lot of mods using SKSE, it provides a lot more freedom for the modders to make the mods they envisioned.

Let's hope Bethesda writes a fix ASAP 'cause like this we can not update our Workshop mods anymore.

Thank you Ilja for this thread, good idea!
1 comment, unsubscribing and re-subscribing can mess up the installation order for mods where that matters. Well, there aren't many of those on the Workshop. And for at least 1 person on this forum his mods even worked better then before.
Last edited by Bumbefly Sony Test םו; Mar 23, 2015 @ 9:36am
Nazenn Mar 23, 2015 @ 9:38am 
Originally posted by Bumbefly Nicky Test םו:
Snipped for Space
A better mod manager for those who are only doing workshop modding is actually Wrye Bash as it is laid out more like the Data Files, visually warns of problems, maintains the LOOT load order and also generates the bashed patch which is essential for many mod lists to make them compatable. More info here if you want it : Guide : Modding Tools, Tips and Resources

I hadnt actually thought if changing mod managers might fix this but if someone tests it out and reports back I would love to know if it bypasses the update bug
THOT Patrol 006 Mar 23, 2015 @ 3:29pm 
skyrim started crashing after I open up my inventory, search something, loot, or open my magic menu. does anyone know how to fix this?
Rapikol Mar 24, 2015 @ 12:42am 
Nothing works for me, mods that i am subscribed to are not showing up in launcher load list. I tried everything including reinstalling whole Steam. This is absolute disaster.
Rapikol Mar 24, 2015 @ 12:45am 
I've seen Steam downloading workshop content but... where? Where are all the mod files that Steam have been downloading for Skyrim? I found nothing in the Steam folder /Steam/Steamapps/workshop/[..] - nothing that resembles Skyrim mods is in here
Last edited by Rapikol; Mar 24, 2015 @ 12:46am
Nazenn Mar 24, 2015 @ 1:47am 
Originally posted by Rapikol:
I've seen Steam downloading workshop content but... where? Where are all the mod files that Steam have been downloading for Skyrim? I found nothing in the Steam folder /Steam/Steamapps/workshop/[..] - nothing that resembles Skyrim mods is in here

Mods install into your data folder of your skyrim installation, so Steam/SteamApps/Common/Skyrim/Data
Workshop mods are usually a bsa and an esp and they will have the same name :)
Rapikol Mar 24, 2015 @ 2:29am 
Nope, mods aren't there. That was the first place i looked into, like come on i'm not stupid okay?
Rapikol Mar 24, 2015 @ 2:31am 
I think Bethesda is stealing my subscribed mods files everytime Steam downloads them, i see no other explanation.
Last edited by Rapikol; Mar 24, 2015 @ 2:35am
< >
Showing 1-15 of 308 comments
Per page: 15 30 50

Date Posted: Mar 22, 2015 @ 10:28am
Posts: 308