Yorkshire Gubbins

Yorkshire Gubbins

View Stats:
The First Door Dec 10, 2017 @ 11:41am
Game Not Showing When Launched from in Steam

The game doesn't seem to be starting for me when I open it from within Steam. It starts three processes I can see in the Windows Task Manager, but nothing shows up!

If I run the game from outside of Steam, however, it starts just fine!

Any idea?
< >
Showing 1-10 of 10 comments
Stairfall Institute  [developer] Dec 19, 2017 @ 12:55am 
Hmmmmmmmmm. Well first of all I'm glad you found a way to launch it. I suspect the issue is to do with the Steam Overlay. What sort of GPU does your computer have?
The First Door Dec 20, 2017 @ 3:48am 
Well now, I just tried to launch it through Steam (as it has just installed an update), and now it's working absolutely fine. So... yay, I guess? For future reference, if it's helpful, I have a Geforce 970! Cheers for responding!
The First Door Dec 20, 2017 @ 4:07am 
Actually, scratch that! I just tried to reload it and now it's not opening for some reason? Huh, strange. Either way, I'm muchly enjoying it, just outside Steam at the moment!
Stairfall Institute  [developer] Dec 23, 2017 @ 4:26am 
That.... is tremendously frustrating! Do you have some sort of Interesting(tm) setup with monitors and resolutions? Just trying to figure out what it could be. Sounds like it's running but not creating a window which doesn't make sense at all. Would love to be able to recreate this!
Ripley Dec 27, 2017 @ 8:29am 
I seem to have the same bug too, starts 3 processes but doesn't load a screen. but when i launch it outside steam it loads a screen, but with 4 processes

edit: jus tried launchin it via steam again, still doesn't load but now only runs 2 processes
while launchin it again outside steam it has 3 processes running. something is not being run right with the process i think
Last edited by Ripley; Dec 27, 2017 @ 8:32am
The First Door Dec 28, 2017 @ 8:37am 
No, I don't! A single monitor setup, 1080p resolution running as native.

I'll do some more checks today, if I get a moment!
Stairfall Institute  [developer] Dec 31, 2017 @ 10:53am 
Unfortunately I believe this bug is caused by an interaction between certain third party tech I use and the Steam Overlay and it's one of those things that because I can't recreate it here there's no way to diagnose the problem or find a fix.

One thing that you both could try is adding '--in-process-gpu=false' to the launch options. If I'm right this will prevent the Steam Overlay showing but you should still be connected to the Steam API and get your achievements etc.

Obviously I can't actually test this from here. If you could let me know if it makes a difference that would maybe be a start!
Occulus Mar 30 @ 7:43am 
Had the same problem very it didnt open when i lunched it. but adding "'--in-process-gpu=false'" fixed it for me
Stairfall Institute  [developer] Apr 16 @ 11:00am 
I will be upgrading to the latest versions of my various third party dependencies for the next release. I hope this fixes some of these issues.

I know some people have found that restarting steam before trying to launch again has fixed this problem too. I'm no closer to finding the source of it, sadly!
Stairfall Institute  [developer] Apr 17 @ 7:03am 
Okay so I've found a reference to this particular bug in the issues tracker for one of my third-party dependencies and it's possible that upgrading to the latest version on the next release will actually fix it.
< >
Showing 1-10 of 10 comments
Per page: 15 30 50