Sonic Generations

Sonic Generations

View Stats:
20 fps?
Why am I gettin 20 fps in this game? Specs (please don't hate on me for using a laptop, I use it for work too!)

I7-4702MQ 2.2Ghz Turbo boost to 3.2ghz

GTX 760M 2GB

8GB

Windows 8 64bit
< >
Showing 1-12 of 12 comments
Solus Mar 1, 2014 @ 10:50am 
I have the same laptop as you :D

Make sure your charger is plug in.
Go to your nvidia control panel.
Go To Manage 3D settings. Click Program settings.
Look for the Sonic Generations exe. If it's not there, add it by clicking the add button.
Make sure it's using "High preforamance Nvidia processor.
Also, scroll down and look for the power management mode. Make sure it's on "Prefer maximun preforance".

Furthemore, go to your global settings. If it's on AUTO-select, change it to "high-preforance Nvidia Procesor". That auto select rarely works for me. I usually have to manually put it myself.

That should fix your problem and the game should use your graphic card.

Let me know if it fixed your problem.
depressed krabs Mar 1, 2014 @ 2:17pm 
Originally posted by infamous'Cynic:
I have the same laptop as you :D

Make sure your charger is plug in.
Go to your nvidia control panel.
Go To Manage 3D settings. Click Program settings.
Look for the Sonic Generations exe. If it's not there, add it by clicking the add button.
Make sure it's using "High preforamance Nvidia processor.
Also, scroll down and look for the power management mode. Make sure it's on "Prefer maximun preforance".

Furthemore, go to your global settings. If it's on AUTO-select, change it to "high-preforance Nvidia Procesor". That auto select rarely works for me. I usually have to manually put it myself.

That should fix your problem and the game should use your graphic card.

Let me know if it fixed your problem.


Did the exact same thing as you did! It used the damn intergrated. -.- Thanks, though !
Solus Mar 1, 2014 @ 5:19pm 
It should have worked!? Make sure you have both sonicgeneration.exe and fxpineline.exe one if you are using it.

Your computer should be able to run it at max 1080p with some framerate drop like in chemcial plant.
depressed krabs Mar 1, 2014 @ 5:27pm 
Originally posted by infamous'Cynic:
It should have worked!? Make sure you have both sonicgeneration.exe and fxpineline.exe one if you are using it.

Your computer should be able to run it at max 1080p with some framerate drop like in chemcial plant.

I mean that it worked, lol. And yeah, it's not very hard to handle the game except w/ modern sonic on chemical planet. By the way, is there any way to use the analog sticks on the ps3 controller for sonic generations? hope you know what I mean
Last edited by depressed krabs; Mar 1, 2014 @ 5:29pm
Solus Mar 1, 2014 @ 5:33pm 
Do not use motion joy! that causes problems and makes sonic roll. Uhh i recomend...
http://forums.pcsx2.net/Thread-XInput-Wrapper-for-DS3-and-Play-com-USB-Dual-DS2-Controller
Its better than motionjoy.
Last edited by Solus; Mar 1, 2014 @ 5:34pm
badaubles Mar 3, 2014 @ 4:21pm 
the best thing to do is lower the quality to 1024x768p because the same thing happened to me
depressed krabs Mar 3, 2014 @ 4:52pm 
Originally posted by ultra fan 54:
the best thing to do is lower the quality to 1024x768p because the same thing happened to me

Well, I did fix it, and now I get 60 fps, but yeah, like you said, lowering your resolution does help!
Gabriel Mar 13, 2014 @ 2:43am 
it worked
depressed krabs Mar 13, 2014 @ 6:08am 
Originally posted by Gabriel:
it worked

Have fun playing!
Shierke Mar 19, 2014 @ 7:04am 
Originally posted by infamous'Cynic:
Do not use motion joy! that causes problems and makes sonic roll. Uhh i recomend...
http://forums.pcsx2.net/Thread-XInput-Wrapper-for-DS3-and-Play-com-USB-Dual-DS2-Controller
Its better than motionjoy.

Correct. MotionInJoy is malware and contacts China's servers for some reason... It's a pain in the ♥♥♥♥ to get rid of completely too. Scarlet's drivers are much better.
Smoking Hot BBQ Apr 9, 2014 @ 7:39pm 
Originally posted by infamous'Cynic:
It should have worked!? Make sure you have both sonicgeneration.exe and fxpineline.exe one if you are using it.

Your computer should be able to run it at max 1080p with some framerate drop like in chemcial plant.
I cannot find fxrpipeline.exe in the mod folder when I am trying to set it to high performance processor. Where is it?
Originally posted by Smoking Hot BBQ:
Originally posted by infamous'Cynic:
It should have worked!? Make sure you have both sonicgeneration.exe and fxpineline.exe one if you are using it.

Your computer should be able to run it at max 1080p with some framerate drop like in chemcial plant.
I cannot find fxrpipeline.exe in the mod folder when I am trying to set it to high performance processor. Where is it?

fxrpipeline.exe is included in the Sonic GMI Mod loader
< >
Showing 1-12 of 12 comments
Per page: 15 30 50