DiRT Rally 2.0

DiRT Rally 2.0

View Stats:
This topic has been locked
PJTierneyCM  [developer] Jul 9 @ 4:10am
DiRT Rally 2.0, Version 1.6: Bug Reporting Thread
IMPORTANT: Read and understand this entire opening post before replying, as providing the right amount of detail will help out the team immensely in tracking and resolving any bugs that arise, thanks.


Hello everyone.

Version 1.6 of DiRT Rally 2.0 is available now and contains a number of features and bug fixes based on community feedback. The full patch notes can be found here:


http://blog.codemasters.com/dirt/07/patch-notes-version-1-6-of-dirt-rally-2-0/


The DiRT team is always on the look-out for any bugs or issues that arise as a result of updates, so if you have come across any please post them in here. Your contributions to previous threads have been very useful in helping the team plan not only for version 1.6 but additional updates in the future.



Before posting, please make sure to follow these guidelines. Without adequate information the team will have trouble identifying and fixing bugs, so please provide as much info as you can:


. Check if a bug has already been reported.

. If a bug has been reported and you are experiencing the same issue, quote it and say that it's happening for you too.

. Don't quote posts for the sake of them, only quote ones you're actually experiencing.

. The more popular bug posts will have a better chance of catching the attention of the team.

. If a bug cannot be reproduced, it cannot be fixed.

. When you experience a bug, please try to trigger said bug again if you can, and show us the steps you went through to trigger it.

. Text steps are good, video even better.

. One post per bug please, for our tracking purposes.



Please also provide the following:

. Your PC specs.

. Whether you're a Standard or Deluxe user.

. Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc.
Last edited by PJTierneyCM; Jul 9 @ 4:12am
< >
Showing 1-15 of 300 comments
PJ,

It's time to tackle the texture and shadow popping. I assume it's named LOD and shadow distance in PC-terms.

https://i.imgflip.com/358pa0.jpg :steamhappy:

With love,

Ivy.

PJTierneyCM  [developer] Jul 9 @ 4:25am 
Originally posted by Ivysaur:
PJ,

It's time to tackle the texture and shadow popping. I assume it's named LOD and shadow distance in PC-terms.

https://i.imgflip.com/358pa0.jpg :steamhappy:

With love,

Ivy.

Have you played through 1.6 yet to see if it's still there?

You never know, one of the many lines of code may have indirectly resolved it (it happens sometimes).
Hardy Jul 9 @ 4:28am 
The new Delta's sound is sick :steamhappy:
The loading times shortened indeed – no need to disable Core 0 for me from now on :steamhappy:
Ambient sounds back in Service Area after selecting an option :steamhappy:
Thank you!!!
Last edited by Hardy; Jul 9 @ 4:32am
Yeah. The daily in USA with the R2. You can clearly see in the distance there's 'no' shadows on the trees etc, and then if you approch it there's shadow. Same with the grass. You can clearly see the same effect in Monaco. Lemme take a screenshot, but i need to poop first. lol.

Also the leaves of the trees to have LOD problem. Further up the texture is different or low res, if you approach it loads to a better texture

However, it was also a issue with Dirt Rally 1. I bet it's just a limitation of the engine Codies uses.

https://imgur.com/a/27UQ1k8 Pics. You can clearly see the tree changing from shadowed, to not, to shadowed etc. Also tree branches, and leaves changes on other trees.

Here's Monaco too:

https://imgur.com/a/gIEdIQg You can clearly see on first pic there's is shadow on the wall. When you come closer there suddenly is not. In the last pic there's a bit of shadow in the trees etc. and if closer it's totally covered in shadows

This effect appears on every track, even Australia where there's shadow a few meters in front of you in the vegetation etc, and somewhat more there's not. If you race along the shadow just pops up.

For my specifications you can open my profile.
Last edited by RacingIvysaur; Jul 9 @ 5:10am
Hardy Jul 9 @ 5:11am 
I found that in mode Manual H-pattern + Clutch or Manual Sequential & Manual H-pattern or Manual Sequential some cars have sequential transmission now, instead of H-pattern. For example: Audi Quattro S1 E2 and Peugeot 205 T16 Evo2
fix. the. sound. cutting. out. mid. rally.
DesRoin Jul 9 @ 5:16am 
Loving the sound of the Delta now *_*
Good stuff all that's missing now is some classic Toyotas *g*
Originally posted by colinL:
fix. the. sound. cutting. out. mid. rally.
yes please... i mean i wont run a 10km stage without sound... so i have to retire everytime.. so all the multi event are unreachable, as i will likely have to retire one of the event :(
Originally posted by a man with no name:
Originally posted by colinL:
fix. the. sound. cutting. out. mid. rally.
yes please... i mean i wont run a 10km stage without sound... so i have to retire everytime.. so all the multi event are unreachable, as i will likely have to retire one of the event :(
Try to pause game. Leave game screen in Backgeound (Alt tab) and change audio settings of soundcard and set back. Go back to to ingame and check sound. Was working on my side.
PJ. Can you confirm if I made my post clear. So I know you understand what I meant.

Also I did the 16km daily in Poland. It's a good track that shows all the popping and such; Trees dense from afar, but looks less dense when I approch them. Shadows in the distance, but they less dense or gone when closer, and vice versa. Or the distance is quite dark, but more lighten when I am driving on the dark spot. etc

PJTierneyCM  [developer] Jul 9 @ 7:48am 
Originally posted by Ivysaur:
PJ. Can you confirm if I made my post clear. So I know you understand what I meant.
I think I've got it and can pass it on.

Originally posted by PJTierneyCM:
Originally posted by Ivysaur:
PJ. Can you confirm if I made my post clear. So I know you understand what I meant.
I think I've got it and can pass it on.


Alrighty! Now I can play Diablo II LOD again.

Wish you a fine day

Ivy
Originally posted by Carlos_K:
Originally posted by a man with no name:
yes please... i mean i wont run a 10km stage without sound... so i have to retire everytime.. so all the multi event are unreachable, as i will likely have to retire one of the event :(
Try to pause game. Leave game screen in Backgeound (Alt tab) and change audio settings of soundcard and set back. Go back to to ingame and check sound. Was working on my side.
oh nice. I will definitly try your workaround next time it happens. thanks!
Shark Jul 9 @ 8:00am 
Will you improve some tarmac physics?
My FPS in game is sluggish, before the update it was running fine, now only if I put graphics on the very low the game run normal.
i7 4790k
gtx 1070.
< >
Showing 1-15 of 300 comments
Per page: 15 30 50

Date Posted: Jul 9 @ 4:10am
Posts: 300