OUTRIDERS

OUTRIDERS

View Stats:
OUTRIDERS > Technical Support > Topic Details
 This topic has been pinned, so it's probably important
SE Toby  [developer] Apr 1 @ 8:39am
Stuttering and Frame Rate Issues
We are aware of an issue with our DX12 implementation that can cause PC players to encounter stuttering, a hard crash or shader cache issues due to an overloaded CPU.

We are investigating this urgently and hope to provide a resolution in the near future.

POTENTIAL WORKAROUND:
  • Select the "Play Outriders- DirectX11" launch option when starting the game.
  • Alternatively, force DX11 to run the game via a command line

    In Steam : Outriders Demo -> Manage -> Properties -> Launch option-> Write the below in the textbox without the " "

    "-force -dx11"
Please also check whether you have the latest NVIDIA Game Ready installed. If you currently have the latest driver already installed, please consider rolling back to the previous driver to see if this affects anything.

Alternative Workarounds:
  • Disable Ansel
  • Disable DLSS
  • Turn Vsync off
  • Enable your FPS Limiter and choose various limits to see if improvements are made
  • Ensure Controller Configuration is supported (thread)
  • Exclude the Outriders game folder in Windows Defender.
    • Start > Settings > Update & Security > Windows Security > Virus & threat protection.
    • Under Virus & threat protection settings, select Manage settings > Exclusions > "Add or remove exclusions".
    • Select Add an exclusion,
    • Select folders and add the Outriders game folder in steamapps/common

Please note that we are also aware of an issue whereby stuttering can occur whenever you visit a new area or encounter new enemies/powers etc. This should only occur the FIRST time however, with subsequent visits being stutter-free.
Last edited by SE Toby; Apr 2 @ 8:56am
Originally posted by SE Toby:
Earlier today we pushed a fresh DX11 config that may help many people resolve stuttering issues. More information here.
https://steamcommunity.com/app/680420/discussions/0/3075370188231547206/?ctp=3
< >
Showing 31-45 of 482 comments
Batho Apr 1 @ 11:31am 
Still Stuttering and Hitching here on DX11, with a 2070. Tried Low -> High Presets. FPS Limited to 60. Latest Nvidia Driver.

Its strange as the Demo ran perfectly fine. This on the other hand is unacceptable.
SE Toby  [developer] Apr 1 @ 11:35am 
Originally posted by Batho:
Still Stuttering and Hitching here on DX11, with a 2070. Tried Low -> High Presets. FPS Limited to 60. Latest Nvidia Driver.

Its strange as the Demo ran perfectly fine. This on the other hand is unacceptable.

Could you confirm whether the stuttering is only encountered in new areas or if it is present in previously visited areas as well?
waggz81 Apr 1 @ 11:36am 
My issues start as soon as the game launches. I've tried everything listed here with no difference. Also with a 2070 and updated game nvidia game drivers. Also ran demo with no issues. I'm getting about one frame every 2-3 seconds.
Last edited by waggz81; Apr 1 @ 11:37am
Gorgomus Apr 1 @ 11:37am 
Originally posted by SE Toby:
Could everyone try enabling/disabling your FPS limiter to see if this helps or changes anything?

Switched the FPS limiter to off and activated the 60 fps limit in MSI afterburner.

NOT one single hickup yet on DX12 with DLSS on balanced!!
Everything else is on ultra except for post processing and shadows

I really think the ingame FPS limiter could be the prob.

Last edited by Gorgomus; Apr 1 @ 11:49am
crudewar Apr 1 @ 11:51am 
I switched to the Nvidia studio driver for now 461.92 and the game is running a lot better
Originally posted by SE Toby:
Could everyone try enabling/disabling your FPS limiter to see if this helps or changes anything?
How to switch to dx11? because if choice dx11 in toolbox - game ANYWAY run on dx12.
Liger.tv Apr 1 @ 11:59am 
Originally posted by waggz81:
My issues start as soon as the game launches. I've tried everything listed here with no difference. Also with a 2070 and updated game nvidia game drivers. Also ran demo with no issues. I'm getting about one frame every 2-3 seconds.

Same situation, except with a 3090. Maybe 2-3 FPS from the moment the game launches. Demo ran without a problem
Geexx Apr 1 @ 12:04pm 
Not sure if it's related to the stuttering. But there's also a bug that's been occurring with the cut-scene FPS limiter/increase. I've noticed the game will get locked to 60 FPS unless you go back in to settings and reconfirm them / turn any kind of limiter on and off again. It's been fairly easy to reproduce on my end.
SE Toby  [developer] Apr 1 @ 12:06pm 
Originally posted by Geexx:
Not sure if it's related to the stuttering. But there's also a bug that's been occurring with the cut-scene FPS limiter/increase. I've noticed the game will get locked to 60 FPS unless you go back in to settings and reconfirm them / turn any kind of limiter on and off again. It's been fairly easy to reproduce on my end.

Thanks - this is likely separate but I've reported it to the team.
Xuuyan Apr 1 @ 12:10pm 
I’m on a 2070 Super and when I boot I don’t even get an option to change, it boots outside of steam in a windowed tab that I have to force to open. Not sure if that’s relevant but wanted to put it out there.
The stutter is so frequent,happens like every 3-4 seconds,during fights and traversing.
It is unplayable for me at the moment.
Hdr also is broken,it is worse than hdr effect many tvs and monitors have as an alternative option.
Abyss Apr 1 @ 12:16pm 
Originally posted by SE Toby:
Originally posted by Batho:
Still Stuttering and Hitching here on DX11, with a 2070. Tried Low -> High Presets. FPS Limited to 60. Latest Nvidia Driver.

Its strange as the Demo ran perfectly fine. This on the other hand is unacceptable.

Could you confirm whether the stuttering is only encountered in new areas or if it is present in previously visited areas as well?

Mine is in new area's. Quickly goes away once Ive been in the area for 10 seconds or so
I have the same issue, stuttering all the time. My CPU is sleeping so It is not an CPU overload issue. 10900k @ 5GHz, no cores go higher than 30% utilisation on DX12.
S1kR Apr 1 @ 12:17pm 
I fixed it on an RX 6900 XT by disabling the Overlay in the Radeon Control Software. With the overlay enabled it was a mess.
I can confirm that the game still runs on DX12 when selecting either DX11 or forcing DX11 in the launch settings. Frame timings are pretty bad (RTX 3090, 9900KS, 64GB RAM, DLSS UP). I can clear up some of the bad frame timing by disabling the in game frame limiter and disabling VSync in game. But every 3 - 4 seconds there's a 50 - 100 ms frame time spike.
< >
Showing 31-45 of 482 comments
Per page: 15 30 50

OUTRIDERS > Technical Support > Topic Details