Tracks - The Train Set Game

Tracks - The Train Set Game

View Stats:
 This topic has been pinned, so it's probably important
Dr. Whoop DSc  [developer] Feb 4, 2018 @ 11:23am
Fatal Error - D3D device being lost. (Error: 0x887A0006- 'HUNG')
-

Update (23rd June 2018)
Unreal Engine 4.20 is available in beta, this is the version which was supposed to get this fixed.
Now Epic have suddenly changed the target fix to 4.21, so that's fricking great. No concrete date for when that might be available or whether this will actually be fixed in it..

Update (17th March 2018)
Good news, Epic previously believed this was fixed but have recently acknowledged that it is still a problem and are targeting a fix to come out in the next version of Unreal Engine. Link to bug tracker entry.[issues.unrealengine.com]



Unfortunately this is an issue plaguing just about every Unreal 4 game at the moment.
It's a problem within the engine rather than the games themselves so we developers are at the mercy of Epic to fix it. You can see the bug tracker entry linked above.

Like I say there's not much I can do I'm afraid. You're welcome to get a refund, wait it out, or alternatively below there are instructions to play an older version of the game from before this became an issue. It doesn't have all the latest features but it should work for you. Sorry about that.

You can play/test an older version from before this became an issue:
  1. Right click on the game in your Steam library
  2. Click Properties
  3. Click on the Betas tab and enter previousversion into the text box
  4. Click Check code
You should see it appear in the drop-down menu after. The game in your Steam library will have a [previousversion] tag in the title if selected properly.
The game will then begin downloading the last version which should hopefully work for you while I work on sorting out the issue.

Anyone experiencing this problem, I'd appreciate if you could post your PC specs in this thread and also confirm whether the solutions work for you.
Last edited by Dr. Whoop DSc; Jun 23, 2018 @ 7:00am
< >
Showing 1-15 of 45 comments
mattmobes Feb 4, 2018 @ 9:58am 
Tracks Fatal Error on Start
I just bought the game for $10 and downloaded it. When I try to start it a pop-up message displays:
Fatal Error: {File:D:\Build\++UE4+Release-4.8+Compile\Sync\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11Util.cpp] [Line: 182] Unreal Engine is exiting due to D3D device being lost. (Error: 0x887A0006- 'HUNG')
Can I get some help? I don't want my ten dollars to go to waste.
Last edited by mattmobes; Feb 4, 2018 @ 9:58am
Dr. Whoop DSc  [developer] Feb 4, 2018 @ 11:11am 
Sorry you're having problems, I'm currently looking into that issue which seems to have been introduced in the most recent update.

In the meantime if you right click on the game in your Steam library > click Properties > Betas tab and enter previousversion in the text box and click Check code. You should see it appear in the drop-down menu after.

The game will then begin downloading the last version which should hopefully work for you while I work on sorting out the issue.

Would you mind posting your PC specs also?
Last edited by Dr. Whoop DSc; Feb 4, 2018 @ 11:21am
mattmobes Feb 4, 2018 @ 11:38am 
Thanks Whoop. I have intel graphics HD with an intel celeron processor N2840, but the computer ran previous versions of Tracks.
Dr. Whoop DSc  [developer] Feb 4, 2018 @ 12:04pm 
If you're still on the version which is causing problems, could you try something for me?
  1. Right click on the game in your Steam library
  2. Properties
  3. Local Files tab
  4. Browse Local Files
  5. TrainSet (folder) > Saved > Config > WindowsNoEditor
  6. Open GameUserSettings and find the line FullscreenMode=?
And tell me what number is there?
Last edited by Dr. Whoop DSc; Feb 4, 2018 @ 12:05pm
PeskyPeckett Feb 6, 2018 @ 8:13am 
A. What if fullscreenMode is already set to 2?
B. None of these worked for me.
C. My computer specs:

Computer Information:
Manufacturer: LENOVO
Model: 90C2003WUK
Form Factor: Desktop
No Touch Input Detected

Processor Information:
CPU Vendor: GenuineIntel
CPU Brand: Intel(R) Pentium(R) CPU J2900 @ 2.41GHz
CPU Family: 0x6
CPU Model: 0x37
CPU Stepping: 0x8
CPU Type: 0x0
Speed: 2417 Mhz
4 logical processors
4 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported
AES: Unsupported
AVX: Unsupported
CMPXCHG16B: Supported
LAHF/SAHF: Supported
PrefetchW: Supported

Operating System Version:
Windows 8.1 (64 bit)
NTFS: Supported
Crypto Provider Codes: Supported 311 0x0 0x0 0x0

Video Card:
Driver: Intel(R) HD Graphics
DirectX Driver Name: igdumdim32.dll
Driver Version: 10.18.10.3496
DirectX Driver Version: 10.18.10.3496
Driver Date: 3 11 2014
OpenGL Version: 4.0
Desktop Color Depth: 32 bits per pixel
Monitor Refresh Rate: 60 Hz
DirectX Card: Intel(R) HD Graphics
VendorID: 0x8086
DeviceID: 0xf31
Revision: 0xe
Number of Monitors: 1
Number of Logical Video Cards: 1
No SLI or Crossfire Detected
Primary Display Resolution: 1600 x 900
Desktop Resolution: 1600 x 900
Primary Display Size: 17.09" x 9.29" (19.45" diag)
43.4cm x 23.6cm (49.4cm diag)
Primary Bus Type Not Detected
Primary VRAM: -2037 MB
Supported MSAA Modes: 2x 4x 8x

Sound card:
Audio device: Speakers (Realtek High Definiti

Memory:
RAM: 3988 Mb

Miscellaneous:
UI Language: English
Media Type: DVD
Total Hard Disk Space Available: 926979 Mb
Largest Free Hard Disk Block: 655831 Mb
OS Install Date: Jan 01 1970
Game Controller: None detected
VR Headset: None detected

Originally posted by Dr. Whoop DSc:
If you're still on the version which is causing problems, could you try something for me?
  1. Right click on the game in your Steam library
  2. Properties
  3. Local Files tab
  4. Browse Local Files
  5. TrainSet (folder) > Saved > Config > WindowsNoEditor
  6. Open GameUserSettings and find the line FullscreenMode=?
And tell me what number is there?
Im having the same problem as he is. My computer was able to run the previous version of tracks, and now im getting the same error message as he is. The number im getting in the FullscreenMode line is 2, if that helps.
Dr. Whoop DSc  [developer] Feb 7, 2018 @ 7:26am 
Merged the thread into the main topic

Originally posted by Jackson of Future Passed:
Im having the same problem as he is. My computer was able to run the previous version of tracks, and now im getting the same error message as he is. The number im getting in the FullscreenMode line is 2, if that helps.
Have you tried the of the steps in the top post?
Also could you post your PC specs?
Last edited by Dr. Whoop DSc; Feb 7, 2018 @ 7:55am
Originally posted by Dr. Whoop DSc:
Merged the thread into the main topic

Originally posted by Jackson of Future Passed:
Im having the same problem as he is. My computer was able to run the previous version of tracks, and now im getting the same error message as he is. The number im getting in the FullscreenMode line is 2, if that helps.
Have you tried the of the steps in the top post?
Also could you post your PC specs?
Windows 10, processor is intel celleron cpu j1800 @2.41 ghz. Thats about all i know, the computer isnt all that good. I was able to run the previous version on low settings though, so i dunno. Also, I tried the fixes in the top post. None worked.
Last edited by Jackson of Future Passed; Feb 8, 2018 @ 3:20am
Mac Feb 8, 2018 @ 8:37am 
If i open 'GameUserSettings' the document is blank. :(
Dr. Whoop DSc  [developer] Feb 8, 2018 @ 9:13am 
Originally posted by Insert A Creative Username Here:
If i open 'GameUserSettings' the document is blank. :(
That just means the game hasn't been run before.

Could you post your PC specs?
Also there are instructions in the top post for accessing the previous version which will hopefully work for you.
Mac Feb 9, 2018 @ 11:12am 

The instructions for previous verson didnt work.

Specs:

GPU: Nvidia GeForce 8500GT
RAM:6gb
CPU:AMD Athlon Dual Core Processor
HDD:2TB
OS:Windows 10
Last edited by Mac; Feb 9, 2018 @ 11:12am
Mac Feb 14, 2018 @ 1:17pm 
Originally posted by Dr. Whoop DSc:
Originally posted by Insert A Creative Username Here:
If i open 'GameUserSettings' the document is blank. :(
That just means the game hasn't been run before.

Could you post your PC specs?
Also there are instructions in the top post for accessing the previous version which will hopefully work for you.

the previous version fix does not work.
Dr. Whoop DSc  [developer] Feb 14, 2018 @ 6:08pm 
Originally posted by Insert A Creative Username Here:
the previous version fix does not work.
You went through those instructions and there was [previousversion] at the end of the game's name in your Steam library?

Perhaps uninstalling through Steam, removing any remaining files and trying again with a fresh copy could work, but really it's possible that this version of UE4 simply doesn't spport a PC with your specs.
Like I've said I'm hoping a fix will be found but if it doesn't work out I'd suggest getting a refund.
Last edited by Dr. Whoop DSc; Feb 14, 2018 @ 6:08pm
Dr. Whoop DSc  [developer] Mar 17, 2018 @ 4:35pm 
Good news!

Epic previously believed this was fixed but have recently acknowledged that it is still a problem and are targeting a fix to come out in the next version of Unreal Engine.

Link to bug tracker entry.[issues.unrealengine.com]

Currently no information on when this new version will be released, but they generally come out every few months.
PeskyPeckett Mar 18, 2018 @ 12:19am 
Originally posted by Dr. Whoop DSc:
Good news!

Epic previously believed this was fixed but have recently acknowledged that it is still a problem and are targeting a fix to come out in the next version of Unreal Engine.

Link to bug tracker entry.[issues.unrealengine.com]

Currently no information on when this new version will be released, but they generally come out every few months.
that's great!
< >
Showing 1-15 of 45 comments
Per page: 15 30 50