They Are Billions

They Are Billions

View Stats:
game is running on 2x or 3x speed
for some reason all my new games are running on a fasted paced speed like 2x or 3x and i have no idea how to fix this. is this a new feature or is my game bugged? anyone else with the same problems?
< >
Showing 1-15 of 59 comments
I have the same problem
Crispy Feb 20 @ 1:34am 
oh my gawd
Crispy Feb 20 @ 1:36am 
Originally posted by allez encore un tour:
I have the same problem

bro idk what happened but its fixed for me O.O went to look at your reaction and went back into the game and its fixed >.<
Crispy Feb 20 @ 1:39am 
wait i dont even know if its fixed it seems to be a bit more fast paced then normal .... idk omgad
Naenne Feb 20 @ 3:44am 
Same for me. seemed to happen after I restarted a new game a few times in a short period to get a map setting i like.
Now when i'm exploring around with my hunters they walk twice as fast it seems
Naenne Feb 20 @ 3:48am 
Originally posted by Naenne:
Same for me. seemed to happen after I restarted a new game a few times in a short period to get a map setting i like.
Now when i'm exploring around with my hunters they walk twice as fast it seems


Restarting a game under a different name, so not using the same savegame seemed to turn things back to normal for me.
Same problem. Tried the different save. Didn't work. :(
Numantian Games  [developer] Feb 20 @ 5:16am 
Hi!

We haven't detected that issue in any of our test computers. Nevertheless we have updated the game using less aggressive timing parameters. Can you restart Steam to force the update and test it?

Thanks!
Originally posted by Numantian Games:
Hi!

We haven't detected that issue in any of our test computers. Nevertheless we have updated the game using less aggressive timing parameters. Can you restart Steam to force the update and test it?

Thanks!

Going to hijack real quick. Do you guys plan on fixing the unit pathing at any point? I think it is one of the ONLY issues i have with the game really otherwise it is one of the most fun games ive played in years.
YANO <3 Feb 20 @ 5:30am 
same :(
Same thing here
Arnie Feb 20 @ 6:02am 
Yup, same here, happens after a restart. But its fixed when saving the game and reloading it.
Kevin Feb 20 @ 6:04am 
same on my games
Gatygun Feb 20 @ 6:06am 
I need this bug
fågel#3 Feb 20 @ 6:08am 
Have the same issue, I don't even wanna imagine how fast the harpies are :pfff:
< >
Showing 1-15 of 59 comments
Per page: 15 30 50

Date Posted: Feb 20 @ 1:32am
Posts: 59