The Longest Journey

The Longest Journey

View Stats:
8-bit_gaming Jun 18, 2016 @ 12:09am
how to run on windows 10
here is a list of everything you should do to run this game with hopefully zero issues some of these steps might be skippable for your situation but it would cuase no harm doing them anyway so id recomend doing them to be safe if you are not tech savy

i have given little explnations top try and help you understand why im doing each step

step 1:copy steam.dll file from the main steam dirctory to the longest journy folder
(this step was nessary for me as when i do step 3 it would give me an error saying it could not find steam if i skiped this)

step 2: go to "C:\Users\[username here]\AppData\Roaming\The Longest Journey"
step 2.a: open preferences.ini
step 2.b: starting at the direct x line make your settings match this
[DirectX]
GfxDriver=display
int_BitDepth=16
bool_IsDoubleBuffer=0
bool_UseHardware=0
bool_StartFullscreen=1
bool_ForceSingleBuffer=1
bool_ShadowsOn=1



(this is done becuse newer computers do not have the same directdraw driver that the game looks for and can not work)

step 3: set the game.exe compatbility setings to xp service pack2 and run as admin.



i hope this helps if you still have troble feel free to post cant promis ill be able to help but maybe somone else will be able to. goodluck and enjoy a great game!
< >
Showing 31-42 of 42 comments
Jumpydoll Dec 22, 2016 @ 10:59pm 
Originally posted by moonlight:
I've find "C:\Users\[username here]\AppData\Roaming\The Longest Journey" but the folder is empty.What could I do then?
This folder lacks the preferences.ini file for me as well. You could try creating a .txt file in Notepad with the indicated text, then save and change its extension to .ini, though I am not sure if that would work.
Yugen Oct 28, 2017 @ 9:48am 
The game still doesn't run my pc :(
Irae Mar 5, 2018 @ 11:04am 
Thanks, it worked perfectly. Now I can finally enjoy the game.
Chloe-dette Jun 19, 2018 @ 8:51pm 
Yes. same. Nothing in the folder. itsd empty
King Jun 29, 2018 @ 6:15pm 
For those without the preferences.ini file, you can try this. Run the configure.exe in the installation folder. Change one of those settings, any one. Now go back and see if the preferences.ini file magically appeared.
HD Aug 16, 2018 @ 3:14am 
Originally posted by Tyr:
The game still doesn't run my pc :(
Try residualVM:
http://www.residualvm.org/downloads/#daily
corruptcompassion May 20, 2019 @ 1:16pm 
To run the game in full screen mode without the game cutting off a large portion of content, and to have the fewest bugs, I had to set the config file with the directions posted above, and do the following: Get to the compatibility tab for the game's execution file and click "Change High DPI Settings". Go to the "High scaling DPI override" section and click the checkbox beneath. Then use the drop down list below the checkbox and select "Application". Click "OK" and this panel will disappear, then click "OK" in the properties panel.
Last edited by corruptcompassion; May 20, 2019 @ 1:18pm
Nacery May 21, 2019 @ 9:10am 
As stated above right now ResidualVM is the best way to play this
Nerwen Vardamir May 21, 2019 @ 11:14pm 
Opened the preferences.ini file and there is no Direct X line. This is all I can see:

SfxVolume=1.000000
VoiceVolume=1.000000
MusicVolume=1.000000
bool_Subtitles=1
bool_AprilHighRes=1
bool_ShadowsOn=1
bool_AllowFastForward=1

Any ideas? I was hoping this would solve my problem where the game pretty much freezes whenever I try to save or quit.
corruptcompassion May 21, 2019 @ 11:23pm 
I had to add the [DirectX] Line at the bottom, then add new info. My pref file looks like this, and runs almost perfectly in full screen mode: (The exit and save windows display a white box, and I need to type "y" to exit or save.)

[Preferences]
SfxVolume=1.000000
VoiceVolume=1.000000
MusicVolume=1.000000
bool_Subtitles=1
bool_AprilHighRes=1
bool_ShadowsOn=1
bool_AllowFastForward=0
AudioDevice=autodetect
[DirectX]
GfxDriver=display
int_BitDepth=16
bool_IsDoubleBuffer=0
bool_UseHardware=0
bool_StartFullscreen=1
bool_ForceSingleBuffer=1
bool_ShadowsOn=1

Not sure if this will solve your problem, but if not, we can troubleshoot some more, and hopefully find a solution.
Last edited by corruptcompassion; May 21, 2019 @ 11:26pm
HD Aug 15, 2019 @ 1:45am 
Originally posted by Nerwen Vardamir:
Opened the preferences.ini file and there is no Direct X line. This is all I can see:

SfxVolume=1.000000
VoiceVolume=1.000000
MusicVolume=1.000000
bool_Subtitles=1
bool_AprilHighRes=1
bool_ShadowsOn=1
bool_AllowFastForward=1

Any ideas? I was hoping this would solve my problem where the game pretty much freezes whenever I try to save or quit.
You should try the daily version of residualVM to run the game

https://www.residualvm.org/downloads/#daily

This fixes most of the bugs and you don't have to do any of the old fixes

shaun894 Apr 23 @ 9:16pm 
Originally posted by corruptcompassion:
I had to add the [DirectX] Line at the bottom, then add new info. My pref file looks like this, and runs almost perfectly in full screen mode: (The exit and save windows display a white box, and I need to type "y" to exit or save.)

[Preferences]
SfxVolume=1.000000
VoiceVolume=1.000000
MusicVolume=1.000000
bool_Subtitles=1
bool_AprilHighRes=1
bool_ShadowsOn=1
bool_AllowFastForward=0
AudioDevice=autodetect
[DirectX]
GfxDriver=display
int_BitDepth=16
bool_IsDoubleBuffer=0
bool_UseHardware=0
bool_StartFullscreen=1
bool_ForceSingleBuffer=1
bool_ShadowsOn=1

Not sure if this will solve your problem, but if not, we can troubleshoot some more, and hopefully find a solution.


This works SOOO close. But it opens in full screen in a 4x4 inch square in the top left of my monitor. The rest of the screen is black.
< >
Showing 31-42 of 42 comments
Per page: 15 30 50