Age of Wonders

Age of Wonders

 This topic has been pinned, so it's probably important
sikbok  [developer] Nov 17, 2016 @ 5:59am
Having Trouble getting the Game to Run?
Hi,


Some people are experiencing difficulty getting the game to run on more recent operating systems. This pinned discussion is here to help.

Please follow the instructions below to see if these resolve any issues you are having.
Also, please let us know if these steps have helped you resolve the issue or not. The goal is to update this how2 so it can help more people in future.

After installing the game on Win10:
  1. Open the folder in which AoW is installed. To accomplish this: right-click the game in your steam library, select 'Properties', switch to the 'LOCAL FILES' tab and click the 'BROWSE LOCAL FILES...' button.
  2. Right click 'AoWSetup.exe', select 'Properties', switch to the 'Compatibility' tab, toggle the 'Compatibility mode' checkbox and set the mode to 'Windows XP (Service Pack 2)'.
  3. While in the 'Compatibility' tab also check the 'Run this program as an administrator' option, click 'Apply' and then click 'Ok' to close the screen.
  4. Double click 'AoWSetup.exe' in the folder. This will launch the AoWSetup application. Windows will prompt you asking if you trust us, to which I suggest answering with 'Yes'.
  5. In the setup click the 'Settings' tab, set the 'Startup Video Mode' to 'Window' and press 'Ok'.
  6. This brings you back to the setup application where you click 'Play!' to start the game.
  7. In the game, click the left most button with the crossed swords that is labelled 'Scenario'. This should trigger a windows prompt stating you miss 'Direct Play'. Please install 'Direct Play' as suggested.
  8. When installation is completed. Exit the game.
  9. Right click 'AoWSetup.exe', select 'Properties', switch to the 'Compatibility' tab, toggle the 'Compatibility mode' checkbox and set the mode to 'Windows7', click 'Apply' and then click 'Ok' to close the screen.
  10. That's configuration done.
  11. To launch the game press 'Play' from the Steam library, select 'Configuration' to start the setup application and press 'Play!' to start the game.

Note that:
  • If the steps above still result in an installation that throws errors, please uninstall the game and repeat the steps above on a fresh installation.
  • You can set AoW.exe to run as administrator to allow you to start the game using 'Play Age of Wonders' instead of having to do the extra click going through 'Configuration'.
  • We were able to set the game to run full screen in the setup tool after going through the above configuration.

Also note that:
  • Diego96 advices 'disabling "Direct Input Sound" in the configuration menu' because it 'fixed many of the crashes'. Thanks for sharing Diego96.

To manually install DirectPlay on Windows 10
  • Goto Control Panel\All Control Panel Items\Programs and Features
  • Click on Trun Windows features on or off
  • Enable Legacy Components -> DirectPlay
  • and Press OK

If you are still on Win7:
  • Step 7 will not prompt you to install Direct Play. To activate Direct Play please follow the steps on in the 'Answer' on this page[answers.microsoft.com].
Last edited by sikbok; Jul 3, 2019 @ 12:04am
Originally posted by mad kitten:
Here's the patch. Just open the zip file, run the .exe inside, and point it at ILPACK.DLL in your AoW installation folder (it will try to locate it automatically from registry, but if that doesn't work, you'll need to look it up yourself).

https://github.com/int19h/aow-patch/releases/tag/v1
< >
Showing 31-45 of 125 comments
mad kitten May 2, 2017 @ 9:26pm 
The patch linked to above is what fixes this particular error. I applied it to my GoG version of the game, and now it seems I can play normally, including combat.

sikbok, do you guys mind if I make a binary delta patch out of it, so that one doesn't need to know how to use a hex editor to apply it? It seems like it might help a few people, at least until you can make a proper fix.
sikbok  [developer] May 3, 2017 @ 1:50am 
Originally posted by mad kitten:
sikbok, do you guys mind if I make a binary delta patch out of it, so that one doesn't need to know how to use a hex editor to apply it? It seems like it might help a few people, at least until you can make a proper fix.

We'd have no problem with that. So go ahead.
Using that patch will - naturally - still be at the users risk.

It's actually the testing that is keeping us from moving more quickly on this. But as a convenient in between solution this sounds pretty good.

Thanks!
mad kitten May 5, 2017 @ 2:02am 
So, here's another interesting (weird?) data point. Just for fun, I completely wiped my AoW steam folder - deleted all files - then had Steam reinstall it (by doing "Verify local files"). The weird thing is that it fixed ALL problems that I had: no MapViewer error, no crashes entering combat, nothing. It just works. Not only that, but this is the exact repro - I happened to have the same savegame around that I was using for testing earlier, so I initiated the same exact combat in the same exact way - no errors.

What's even more interesting is that I didn't do anything at all other than reinstalling the game. In particular, I didn't do any steps outlined in this thread. I simply clicked AoW in the Steam library, and selected the option to play - whatever compatibility settings etc it's running with (I didn't check), it's what Steam applied out of the box.

I also didn't use my patch. So I'm going to recommend that anyone seeing problems do the same thing (delete your AoW Steam folder completely and reinstall) for now, to avoid complicating matters with a patch.

This all is on Win10 Creators Update, the latest and greatest. Same as my previous experiments.
mad kitten May 6, 2017 @ 2:35am 
Got the MapViewer.ShowScene error while playing the Steam version. Took a while - this is several turns into an XL map with 12 players, and after several tactical battles. Nowhere near as common as what I was seeing before, but still, it's there.
Tundrahawk May 11, 2017 @ 12:10am 
I went from having no crashes to having crashes every few turns - because I started playing in windowed mode.

Once I switched back to playing only in full screen I've only had a single crash in maybe 10 hours of playing through the campaign. Alt-Tab is a guaranteed crash for me but I've been able to get around it by using alt+enter, doing whatever I need to do on my other monitor, then alt+enter again on AOW with no crashes as of yet.

I've never had the MapViewer issue while in fullscreen but had it constantly while I tried playing in windowed mode so I can only assume that being windowed is part of the cause of this bug/crash.
Originally posted by ToadStoned:
Following the steps provided for compatability mode for Win Xp SP2 (Win 7 comp mode just crashes like normal), I then am able to get past the crash, but get the "Exception in MapViewer.ShowScene" error dialog when the scenirio loads and it will not go away no matter how many times I click the ok button. I just have to crash the program to get out of it.
I just had this happen, only not using any compat mode (I'm on Win7Ult 64) and trying to enter a city menu. It's actually happened twice, tho the first time was slightly different (I think a straight CtD?) and under slightly-different circumstances (I recall having started in fullscreen rather than starting windowed and switching, for instance). Now, I haven't tried the hex patch; I tried the "delete and verify" tactic (deleted all files in the folder instead of folder itself; think that's an issue?) and all it did was make the game refuse to start with a Steam error.

There are a couple of variations I haven't tried yet because I need to get to bed:
* Delete the gamefiles, verify, REBOOT STEAM before running (this fixed it not wanting to run after a normal un/reinstall, so...)
* Delete the gamefiles, REBOOT STEAM AND THEN VERIFY
* Run in XPSP2 compat mode
* Stay windowed

Think I should try any of those before looking for a proper diagnosis?
mad kitten May 14, 2017 @ 12:20am 
Note that deleting the files was what helped me with the other issue I was having (NOT MapViewer.ShowScene, but rather TArmyCombatMoveCE). So I suspect that that one was due to either corrupt install, or because I had some older version installed that Steam didn't update when it should have. MapViewer.ShowScene still shows up on clean unpatched Steam install for me, just not as often.

I'm working on packaging the patch at the moment, and will have it posted shortly.
Yeah, that wasn't the issue I was having, either (not to say I won't at some point); but it felt suspicious that it showed the same "recurring error requestor" behaviour.
...Well nevermind, then. I thought I'd tried AoWcompat.exe, but apparently not. o.O
A developer of this app has indicated that this post answers the original topic.
mad kitten May 14, 2017 @ 8:00pm 
Here's the patch. Just open the zip file, run the .exe inside, and point it at ILPACK.DLL in your AoW installation folder (it will try to locate it automatically from registry, but if that doesn't work, you'll need to look it up yourself).

https://github.com/int19h/aow-patch/releases/tag/v1
Beautiful. Five hours, zero problems.
ghost_darkness May 18, 2017 @ 4:34pm 
Originally posted by mad kitten:
Here's the patch. Just open the zip file, run the .exe inside, and point it at ILPACK.DLL in your AoW installation folder (it will try to locate it automatically from registry, but if that doesn't work, you'll need to look it up yourself).

https://github.com/int19h/aow-patch/releases/tag/v1

Well played, works like butter.
sikbok  [developer] May 19, 2017 @ 1:01am 
Indeed, thanks a bunch mad kitten.
Glad to see it works well here.

And as promised, we'll be looking into an official solution based on this as soon as we find the time.
L_o_f_t_u_s Jun 5, 2017 @ 5:13am 
Originally posted by mad kitten:
Here's the patch. Just open the zip file, run the .exe inside, and point it at ILPACK.DLL in your AoW installation folder (it will try to locate it automatically from registry, but if that doesn't work, you'll need to look it up yourself).

https://github.com/int19h/aow-patch/releases/tag/v1

Thank you for this! I didn't realise about the issues until loading the game up and couldn't even get to the main map, your patch fixed everything in a matter of seconds and everything is running great :)
vitgar83 Jun 16, 2017 @ 9:33am 
Originally posted by mad kitten:
Here's the patch. Just open the zip file, run the .exe inside, and point it at ILPACK.DLL in your AoW installation folder (it will try to locate it automatically from registry, but if that doesn't work, you'll need to look it up yourself).

https://github.com/int19h/aow-patch/releases/tag/v1

Thanks so much.
It works on Windows 10!!! I'm so happy :)
< >
Showing 31-45 of 125 comments
Per page: 1530 50