Devil May Cry 5

Devil May Cry 5

View Stats:
FasterThanFTL Mar 7, 2019 @ 9:47pm
Unofficial Ultrawide (21:9, 32:9 & 48:9) - Proper Fix for Vergil Update now available
[Fix for June 2019 Update] - [Outdated, see below for new proper fix]

Black/Grey Bar - Fixed
Gameplay/Camera Distance - Fixed
Cutscenes - Fixed
HUD - Fixed

Proper Fix for June Update released by jackfuste at WSGF:

http://www.wsgf.org/phpBB3/viewtopic.php?f=95&t=33038&start=200

1. Download DMC5_June_patch.7z from here:

http://www.wsgf.org/phpBB3/viewtopic.php?f=95&t=33038&start=200

2. Extract the DMC5_June_patch.7z using a software called 7-Zip:

https://www.7-zip.org/

3. Copy the DMC5_June_patch.exe that you extracted using 7-zip.

4. Paste it inside the Steam installation folder of Devil May Cry 5 located in X:\Program Files (x86)\Steam\steamapps\common\Devil May Cry 5

5. Run DMC5_June_patch.exe and press Start, then press OK.

6. That's it. Select the your desired Ultrawide resolution in-game.

7. Enjoy playing Devil May Cry 5 in Ultrawide.

______________________________________________________________________

[Old Dirty Fix] - Don't Use This (Not Recommended)

This fix removed the Grey/Black Bars and Gameplay/Camera Distance was also fine but it was not perfect as the HUD was slightly cut off from the top and bottom and the cutscenes were slightly zoomed in as well. This was just a temporary fix until a much better (see above) and/or Official fix was released that fixed the HUD and cutscenes as well.

Black/Grey Bar - Fixed
Gameplay/Camera Distance - Fixed
Cutscenes - Not Fixed
HUD - Not Fixed

For 2560x1080:
1. Open DevilMayCry5.exe in a Hex Editor, like HxD
2. Press Crtl+R, select Hex-values, Search for: 6E 40 00 00 80 41 C3 F5 38, Replace with: 6E 40 00 00 AB 41 C3 F5 38, Search direction: All
3. Click Replace all
4. Save and close.
5. In-Game set the Camera Distance setting located in Game Options to Max.

For 3440x1440:
1. Open DevilMayCry5.exe in a Hex Editor, like HxD
2. Press Crtl+R, select Hex-values, Search for: 6E 40 00 00 80 41 C3 F5 38, Replace with: 6E 40 00 00 AC 41 C3 F5 38, Search direction: All
3. Click Replace all
4. Save and close.
5. In-Game set the Camera Distance setting located in Game Options to Max.

For 3840x1600:
1. Open DevilMayCry5.exe in a Hex Editor, like HxD
2. Press Crtl+R, select Hex-values, Search for: 6E 40 00 00 80 41 C3 F5 38, Replace with: 6E 40 00 00 AD 41 C3 F5 38, Search direction: All
3. Click Replace all
4. Save and close.
5. In-Game set the Camera Distance setting located in Game Options to Max.

For 3840x1080:
1. Open DevilMayCry5.exe in a Hex Editor, like HxD
2. Press Crtl+R, select Hex-values, Search for: 6E 40 00 00 80 41 C3 F5 38, Replace with: 6E 40 00 00 FF 41 C3 F5 38, Search direction: All
3. Click Replace all
4. Save and close.
5. In-Game set the Camera Distance setting located in Game Options to Max.
Last edited by FasterThanFTL; Dec 16, 2020 @ 1:41pm
< >
Showing 136-150 of 375 comments
C-Dub Mar 19, 2019 @ 5:19am 
New update breaks this.
Sib3riX Mar 19, 2019 @ 5:23am 
broken game just crash
Bowm4080 Mar 19, 2019 @ 6:26am 
Only tested it with the Denuvo-free exe, but I deleted the patch_002.pak file as another user st ated, and it works.
☂Aqua☂ Mar 19, 2019 @ 8:27am 
New update breaks the fix, deleting patch_002.pak doesn't solve the problem
♥♥♥♥ capcom
hickz Mar 19, 2019 @ 9:45am 
Game over, wont play until ultrawide works again
Sib3riX Mar 19, 2019 @ 9:50am 
Originally posted by raubin:
Game over, wont play until ultrawide works again
same i hope someone fix this today
Vrihedd Mar 19, 2019 @ 12:12pm 
is no longer working
ChilLyWilLy Mar 20, 2019 @ 12:51pm 
Bump, update fix. Thanks in advanced whoever gets it lol.
💙💛💗 Mar 20, 2019 @ 1:00pm 
https://steamcommunity.com/sharedfiles/filedetails/?id=1687902693

Use this to revert the patch to use Ultrawide settings again.
Last edited by 💙💛💗; Mar 20, 2019 @ 1:00pm
Łućiƒer Mar 20, 2019 @ 3:23pm 
After I did the steps the game won't start up I press the start bottom from steam but nothing happens, until I do verify the integrity of the game files after that its lunch, but I lose the ultrawide patch

I am pretty sure that I install the same resolution my pc has,
so does anybody have a solution for my issue because I'm stuck with grey bars );
FasterThanFTL Mar 20, 2019 @ 3:30pm 
Originally posted by Łućiƒer:
After I did the steps the game won't start up I press the start bottom from steam but nothing happens, until I do verify the integrity of the game files after that its lunch, but I lose the ultrawide patch

I am pretty sure that I install the same resolution my pc has,
so does anybody have a solution for my issue because I'm stuck with grey bars );

The game was Patched by Capcom yesterday which also broke the Proper Fix. We are all waiting for the guys over at WSGF to update the The Proper Fix. Until then the only way to play it properly in Ultrawide is to downgrade the yesterday's Patch, look at the post above you, but I would suggest being a little bit patient.
Last edited by FasterThanFTL; Mar 20, 2019 @ 3:32pm
Any update?
Same problem that cant launch game after the new patch. Dont know why cap doing this to their fans...
:steammocking:
Voyagers Revenge Mar 22, 2019 @ 10:56pm 
Originally posted by Rhino Prime:
Any update?
Same problem that cant launch game after the new patch. Dont know why cap doing this to their fans...
:steammocking:
Same! Verify file integrity to at least play the game if you want. Seems like an update for the game has corrupted the ultrawide monitor fix. I just got one of these myself and this is the only game so far that I've had trouble with it seems. Weird because Resident Evil 2 works fine.
Not working for 21:9 3/23/19
< >
Showing 136-150 of 375 comments
Per page: 15 30 50