FINAL FANTASY XII THE ZODIAC AGE

FINAL FANTASY XII THE ZODIAC AGE

View Stats:
Fix for "white screen" on GPD Win, possibly other Intel
Alright, I've got something.

One little oddity of the GPD Win (Google it) is that, rather than seeing itself as having a 1280x720 landscape screen (standard 720), it instead sees itself as having a 720x1280 portrait screen, which is rotated by the Intel graphics drivers in software. As a test, I turned off the rotation, started the game, and presto: The game gets past the white screen and fully loads, seemingly entirely playable. I've tried back-and-forth a few times and it was reproducible: load rotated and it crashes, load without and it's fine. Naturally there's an issue in that the screen is sideways, but I've been able to work around this.

This hints at the behind-the-scenes cause of this, and may lead to a more general solution, but for now: GPD WINners, here's how to get the game up and running.

First, one-off setup:
1) Optionally, grab the latest drivers. I did, but I didn't test with the original ones, and doubt it affected anything.
2) Run the configurator, and set the game up for Windowed mode, 1280x720. (Sorry, no borderless yet)
3) Make sure you have the Intel Graphics icon in your toolbar.

Once this is done, this is how to run the game:
1) Using the Intel icon, turn Screen Rotation to 0 degrees. This will make things hard to control, as the screen is now rotated but your controls aren't.
2) Start up Zodiac Age. It should properly load after a while.
3) Any time after you see the spinning "Loading" icon, Alt-Tab out of the game, go back to the Intel icon, and change your screen rotation back to how it was.

And, you're done! Once you're in-game you can change most graphics settings however you like, but don't change resolution or leave windowed mode; doing so will lock the game up on a black screen.

I haven't tested this extensively, so it may fail once you hit an FMV or something, and you always need to switch rotation off before you load the game, but this definitely lets you reach gameplay. More work to do for a decent, general solution!
Last edited by Internet Pedant; Feb 4, 2018 @ 4:15pm
< >
Showing 1-15 of 27 comments
Kooiboy Feb 4, 2018 @ 3:51pm 
Tnx man!! :)
while this is not ideally, the GPD is able to run it!
How is you screen res? It seems to be very stretched (unplayable)
Which scaling options do you use?
Last edited by Kooiboy; Feb 4, 2018 @ 4:08pm
Internet Pedant Feb 4, 2018 @ 4:14pm 
I had terrible scaling issues when trying this with Borderless mode, just a very wide short image across the screen (hence why the guide says this doesn't work for Borderless). With windowed mode, it keeps the window resolution set (I'm using 1280x720) and runs as expected, no issues with weird proportions at my end.
Kooiboy Feb 4, 2018 @ 4:21pm 
edit setting.ini to 720x1280 and do your trick again! then scalling is ok! :)
gonna test a little is its playable, it feels laggy in the menu. all settings to low, haha
Last edited by Kooiboy; Feb 4, 2018 @ 4:22pm
GuidoSeagal Feb 4, 2018 @ 9:21pm 
This worked great! Thank you very much! I made an intel graphics profile to turn off rotation when loading the game, then I manually switch the rotation after the game loads. I use Borderless Gaming to switch to fullscreen. Hopefully there will be a patch so I don't have to do this every time I load the game but will have to do for now.
Kooiboy Feb 4, 2018 @ 11:37pm 
Originally posted by GuidoSeagal:
This worked great! Thank you very much! I made an intel graphics profile to turn off rotation when loading the game, then I manually switch the rotation after the game loads. I use Borderless Gaming to switch to fullscreen. Hopefully there will be a patch so I don't have to do this every time I load the game but will have to do for now.
Ohh good idea! :) Do you find the game playable? I can manage, but am afraid for the bigger battles
GuidoSeagal Feb 4, 2018 @ 11:43pm 
I set a custom resolution of 854x480 for better performance with low settings and 30fps.
Wombat Feb 4, 2018 @ 11:47pm 
it's not due to being a GDP win or intel. I think it's because of having a 1280x720 native display. I use a TV for a monitor and only have an Nvidia gtx 760 with the onboard intel graphic disabled completely at the bios. Rotating the display in the nvidia control panel acheived the same workaround. Can only play windowed or get same results reported here.
Kooiboy Feb 4, 2018 @ 11:58pm 
Will play this more when I,m back from work, really glad we found a work around for the time being!
Ted Feb 5, 2018 @ 6:31am 
.
The Space Ferret Feb 5, 2018 @ 8:18am 
Originally posted by sc2mails:
it's not due to being a GDP win or intel. I think it's because of having a 1280x720 native display. I use a TV for a monitor and only have an Nvidia gtx 760 with the onboard intel graphic disabled completely at the bios. Rotating the display in the nvidia control panel acheived the same workaround. Can only play windowed or get same results reported here.

Wish it worked for me. I also use that res but rotating the display didn't do squat :( Oh well, I'll just eat the money I paid. I don't think I'll find a workable solution.
Ted Feb 5, 2018 @ 8:24am 
same. ive tried every firewall/AntiVirus solution on the CMD promt level to accept Denuvo "just in case".. in uninstalled and reinstalled the Game files, C++ - VCRedist.. Video Drivers. SP1 for Win7.. now ive rotated the screen every way . tried several resolutions.

SE has let me down. i feel traumatized by this betrayal. ill never trust another game dev again QQ
Wombat Feb 5, 2018 @ 8:45am 
Are you sure you're using windowed mode? It's worked for me since using a utility to completely unistall all but the plugandplay defualt graphics driver, installing the new one fresh, and then rotating portrait before starting. There could be other issues, but it's worked for quite a few.
Kooiboy Feb 5, 2018 @ 11:12am 
Any GDPWin user whe can share the containance of their setting.ini file? I find the game quite laggy even with the lowest (i think?) settings. cheers!
Plex Feb 11, 2018 @ 4:46pm 
hm I gotta try this, but I'm not expecting it to run well on the Win since its already laggy on my core-m tablet on low.
Kooiboy Feb 12, 2018 @ 2:57am 
it is laggy indeed. I wasnt able to get it run smoothly. I kept it in windowed mode without stretching the screen to much. Then is playable (all settings low) I wanted to stretch the screen and keep the resolution, but no matter what I do, it will always adapt the res, and thus making it laggy again. I expected XII to run better as X/X-2 were very playable. For now we can only hope a future patch will help out
< >
Showing 1-15 of 27 comments
Per page: 15 30 50

Date Posted: Feb 4, 2018 @ 3:40pm
Posts: 27