Assassin's Creed Origins

Assassin's Creed Origins

View Stats:
 This topic has been pinned, so it's probably important
UbiQuB3  [developer] Oct 26, 2017 @ 10:55am
Assassin's Creed Origins - Known Issues [Updated: May 15]
Hey everyone,

Please find the current list of known issues below.


In-Game Issues

Game crashes
Description: We’ are currently investigating various user reports of crashes on all platforms.
Status: Under Investigation
PC specific note: Please do get in touch with the support team and provide them with ms info and dxdiag.

PC-specific

HBCC causes performance drops
Description: Enabling HBCC on AMD Radeon settings can result in a drop of performance.
Workaround: We advise to turn off this setting until AMD resolved the issue with a future driver.
Status: Will be addressed with a future driver update on AMD side

Poor Performance with AMD CPUs
Description: Players who are using AMD FX Series processors may experience FPS drops and freezes, especially with the FX-8350 model.
Workaround: Disable the Cool and Quiet feature in BIOS settings and set the Power Plan to High Performance. Please note that a good cooling solution is also recommended in order to avoid overheating issues, should you implement this workaround.
Status: Under investigation

Nvidia GPUs | Game Crashes since 1.2.0
Description: We're are aware that some players using Nvidia graphics cards may experience game crashes since the most recent Title Update (1.2.0).
Initial investigations indicate that this is related to an unsupported Antialiasing option.
Workaround: Open Nvidia Control Panel > Navigate to "Manage 3D Settings" > Check if Antialiasing - FXAA is set to "ON". If so we recommend to turn it off & save your changes.

Game crashes with AMD drivers 18.2.1
Description: We have noticed game client instability with both the base game and the upcoming Discovery Tour mode, while using AMD drivers 18.2.1
Workaround: We recommend rolling back to previous driver version 17.12.1 until we have more information about the issue.
Status: Under investigation

*******

Please report any issues to our support [http//%26quot%3Bhttp]team.
Last edited by UbiQuB3; May 16 @ 2:58am
< >
Showing 1-15 of 1,524 comments
Yourname942 Oct 26, 2017 @ 10:57am 
Thanks for the post, but your formatting is showing the brackets
UbiQuB3  [developer] Oct 26, 2017 @ 11:02am 
Originally posted by Yourname942:
Thanks for the post, but your formatting is showing the brackets
Fixed it. Thanks for the note. ;)
Voidolt Oct 26, 2017 @ 11:03am 
Release this game already...
Joh Oct 26, 2017 @ 11:05am 
Thx for letting us know already. Really appreciated.
Last edited by Joh; Oct 26, 2017 @ 11:06am
你没有朋友 Oct 26, 2017 @ 11:32am 
When will the first title update be?
canzan Oct 26, 2017 @ 11:55am 
Will the game support the old AMD CPU that not support SSE 4.1?
IFFATH_ZIYARD™ Oct 26, 2017 @ 12:14pm 
Thank you so much for caring so much for the game and us and i will feedback on anything i find aswell not yet released here but im waiting hyped to play the game <3
Lozzle Oct 26, 2017 @ 2:03pm 
GPU driver crashing in the opening sequence with the 1v1 duel? RX 570. Tried all settings, fresh reinstalled latest drivers. Something about blood spray and sand kicking up, those particle effects the second it happens driver crashes.
MarK_ES Oct 26, 2017 @ 6:51pm 
I have a really big issue with sound. Currently playing on a i7 4400 unlocked, 32Gb Ram, Gtx1080 and G933 Artemis as sound device. Playing in Spanish language. Speeches are completely lost. In cinematics there are no voices at all, but environmental sound yes. During gameplay, first mission I go to the blacksmith, he greets me while I walk to him perfectly audible, but once the cinematic starts, voices dissapear. In the cave, bayek talks to the girl accross the door, but when cinematic starts sound is gone. It's like there are files missing or sound is badly encoded, but it's ruining completely the experience... please help. Thank you.
Knuckleheader Oct 26, 2017 @ 8:45pm 
Played for 40 minutes and encountered a bug which makes the game unplayable for me at the moment. When I move the mouse, the camera 'lags', doesn't move or only moves slighty in small jumps -> Not the smooth camera movements I had in the first 20-30 minutes. Dropping settings doesn't work, also happens on low settings. (GTX1070, I7-6800K, 16 GB RAM)

Is there a work around? Otherwise I simply can't play... It's impossible to stealth, or even attempt to fight, with a camera that doesn't respond to your mouse movements.
Voidolt Oct 26, 2017 @ 8:50pm 
I want report a weird issue, most i7 processors has 90-100 CPU usage in this game so I hope you can do with this.
Androsida Oct 26, 2017 @ 8:58pm 
Fix cpu usage please. Always on 100% with good cpus
Biggie_GP Oct 26, 2017 @ 9:00pm 
i preloaded it yesterday and now its "unpacking? it says 2-3+hours? wtf is going on i already preloaded it
I swear I refunded watch dogs 2 because of 90-100% CPU USage on my i7 6700K IF THIS HAPPENDS AGAIN TO ACO... I WILL GET REAL MAD I dont want my PC sounding like its being benchmarked 24/7 I swear ubisoft im getting a little scared.
russianninja Oct 26, 2017 @ 9:12pm 
My game won't launch. I pre loaded it and when I try to launch it says its updating but nothing is happening...
< >
Showing 1-15 of 1,524 comments
Per page: 15 30 50