Insurgency: Sandstorm

Insurgency: Sandstorm

İstatistiklere Bak:
*Old* Possible FPS/Stutter Fix
1. Go to C:\Users\YourName\AppData\Local\Insurgency\Saved\Config\WindowsClient
2. Open engine.ini and delete all text and paste this:

[Core.System]
Paths=../../../Engine/Content
Paths=%GAMEDIR%Content
Paths=../../../Insurgency/Plugins/Wwise/Content
Paths=../../../Engine/Plugins/Editor/CryptoKeys/Content
Paths=../../../Engine/Plugins/Enterprise/DatasmithContent/Content
Paths=../../../Engine/Plugins/Media/MediaCompositing/Content

[/script/engine.engine]
bUseVSync=false
MaxPixelShaderAdditiveComplexityCount=128
MaxES2PixelShaderAdditiveComplexityCount=45
IdealLightMapDensity=0.02
MaxLightMapDensity=0.05

[/script/engine.garbagecollectionsettings]
TimeBetweenPurgingPendingKillObjects=15

[/script/engine.renderersettings]
r.SkeletalMeshLODBias=10
r.MotionBlurQuality=0
r.AmbientOcclusionMipLevelFactor=0.0
r.AmbientOcclusionMaxQuality=0
r.AmbientOcclusionLevels=0
r.AmbientOcclusionRadiusScale=0.0
r.DefaultFeature.Bloom=False
r.DefaultFeature.AmbientOcclusion=False
r.DefaultFeature.AmbientOcclusionStaticFraction=False
r.DefaultFeature.AutoExposure=False
r.DistanceFieldAO=0
r.VolumetricFog=0
r.VolumetricFog.GridPixelSize=0
r.VolumetricFog.GridSizeZ=0
r.AllowLandscapeShadows=0
r.LightMaxDrawDistanceScale=0
r.ParticleLightQuality=0
r.LightPropagationVolume=0
r.ReflectionEnvironment=0
r.MSAA.CompositingSampleCount=1
r.ViewDistanceScale=0.6
r.PostProcessAAQuality=0
r.BlurGBuffer=0
r.DepthOfFieldQuality=0
r.RenderTargetPoolMin=5
r.LensFlareQuality=0
r.SceneColorFringeQuality=0
r.BloomQuality=0
r.FastBlurThreshold=0
r.Upscale.Quality=0
r.Tonemapper.GrainQuantization=0
r.TonemapperQuality=0
r.LightShaftQuality=0
r.RefractionQuality=0
r.Shadow.MaxResolution=2
r.Shadow.DistanceScale=0.001
r.Shadow.CachedShadowsCastFromMovablePrimitives=0
r.ShadowQuality=0
r.Shadow.CSM.MaxCascades=1
r.Shadow.RadiusThreshold=0.1
r.Shadow.CSM.TransitionScale=0
r.LPV.RSMResolution=4
r.Streaming.MipBias=0
r.Streaming.PoolSize=2000
r.FinishCurrentFrame=0
r.MaxAnisotropy=8
r.TranslucencyLightingVolumeDim=6
r.SSR=0
r.SceneColorFormat=2
r.DetailMode=0
r.TranslucencyVolumeBlur=0
r.SSS.Scale=0
r.SSS.SampleSet=0
r.SSS.Quality=0
r.SSS.HalfRes=1
r.GBufferFormat=3
r.VirtualTexture=1
r.VirtualTextureReducedMemory=1
s.AsyncLoadingThreadEnabled=1
r.MaterialQualityLevel=0
r.Filter.SizeScale=0.2
r.setres=640x480wf
r.Tonemapper.Sharpen=0.1
r.TonemapperGamma=2.5
r.DeferSkeletalDynamicDataUpdateUntilGDME=1
r.DeferUniformBufferUpdatesUntilVisible=1
r.DoInitViewsLightingAfterPrepass=1
r.SkinCache.Mode=1
r.ClearWithExcludeRects=2
r.CreateShadersOnLoad=1
r.OptimizeForUAVPerformance=1

[ConsoleVariables]
AllowAsyncRenderThreadUpdates=1
AllowAsyncRenderThreadUpdatesDuringGamethreadUpdates=1
AllowAsyncRenderThreadUpdatesEditor=1
r.DeferSkeletalDynamicDataUpdateUntilGDME=1
r.DeferUniformBufferUpdatesUntilVisible=1
r.DoInitViewsLightingAfterPrepass=1
r.SkinCache.Mode=1
r.ClearWithExcludeRects=2
r.CreateShadersOnLoad=1
AllowAsyncRenderThreadUpdates=1
AllowAsyncRenderThreadUpdatesDuringGamethreadUpdates=1
AllowAsyncRenderThreadUpdatesEditor=1

[TextureStreaming]
BoostPlayerTextures=1.0
AllowStreamingLightmaps=False
r.Streaming.DropMips=0
r.Streaming.LimitPoolSizeToVRAM=0
r.Streaming.MipBias=0
r.Streaming.UseAllMips=1
r.Streaming.UseMaterialData=1
r.Streaming.UseNewMetrics=1
r.Streaming.UsePerTextureBias=1

Also, go into steam and check the properties of insurgency: Sandstorm and open the launch command window and type -USEALLAVAILABLECORES and save it.

It made my game smoother, no more stuttering and much better mouse movement. Let me know if it helps!

CREDITS: necriss, Boocheus, and others from Focus Home Forums
also to Synthetic who originally posted these config settings. Thanks guys!
En son ScoobZ tarafından düzenlendi; 12 Oca @ 19:32
< >
200 yorumdan 1 ile 15 arası gösteriliyor
Bookmarking this to see if it actually works.
İlk olarak OG∑Я tarafından gönderildi:
Bookmarking this to see if it actually works.
Does it work?
MY MAN IT WORKS!
I dont have an APP DATA folder in my profile, where else could it be?
İlk olarak Omega+ tarafından gönderildi:
I dont have an APP DATA folder in my profile, where else could it be?

Search for %AppData% in the start menu possibly.
İlk olarak Based MRE God Steve tarafından gönderildi:
İlk olarak Omega+ tarafından gönderildi:
I dont have an APP DATA folder in my profile, where else could it be?

Search for %AppData% in the start menu possibly.
No, only one that containes a "microsoft" folder and nothing else
So it’s basically turning off every graphics options?
İlk olarak Omega+ tarafından gönderildi:
İlk olarak Based MRE God Steve tarafından gönderildi:

Search for %AppData% in the start menu possibly.
No, only one that containes a "microsoft" folder and nothing else

Show hidden folders maybe?
İlk olarak Katon tarafından gönderildi:
İlk olarak Omega+ tarafından gönderildi:
No, only one that containes a "microsoft" folder and nothing else

Show hidden folders maybe?
I had the game installed on my D:\ drive. I'm currently moving it to C. Will let you know if the folder still doesn't appear. Thanks for the help!
Does this basically set every setting to low?
Thank you OP for your contribuation.


İlk olarak Omega+ tarafından gönderildi:
İlk olarak Based MRE God Steve tarafından gönderildi:

Search for %AppData% in the start menu possibly.
No, only one that containes a "microsoft" folder and nothing else

You'll need to enable the option to view hidden files.

https://support.microsoft.com/en-us/help/14201/windows-show-hidden-files
So much better for me. Thanks OP
I don't want to turn down all graphical settings to the lowest
It feels better, and graphic settings weren't changed.
Low and max settings give me the same horrible performance. this is the only thing that fixed it for me and it doesnt look like low settings so I dunno what it did
< >
200 yorumdan 1 ile 15 arası gösteriliyor
Sayfa başına: 15 30 50