Insurgency: Sandstorm

Insurgency: Sandstorm

Näytä tilastot:
*Old* Possible FPS/Stutter Fix
1. Go to C:\Users\YourName\AppData\Local\Insurgency\Saved\Config\WindowsClient
2. Open engine.ini and delete all text and paste this:

[Core.System]
Paths=../../../Engine/Content
Paths=%GAMEDIR%Content
Paths=../../../Insurgency/Plugins/Wwise/Content
Paths=../../../Engine/Plugins/Editor/CryptoKeys/Content
Paths=../../../Engine/Plugins/Enterprise/DatasmithContent/Content
Paths=../../../Engine/Plugins/Media/MediaCompositing/Content

[/script/engine.engine]
bUseVSync=false
MaxPixelShaderAdditiveComplexityCount=128
MaxES2PixelShaderAdditiveComplexityCount=45
IdealLightMapDensity=0.02
MaxLightMapDensity=0.05

[/script/engine.garbagecollectionsettings]
TimeBetweenPurgingPendingKillObjects=15

[/script/engine.renderersettings]
r.SkeletalMeshLODBias=10
r.MotionBlurQuality=0
r.AmbientOcclusionMipLevelFactor=0.0
r.AmbientOcclusionMaxQuality=0
r.AmbientOcclusionLevels=0
r.AmbientOcclusionRadiusScale=0.0
r.DefaultFeature.Bloom=False
r.DefaultFeature.AmbientOcclusion=False
r.DefaultFeature.AmbientOcclusionStaticFraction=False
r.DefaultFeature.AutoExposure=False
r.DistanceFieldAO=0
r.VolumetricFog=0
r.VolumetricFog.GridPixelSize=0
r.VolumetricFog.GridSizeZ=0
r.AllowLandscapeShadows=0
r.LightMaxDrawDistanceScale=0
r.ParticleLightQuality=0
r.LightPropagationVolume=0
r.ReflectionEnvironment=0
r.MSAA.CompositingSampleCount=1
r.ViewDistanceScale=0.6
r.PostProcessAAQuality=0
r.BlurGBuffer=0
r.DepthOfFieldQuality=0
r.RenderTargetPoolMin=5
r.LensFlareQuality=0
r.SceneColorFringeQuality=0
r.BloomQuality=0
r.FastBlurThreshold=0
r.Upscale.Quality=0
r.Tonemapper.GrainQuantization=0
r.TonemapperQuality=0
r.LightShaftQuality=0
r.RefractionQuality=0
r.Shadow.MaxResolution=2
r.Shadow.DistanceScale=0.001
r.Shadow.CachedShadowsCastFromMovablePrimitives=0
r.ShadowQuality=0
r.Shadow.CSM.MaxCascades=1
r.Shadow.RadiusThreshold=0.1
r.Shadow.CSM.TransitionScale=0
r.LPV.RSMResolution=4
r.Streaming.MipBias=0
r.Streaming.PoolSize=2000
r.FinishCurrentFrame=0
r.MaxAnisotropy=8
r.TranslucencyLightingVolumeDim=6
r.SSR=0
r.SceneColorFormat=2
r.DetailMode=0
r.TranslucencyVolumeBlur=0
r.SSS.Scale=0
r.SSS.SampleSet=0
r.SSS.Quality=0
r.SSS.HalfRes=1
r.GBufferFormat=3
r.VirtualTexture=1
r.VirtualTextureReducedMemory=1
s.AsyncLoadingThreadEnabled=1
r.MaterialQualityLevel=0
r.Filter.SizeScale=0.2
r.setres=640x480wf
r.Tonemapper.Sharpen=0.1
r.TonemapperGamma=2.5
r.DeferSkeletalDynamicDataUpdateUntilGDME=1
r.DeferUniformBufferUpdatesUntilVisible=1
r.DoInitViewsLightingAfterPrepass=1
r.SkinCache.Mode=1
r.ClearWithExcludeRects=2
r.CreateShadersOnLoad=1
r.OptimizeForUAVPerformance=1

[ConsoleVariables]
AllowAsyncRenderThreadUpdates=1
AllowAsyncRenderThreadUpdatesDuringGamethreadUpdates=1
AllowAsyncRenderThreadUpdatesEditor=1
r.DeferSkeletalDynamicDataUpdateUntilGDME=1
r.DeferUniformBufferUpdatesUntilVisible=1
r.DoInitViewsLightingAfterPrepass=1
r.SkinCache.Mode=1
r.ClearWithExcludeRects=2
r.CreateShadersOnLoad=1
AllowAsyncRenderThreadUpdates=1
AllowAsyncRenderThreadUpdatesDuringGamethreadUpdates=1
AllowAsyncRenderThreadUpdatesEditor=1

[TextureStreaming]
BoostPlayerTextures=1.0
AllowStreamingLightmaps=False
r.Streaming.DropMips=0
r.Streaming.LimitPoolSizeToVRAM=0
r.Streaming.MipBias=0
r.Streaming.UseAllMips=1
r.Streaming.UseMaterialData=1
r.Streaming.UseNewMetrics=1
r.Streaming.UsePerTextureBias=1

Also, go into steam and check the properties of insurgency: Sandstorm and open the launch command window and type -USEALLAVAILABLECORES and save it.

It made my game smoother, no more stuttering and much better mouse movement. Let me know if it helps!

CREDITS: necriss, Boocheus, and others from Focus Home Forums
also to Synthetic who originally posted these config settings. Thanks guys!
Viimeisin muokkaaja on ScoobZ; 12.1. kello 19.32
< >
Näytetään 1-15 / 196 kommentista
Dinkk 30.8.2018 kello 14.38 
Bookmarking this to see if it actually works.
OG∑Я lähetti viestin:
Bookmarking this to see if it actually works.
Does it work?
MY MAN IT WORKS!
Omega+ 30.8.2018 kello 14.43 
I dont have an APP DATA folder in my profile, where else could it be?
Omega+ lähetti viestin:
I dont have an APP DATA folder in my profile, where else could it be?

Search for %AppData% in the start menu possibly.
Omega+ 30.8.2018 kello 14.45 
Based MRE God Steve lähetti viestin:
Omega+ lähetti viestin:
I dont have an APP DATA folder in my profile, where else could it be?

Search for %AppData% in the start menu possibly.
No, only one that containes a "microsoft" folder and nothing else
So it’s basically turning off every graphics options?
D4rKaton 30.8.2018 kello 14.52 
Omega+ lähetti viestin:
Based MRE God Steve lähetti viestin:

Search for %AppData% in the start menu possibly.
No, only one that containes a "microsoft" folder and nothing else

Show hidden folders maybe?
Omega+ 30.8.2018 kello 14.57 
Katon lähetti viestin:
Omega+ lähetti viestin:
No, only one that containes a "microsoft" folder and nothing else

Show hidden folders maybe?
I had the game installed on my D:\ drive. I'm currently moving it to C. Will let you know if the folder still doesn't appear. Thanks for the help!
Daft Lad 30.8.2018 kello 14.58 
Does this basically set every setting to low?
Thank you OP for your contribuation.


Omega+ lähetti viestin:
Based MRE God Steve lähetti viestin:

Search for %AppData% in the start menu possibly.
No, only one that containes a "microsoft" folder and nothing else

You'll need to enable the option to view hidden files.

https://support.microsoft.com/en-us/help/14201/windows-show-hidden-files
Pass 30.8.2018 kello 15.15 
So much better for me. Thanks OP
I don't want to turn down all graphical settings to the lowest
Hadji* 30.8.2018 kello 15.21 
It feels better, and graphic settings weren't changed.
Pass 30.8.2018 kello 15.26 
Low and max settings give me the same horrible performance. this is the only thing that fixed it for me and it doesnt look like low settings so I dunno what it did
< >
Näytetään 1-15 / 196 kommentista
Sivua kohden: 15 30 50

Lähetetty: 30.8.2018 kello 14.33
Viestejä: 196