Insurgency: Sandstorm

Insurgency: Sandstorm

View Stats:
SMOOTHNESS....
as im playing i get roughly on average 90/100 fps.. just the game stutters so hard.. its hard to aim properly,

not sure if there is a fix out there but any help would be greatful

gtx 970 4690k oc 16gb ram
< >
Showing 1-15 of 28 comments
I noticed the stuttering was serverside. Try a coop server.
Nemukka Mar 3 @ 8:23am 
I have the same stutter. Can't play. I have over 100fps but it feels like 40fps.
Try Step 2:
https://steamcommunity.com/app/581320/discussions/2/1743353798891720635/

*If you have to experience a performance decrease from an old build to the current build, please try a fresh install of the game or removing the contents of your app data folder found in “%LOCALAPPDATA%\Insurgency\Saved\Config\WindowsClient

clearing that folder worked for me and removed stutters
Yes same here... never been this bad even off a SSD, same specs but 1070.
Elemeno. Mar 3 @ 11:36am 
nah i cant play this... its like im getting 10 frames while im turning... i tried deleting that folder and no joy..

change the settings from high to low..

every dev i ask seems to shy away from the question.. ive asked on twitter,facebook,reddit and steam forums and nothing.
Originally posted by Elemeno.:
nah i cant play this... its like im getting 10 frames while im turning... i tried deleting that folder and no joy..

change the settings from high to low..

every dev i ask seems to shy away from the question.. ive asked on twitter,facebook,reddit and steam forums and nothing.

Dude, I'm getting the exact same issue as you!! before the update, everything was fine, but now? I can't even turn without my game feeling like I have some sort of turning speed throttling happening. Really, really choppy and unplayable now.

Such a shame. I loved this game.
I can't even aim, there's no point in playing currently. Issued came up after the latest update and I deleted INI files, uninstalled with Revo Uninstaller and re-installed the game. Frustrating.
Try my Steam guide, it has worked wonders for most people! Check it out HERE. It might help with that.
Tried.. still not working , developers are working this month to sort it
Originally posted by Elemeno.:
Tried.. still not working , developers are working this month to sort it

You shouldn't have to do the bulk of my tweaks anymore with the new 1.1.1 patch, they fixed most of the issues. Just a couple of the things I changed make sense anymore.
Aizenhart Mar 10 @ 11:56pm 
Set texture streaming to OFF. GPU to Max Performance in the control panel. Ragdoll count to Low. And try to set Physics to CPU and back to GPU. Also you can get less input lag with this: Nvidia Control Panel - Adjust desktop size and position - No scaling - perform scaling on : GPU
Same here all to low and every setting of streaming has been tried but none works.Hope the next big update is focus on shuttering fix.
Last edited by Lemonadeer ~★; Mar 11 @ 8:30am
VK.Uncy Mar 11 @ 8:35am 
Whole game stutters for you or only mouse movement?
Part of the issue is the game. Our servers seem to suffer from memory leaks. If you send multiple rcon commands you can easily kill a server.
Elemeno. Mar 11 @ 10:10am 
enemies movement stutters, get about 100 fps and it feels like 10 fps ... moving the mouse feels like it has input lag

i just cant play it.
< >
Showing 1-15 of 28 comments
Per page: 15 30 50

Date Posted: Mar 2 @ 3:55am
Posts: 28