Dota 2
Dota 2 > General Discussions > Topic Details
Brandon Potter Dec 27, 2014 @ 1:22am
Custom mode error - RenderDeviceMgr001
So I just downloaded the workshop tools and all that neat stuff, and I tried to play Warchasers by myself for the first time, but when I hit play, it crashes and there is a error pertaining to 'RenderDeviceMgr001' and I am hoping that someone has a fix for it? I cannot play ANY custom games with this issue.
< >
Showing 1-15 of 21 comments
Brandon Potter Dec 27, 2014 @ 9:24am 
Anyone?
Brandon Potter Dec 29, 2014 @ 5:54am 
Anyone got a solution for this problem at all?
NotRussian Dec 29, 2014 @ 6:10am 
I tried to play Pudge Wars and didn't work. Now I'm having fun with bots in -wtf mode.
Brandon Potter Dec 29, 2014 @ 8:11am 
Originally posted by KGB:
I tried to play Pudge Wars and didn't work. Now I'm having fun with bots in -wtf mode.
Well that must get boring quick :\
Brandon Potter Dec 30, 2014 @ 3:04pm 
Anyone have a solution for this issue?
Colapsis Dec 31, 2014 @ 11:54am 
yes i have this too
Brandon Potter Jan 1, 2015 @ 3:24pm 
Still looking for a Solution.
TiTi Jan 2, 2015 @ 4:07pm 
you can load it from workshop tools alpha I think, I have the same problem, I'll tell you if I fix it, maybe it launches on a wrong graphic card.. eh.
Brandon Potter Jan 2, 2015 @ 5:00pm 
Originally posted by TiTi:
you can load it from workshop tools alpha I think, I have the same problem, I'll tell you if I fix it, maybe it launches on a wrong graphic card.. eh.
Doesnt work. Tried to load Holdout in in teh tools, and doesnt work.
a tweet @tedcruz Jan 3, 2015 @ 7:13am 
I was able to effectively reproduce and solve this problem at least for myself. While this may be only one possible reason for this popping up, it is a potential solution for all of you.

First of all I only reproduced this issue by intentionally enabling the root cause which is to allow the 64bit Source 2 client to run in borderless fullscreen mode. Seeing as you can't actually get into the game to you know, fix this, go to ...\steamapps\common\dota 2 beta\dota_ugc\game\core\cfg and simply delete video.cfg, alternatively you can open it and flip the setting for it ("setting.nowindowborder" from 1 to 0).

Like I said, this might not be the only cause, but it is a fix if it is for you.
Brandon Potter Jan 3, 2015 @ 8:54am 
Originally posted by VAY HEK'S EASY ADVENTURE:
I was able to effectively reproduce and solve this problem at least for myself. While this may be only one possible reason for this popping up, it is a potential solution for all of you.

First of all I only reproduced this issue by intentionally enabling the root cause which is to allow the 64bit Source 2 client to run in borderless fullscreen mode. Seeing as you can't actually get into the game to you know, fix this, go to ...\steamapps\common\dota 2 beta\dota_ugc\game\core\cfg and simply delete video.cfg, alternatively you can open it and flip the setting for it ("setting.nowindowborder" from 1 to 0).

Like I said, this might not be the only cause, but it is a fix if it is for you.
Just looked into that folder, and theres is no video.cfg O-o

Did a search, and there is no video.cfg in my entire Dota folder.
Last edited by Brandon Potter; Jan 3, 2015 @ 8:55am
a tweet @tedcruz Jan 3, 2015 @ 9:11am 
Originally posted by Brandon:
Originally posted by VAY HEK'S EASY ADVENTURE:
I was able to effectively reproduce and solve this problem at least for myself. While this may be only one possible reason for this popping up, it is a potential solution for all of you.

First of all I only reproduced this issue by intentionally enabling the root cause which is to allow the 64bit Source 2 client to run in borderless fullscreen mode. Seeing as you can't actually get into the game to you know, fix this, go to ...\steamapps\common\dota 2 beta\dota_ugc\game\core\cfg and simply delete video.cfg, alternatively you can open it and flip the setting for it ("setting.nowindowborder" from 1 to 0).

Like I said, this might not be the only cause, but it is a fix if it is for you.
Just looked into that folder, and theres is no video.cfg O-o

Did a search, and there is no video.cfg in my entire Dota folder.
Yea like I said, there are bound to be a handle of other issues that result in this same error, so if this one doesn't work (or in your case, isn't even the proper cause/solution) then sorry. :[
Brandon Potter Jan 3, 2015 @ 9:24am 
Originally posted by VAY HEK'S EASY ADVENTURE:
Originally posted by Brandon:
Just looked into that folder, and theres is no video.cfg O-o

Did a search, and there is no video.cfg in my entire Dota folder.
Yea like I said, there are bound to be a handle of other issues that result in this same error, so if this one doesn't work (or in your case, isn't even the proper cause/solution) then sorry. :[ [/quote]Tis ok...

Atleast your the first to try and help >-<
Brandon Potter Jan 7, 2015 @ 5:09am 
Still waiting fo help on this.

Pretty bad :\
Rty139 Jan 8, 2015 @ 7:52am 
Have the same problem. No idea how to solve it :/
< >
Showing 1-15 of 21 comments
Per page: 15 30 50

Dota 2 > General Discussions > Topic Details
Date Posted: Dec 27, 2014 @ 1:22am
Posts: 21