Dota 2
Dota 2 > General Discussions > Topic Details
How to fix RenderDeviceMgr001 error
I got this error because Dota Reborn (Source 2) doesnt support borderless window mode (which i have enabled for dota).

All you gotta do is either jump into Dota 2 (normal) and disable it (easy way). Or you can go into your SteamLibrary\SteamApps\common\dota 2 beta\dota_ugc\game\dota\cfg and open the one called "video.txt" and set the "setting.nowindowborder" from 1 to 0.

And thats how i fixed this. there might me some other issues regardin this error, it might be your drivers (updating them fixes the problem) and it also might be DirectX (updating fixes as well).

I hope i helped you, if i did, please comment so everyone can see this!
Last edited by █▄ █ ▀█▀ ▀█▀; Jun 26, 2015 @ 9:18am
< >
Showing 1-12 of 12 comments
GaboAbo Jun 26, 2015 @ 8:13am 
i still have the error and i don't have that folder in my directory "dota_ugc"
Originally posted by Roko:
i still have the error and i don't have that folder in my directory "dota_ugc"

Then you havent downloaded Dota 2 Reborn
GaboAbo Jun 26, 2015 @ 12:10pm 
yes i have the reborn. a friend has the same folders as me and can play
Well, then, try to disable borderless window and set it to fullscreen through normal dota 2, close it and then try opening reborn
Domenco Jun 26, 2015 @ 6:30pm 
what makes you say it doesn't support borderless windowed mode? Reborn boots up the first time with ALL settings resetted besides keybinds. I activated borderless fullscreen without any problem.

So either back this up with a source or dont speak half truths.
Well it fixed after i edited the "video.txt" file as described above, want some more proof to back this up than personal experience?

Also, i activated borderless again with no problems, didnt do anything else and if you try and read the last section, i said it might be due to drivers and directx as well
no Sep 27, 2015 @ 10:53pm 
well i had the same problem, i fix this problem on the launch option go to properties of your dota 2 and in general sub menu click on the "set launch option" i fill that with " -dx11 -fullscreen " (without quote) and click ok then voila your dota can be played again!
hope it works
Atin_Negs Sep 28, 2015 @ 7:22pm 
don't bother to change the 1 to 0. just simply delete the video.txt
it 100% works :)
UNKNOWN Nov 19, 2015 @ 7:52pm 
Originally posted by no:
well i had the same problem, i fix this problem on the launch option go to properties of your dota 2 and in general sub menu click on the "set launch option" i fill that with " -dx11 -fullscreen " (without quote) and click ok then voila your dota can be played again!
hope it works

Thanks thanks thanks thanks thanks this post really helpful
HEIL Hitler Nov 29, 2015 @ 12:48pm 
Originally posted by no:
well i had the same problem, i fix this problem on the launch option go to properties of your dota 2 and in general sub menu click on the "set launch option" i fill that with " -dx11 -fullscreen " (without quote) and click ok then voila your dota can be played again!
hope it works
DUDE TY A LOT I FIX THIS F..... PROBLEM .... it work 1000 % ... ty a lot <3 <3
Clare Jan 19, 2016 @ 12:39pm 
can confirm that the ^above solution works
Big BossMan Jan 24, 2016 @ 8:53am 
none of those solutions worked for me, i rebooted my pc and it runs normally but this happened again later
< >
Showing 1-12 of 12 comments
Per page: 15 30 50

Dota 2 > General Discussions > Topic Details
Date Posted: Jun 26, 2015 @ 4:10am
Posts: 12