Left 4 Dead 2

Left 4 Dead 2

View Stats:
L4D2 DS Server Crash issues
After the update this week, my server has become increasingly erratic. When any lobby attempts to connect to the server, it crashes with the error:

"The instruction at '0x31504247' referenced memory at '0x31504247'. The memory could not be 'read'."

I have re-installed everything, I have started it in every possible way, with and without mods, and even with "vanilla" server.cfg files. Nothing has worked, all have resulted in the same error message. The ONLY way to play on the server right now is to direct connect, by using the "connect IP" command in console, allowing people to join off my name. However, this poses a problem in allowing others to play.

Any info or possible fixes are appreciated.
< >
Showing 1-15 of 19 comments
[uA.O] Shadow Jan 18, 2013 @ 6:58pm 
You are not the only one having this issue. 28 of our servers were fubared with the update, crashing on any client connection. Need a fix like... NOW!
Im sad to hear that you guys are having similar issues, my guys have lost both our servers to this issue. If you get any info, please let me know, I will do the same.
Glad that valve hasn't even commented on these issues. Shows how much they care about those who keep the content for their games pushed to the masses. Apparently my $50 wasn't good enough for them.
juxe Jan 19, 2013 @ 12:06am 
Having the same issue. Since the update I can't connect to my server.
We still have no reply or even acknowledgement from Valve.
Harold bot☢ Jan 19, 2013 @ 8:21am 
Playing L4D1 until server is fix
Our server is having the same issue. We load as Versus from lobby and it puts us into a campaign stuck on Parish. We can change the map from inside the game however we are unable to even start a campaign from lobby on lets say No mercy. We have been working with NFO our server provider and still have no resolution to the problem. I few people we asked mentioned this.....it's matchmaking based, as this creates a "Lobby Reservation" token. If you try and connect to your server from lobby (Regardless of using sv_search_key/Steam groups/mm_dedicated...) it will cause the server to crash immediately on connect. You're still loading though, then the server restarts, which loads the first map of the game.
We tried uninstalled and reinstalling with mods and without still same issue. We even tried forcing our serving as a VS only server. Nothing....Same issue...stuck on Parish from lobby...we can however change the campaign map in game just not through lobby.
Yep, exact same issue I am having. Mine is set to Dead Center as my default map. It sounds as though your server is auto-restarting after crash, mine isn't set up to do that (So I can debug on the fly). It sounds like this is a common issue among server owners now, and we have all taken similar steps (I have reinstalled, tried every combo if mods, turned it all off, even wiped my server and tried vanilla).

Valve has just kicked the server owners in the teeth, and hasn't even acknowledged it.
We have ours working a bit. We can now load from lobby into a VS game. However, the map still changes to our default which is No Mercy and we wanted Dead Air. We can however, change from inside the game. At least VS is working for now. I know there are alot of people still having server issues. I'm not sure what my co-leader did but it had to do with the autoexec.cfg file in ftp. Thanks Valve....man they need to get their life together.
Yes, but I dont want to be making workaround solutions, lets get the game working the way it should be.
Hambone Jan 20, 2013 @ 8:56am 
I run another of our group's servers, and I'm experiencing the same issues. Server starts, try to join and server crashes / restarts.
Spooky Booty Wurk Jan 20, 2013 @ 10:46am 
I'm having a similar issue but not with a server i have. Whenever I try to play single player i.e. host a local match the game crashes to my desktop. However i can join other severs and multiplayer matches fine. Even loading with the "map" command crashes. I don;t know what they did with this update but they surely went wrong somewhere.
MorbidTorture Jan 20, 2013 @ 11:40am 
This game has always ran right for me until here recently. Everytime I try and join an online campaign game or host one I always get the "Server is not available" The server may be offline or you may not be connected to the internet." Even though it displays this message I can still play the game online and with others, but it's MEGA laggy! What gives?
Hopefully Valve does something to fix it tomorrow.
Update: Valve is investigating and has put out a new version. Update your servers, hopefully the update fixed the issues!
< >
Showing 1-15 of 19 comments
Per page: 15 30 50

Date Posted: Jan 18, 2013 @ 6:54pm
Posts: 19