Left 4 Dead 2

Left 4 Dead 2

Näytä tilastot:
Won't finish downloading (Stuck at 99%)

A friend gave me a copy of L4D2 as a birthday present and since then there is no way for me to install it in my computer, I could install Zeno Clash and Portal 2 with no problems at all, but when it comes to L4D2 and GTA IV there is nothing i can do to get past the 99% mark.
I tried all i read from the FAQs and i sent a ticket to Steam 2 weeks ago, i still dont get an answer from them.

What i have done:

-Deleted the .blob file
-Repaired Steam
-Re installed Steam
-Changed download region and speed
-Changed my PC's non-unicode language to english (read in the forum that this could work, didn't)
-Deleted the temporary files of those downloads to force them to check all files (did it 3 times)
-Re downloaded the games (3 times and counting)
-Tried to update/download the games on "Safe Mode" (didn't work)
-Opened my Router's ports
-I'm not using Wi fi (using an ethernet cable)
According to what i read, Wizard Harry, another Steam user had the exact same problem and he fixed it by re installing windows. (He had windows 8, i'm using Windows 7, 64 bits)

I ran out of ideas, and steam's support is not very helpful. So, if you guys could tell me what to do next, it would be great, i dont want to loose my hopes on Steam.

By the way, i'm downloading this from Chile (South America), my friend had no troubles to install it, so i don't know if it is up to my PC or my ISP, all i know is that 2/4 games work well while the other 2 just won't.
< >
Näytetään 1-15 / 15 kommentista
PD: since i can't edit my previous post (or i just don't know how)

I already verified the cache of the games, did it like twice and it did not work.

I can play L4D2 but i have to open the exe. file. It works just fine but, it says that i have -insecure in the launch options, so i can't join VAC secured servers. So maybe my problem is related to VAC. But with GTA IV i tried to open the exe. when it was at 99%, but the game just did not launch. It was on my tasks administrator, but i couldn't use it, my computer froze.

In case you wonder, my computer meets all the requirements.

I could use some ideas.

Thanks for reading.


Edit1: Nevermind, i found how to edit my own posts, the option was at the top right corner.
Viimeisin muokkaaja on Arkhantak; 10.12.2012 kello 11.40
Styks 9.12.2012 kello 21.55 
I am having the same problem, though I can even get it to play by opening the exe. file.
Im Downloading from Washington State North America. My friends have downloaded the game with no problem and are playing it but I cant get it past the 99%
First try bypassing your router. As in connect directly to the Modem.
Also, disable your virus scanner and firewall. And disable Window's UAC functions.
Viimeisin muokkaaja on Hydra_360ci; 10.12.2012 kello 7.37
Arkhantak 10.12.2012 kello 11.39 
Mac Tíre Nexy's lähetti viestin:
I am having the same problem, though I can even get it to play by opening the exe. file.
Im Downloading from Washington State North America. My friends have downloaded the game with no problem and are playing it but I cant get it past the 99%

you can't, right? well to open the exe. i have to do it with admin properties. and when i do it, an alert saying that i have -insecure in the launc options comes out from nowhere. Also if i don't open Steam i can't launch L4D2. I don't know if the client won't finish installing it, because i can play normally the campaigns, and i think i can join non secure servers, like dedicated ones that don't use VAC, but i haven't tested that.

Hydra lähetti viestin:
First try bypassing your router. As in connect directly to the Modem.
Also, disable your virus scanner and firewall. And disable Window's UAC functions.

Thanks for answering, first of all, i dont have an antivirus since they do nothing other that consuming RAM, what i do use is a firewall, my router's one and windows' one. I disabled both before opening steam and nothing happend. I also disabled windows' UAC functions (i disabled that function the very first day i installed windows in my PC). Didn't work.

Bypassing my router... I have always had a confusion between what a router and a modem is. I'm using this model: motorola wireless cable modem gateway SBG900
It says it is a modem, but when i looked for info. to unlock some ports they said it was also a router so i'm confused. I haven't looked for that kind of information yet.

How do i get to know if i'm using a router or not, and how do i bypass it?

Networks... That's where i need to research a lil bit.

Thanks for reading and helping.
Your modem is probably a combined router and modem, then. 2 in 1 type of thing, in which case, you can't bypass.

Is this it?
If so, that's just a modem, but with Wifi capibilities. It only has one ethernet port, though. So, you don't have a router, you should be connected directly to the modem as long as you use an Ether cable. The router term for that modem is likely due to the WiFi portion. Which really isn't a router per say, but more of a radio broadcast thing.

A router basically is a splitter for that single ethernet port on your modem. It branches that single ether net cable into multiple ports. So the Router goes in between your PC's and the modem. (so, you don't have a router.)

This is a router:
And you can't get internet from it alone, it's just used to branch 1 port into 4. Note the picture that shows the back. So the cable from the internet goes into the most left port, and it branches into the 4 on the right. And the router also doubles as a firewall, which is why you bypass it for troubleshooting. But none of that matters in your case.

I'm guessing you've already tried the verify game cache' too?
If you do try it, it may hang, though, or look like it's hanging. Problem with the verify game cache is that it can't work in the background. Steam won't even let you click anything without giving out that annoying ding noise. There is a cancel button though.

When it looks hanged in that verify game cache'. To tell if Steam Client is downloading something, open up task manager, go to the Network tab, and see if the graph is active.

I've had an install stall at 99% before, but changing my download region to Dallas from Houston, got it to work.

Did you modify Windows to access a different drive for My Documents? (people with SDD's usually do that.) I don't know if L4D2 has a problem with that, but Xcom: Enemy Unknown did.
Viimeisin muokkaaja on Hydra_360ci; 10.12.2012 kello 13.01
Arkhantak 10.12.2012 kello 13.20 
Thanks, now i can tell the difference between a router and a modem, you are very helpful.
Yeah, that's my modem, and no, according to what i read in your post, i'm not using a router. So that's not my problem.
I already verified the game's cache and there were no problems at all. Although i will try it again and i will report later.
Now i will try changing my download region again and i will open the task manager to see if it is downloading or not.

Hydra lähetti viestin:
Did you modify Windows to access a different drive for My Documents? (people with SDD's usually do that.) I don't know if L4D2 has a problem with that, but Xcom: Enemy Unknown did.

I would like you to explain that to me, since english is not my native language, i dont really know what you are talking about. (Or maybe english has nothing to do with it =P)
my hard drive is a regular one (Seagate Barracuda 500 GB blue)
just tell me how to do it and i will do it, i don't think there would be a problem.

Well, let me thank you for helping me out, i'm glad to know that there is always a person willing to help. If there is something i can do for you, just let me know.

Thanks for reading and helping.
Viimeisin muokkaaja on Arkhantak; 10.12.2012 kello 13.22
Then I wouldn't worry about it. (I made a mistake anyways, I meant to say SSD, not SDD.) http://www.newegg.com/Product/Product.aspx?Item=N82E16820148448

SSD stands for Solid State Drive. They are expensive for their size and aren't good for a lot of saving/writing. The more you save to them the slower they get. But they have no moving parts and read/write much faster than any mechanical Hard Drive. So, some people modify windows to move the My Documents part of windows onto a standard Hard drive, so that the SSD doesn't have to deal with game saves. And with Windows modified, like that... it could cause problems with other software. Xcom doesn't like it, anyways. Probably, has no effect for Steam downloads, though. Come to think of it I think the stuff I read said that Xcom would just crash, not that it would stop at 99% on the download.

Anyway... the verify game cache' checks your files against Valve's and downloaded any files that are missing. I wouldn't have thought that it would complete if the download is stuck at 99%. If anything I would have thought that it would hang on that bar graph thing that the verify game cache' triggers.

Does the download say suspended?
When I get downloads that do that, I push the pause button for the game, then click on the resume all button that's on top. That usually causes the download to continue, for me. When that doesn't work, i just leave it be, and it's usually gone the next day. But that's always been for TF2, HL2 and Day of Defeat, updates for me and rare, at that.

(Likely when they mess up a patch and happen to stop it before I can get it. And I don't think that would apply with L4D2 at the moment....)

I have a feeling that some sort of security function of Windows is keeping the download from finishing. But, I don't know what it could be.
Viimeisin muokkaaja on Hydra_360ci; 10.12.2012 kello 14.25
Arkhantak 10.12.2012 kello 14.31 
Hello, thanks for helping.

I did verify the cache and it is just the same, it took like 5-10 mins and it said there were no problems, i changed the download region again and it didn't work. i was checking widows task manager.

The download does say it is suspended, i have the same problem with GTA IV.

I do believe it has something to do with windows, but i don't know what it is, i also tried to update the game in safe mode but it didn't work.

I have paused and un paused the download many times, but it does nothing. I have been waiting for almost 2 weeks and it just won't resume the download. Any ideas are welcome.
Only solution I've seen, you're not going to like....
They reinstalled windows.
Arkhantak 10.12.2012 kello 15.20 
Hey, yeah i came across with that solution too, but it that fixes my problem then it means there is something (either a program, a function, a service, a hidden monster, a ghost) that's living inside my PC and won't let me play L4D2 nor GTA IV...

So if i get to fix it by re installing windows, that means there has to be another way to solve my problem. (that's what logic is telling me).

Thanks for helping
don't reinstall windows, I tried it today, didn't help, im stuck with CS GO at 98% and tried changing regions locale everything still nothing :(
Uh, didn't notice this thread was from 2012? Also, fyi it is the game that needs to be compatable with your operating system, not the other way around.
I know it's old, but are you still having that problem? I have several games that get stuck at 99, but I had 1 a while ago that randomly passed even though it wouldn't before. If anyone would help still on this old post, if I moved my computer to a different internet network (like a friend's house) what are the chances of my games getting past 99%
I'm not, i had to ask my ISP for a new modem, and then it just worked, i did nothing out of ordinary, now i bought my own router and i'm not having any problems at all.

If it is a notebook, then just do it, i'm pretty sure it will fix your problem, what could go wrong?

I did research a lot about the topic, but i just couldn't get a grasp of what happenend inside my modem, i tried almost every solution i found on the web, and when i gave up my ISP solved it in 5 minutes.

Good luck with your problem.

BTW this is a really old post, you should have started a new one and linked this one as a reference instead.
< >
Näytetään 1-15 / 15 kommentista
Sivua kohden: 15 30 50

Lähetetty: 9.12.2012 kello 20.30
Viestejä: 15