Left 4 Dead 2

Left 4 Dead 2

View Stats:
Alharich Mar 24, 2013 @ 11:53am
"Could not load library client"
Well, I got the game and played it once, I really liked it.
The next day i decided to play Left 4 Dead 2, and it launched normally.
Everything was fine until the intro scene was over.
The first loading screen after intro crashed.
And the game said: "could not load library client".
I was confused, and I tried to launch the game again but the same thing happened.
I tried about 10 times to launch the game but nothing happened.
I reinstalled the game but it didn't help.
It keeps saying "could not load library client"
So please if you are reading this and you know how to help me with this annoying problem,
feel free and help me, please.
I would really appreciate your help!
Thank you.
< >
Showing 1-12 of 12 comments
Gbane Mar 24, 2013 @ 12:05pm 
Try verifying steam cache that mostly fix all of the problems.
Seregalak Jul 17, 2013 @ 6:09am 
Same problem. The game still not works.
Labusedebase Sep 24, 2014 @ 3:24am 
Same problem ! Is it solved for you? And how ???
Seregalak Sep 24, 2014 @ 3:35am 
No, still i have the problem.
Labusedebase Sep 24, 2014 @ 5:32am 
I may have found a solution by changing the ntfs rights to the "client.dll" file.
1) Right click on the file properties
2) click on Advanced Security
3) Delete all accounts
4) Add "all users"
5) Deny all rights and OK
6) Change the rights and allow "Read and Execute" OK

I started the game and I can even play. The file is still present. I left steam launched the game again and the file is still present

I have not tested after a reboot but I am hopeful.
I hope it will help
There are a ton of postings about this exact problem. Did you make the effort to search?
Labusedebase Sep 24, 2014 @ 6:15am 
Yes i did !

I tried to verify the cache, the file is downloaded again but also deleted when launching the game again.

I tried to uninstall the game by removing local files and reinstalling but the problem persists.

I checked the updates to my graphics drivers

I consulted various forums people seem to encounter the same problem but I have not found a solution.

So I contacted the support that made me remove and install steam

The problem is not solved and because the file is deleted I decided to remove the rights of deleting and modifying. It seems to work

If there is a formal solution thank you's to give !!
Last edited by Labusedebase; Sep 24, 2014 @ 6:15am
Seregalak Sep 25, 2014 @ 2:29am 
I'm sorry but i can't do what you said. Can you explaine better?
I think it's my fault but everytime i wrong i need to verify the cache for recreate the file, funny think cause i deny to delete the file ^^
Seregalak May 1, 2015 @ 6:37am 
New Computer. The problem is still there.
Someone find something?
Seregalak May 1, 2015 @ 8:05am 
It works!
Thank you so much!
< >
Showing 1-12 of 12 comments
Per page: 15 30 50

Date Posted: Mar 24, 2013 @ 11:53am
Posts: 12