Left 4 Dead 2

Left 4 Dead 2

View Stats:
Chilean Boy Mar 23, 2013 @ 3:15pm
Is Steam blocking my account? Unexplicable issues. I've tried everything. Links to youtube samples!
Hi everybody:
I have a lot of problems with L4D 2, I cannot play it normally, something fishy is going on.
First of all, I've tried EVERYTHING so I give up: unistall/reinstall either the game or Steam, defrag the game, the HDD, reinstall drivers (LAN controller), uninstall antivirus, turning off Windows firewall, clean/rename folders, allowing L4D 2 register, update router's firmware... I'm on a decent rig and the game worked a time ago... intel 7, GTX 660, 12GB RAM, 100mb/s internet connection.. My PC or internet is NOT the problem.
The problem consist in: 1. The game loads up to 70% then nothing happens and I have the time out message. Most of time I donät have the patince to wait the time out massege, so I skip the game by pressing CRTL+ALT+DEL
2. While in-the-game, I play some seconds, then I get stuck. The game looks keep running, everybody but me. Most of time I have the time out message if nobody had kicked me off.

Here are some videos I have uploaded to youtube:
1) http://www.youtube.com/watch?v=lKOzhZMQA70
2) http://www.youtube.com/watch?v=APruCtnSRac
3) http://www.youtube.com/watch?v=ZsAJLxsHBvk

It's a very irritating issues because the game is unplayable. Sometimes work fine, but it is a exception.
I have tried everything that the support suggest me.. Have you any idea???? Thanks in advance, me.
< >
Showing 1-4 of 4 comments
flyinghitcher Mar 23, 2013 @ 4:09pm 
Support sucks, they couldn't even guess my OS from the direct X report I sent.
Pinkette Mar 23, 2013 @ 5:53pm 
verify game cache maybe? I'm not confident thats your fix but worth a shot. check addon and workshop folders DELETE EVERYTHING out of both folders.
Pinkette Mar 23, 2013 @ 5:55pm 
Got a solution by Valve a week ago. Thanks a lot Valve

"Please exit Steam and go to the folder called C:\Program Files\Steam\ (this is the default location for a Steam installation - if you set a different installation directory, you will need to browse to it).

Delete all of the files in this folder except:

The Steamapps folder and Steam.exe (this file is listed as an application and features the black and white Steam logo)

Restart your computer.

Then, you will need to launch Steam.exe from within the Steam installation folder, and not from a pre-existing shortcut.

With Steam running, re-test the original issue.

Note: This process will not affect your currently installed games.

Additionally, please complete this process for your installed game(s):

Title: Verifying Game Cache Files (GCF)
Link: http://support.steampowered.com/kb_a...2037-QEUH-3335 "

source: http://forums.steampowered.com/forums/showthread.php?t=1200179
Last edited by Pinkette; Mar 23, 2013 @ 5:55pm
Chilean Boy Mar 24, 2013 @ 12:06pm 
Hi Detox. Thanks for the tip but I have already tried it and doesn't work for me. I have deleted those files and the game runs a bit better at first, the the problems strike back. One thing is for sure: L4D 1 (the original version I also own) works fine though.
< >
Showing 1-4 of 4 comments
Per page: 15 30 50

Date Posted: Mar 23, 2013 @ 3:15pm
Posts: 4