Left 4 Dead 2

Left 4 Dead 2

View Stats:
BruceCheE May 16, 2014 @ 3:22pm
L4d 2 crashes on start!
since 2 days, the game is crashing directly when i try to start it from steam. i reinstalled it allready and checked the gamefiles with steam, but it didn´t help. any other solutions out there?
< >
Showing 1-15 of 19 comments
V-Pariah May 16, 2014 @ 4:12pm 
Are you using the Steam beta?

I just tested this for a couple days (when the symptoms started for me as well) and I've noticed that if I play L4D2 on the non-beta steam version, I can play the game for a while but it will crash at a random time during gameplay as a result from steam unexpectedly crashing.

When I tried it on Beta it would crash instantly. Whatever the developers did, it must have exacerbated the issue. Hopefully they can fix it?

PS. Coincidentally, there was a Windows 8.1 update just a couple days ago, and it seemed to have fit the time that I updated it and when the crashes started happening, but I couldn't find any fix by uninstalling said updates, so I tried Steam Beta and thus made this discovery.
Moșu May 16, 2014 @ 4:16pm 
conflict between custom addons (usually maps) and default game settings. Uncheck all custom maps and check it, if you really want to play it. (in that moment)
V-Pariah May 16, 2014 @ 4:23pm 
I don't actually have any custom addons. The crashes on non-beta Steam happened on the stock campaigns. Although, I could try messing around with the video settings.

EDIT: no dice. I might just wait to see what happens in a future update. It's literally the only game with problems that I have.
Last edited by V-Pariah; May 16, 2014 @ 4:53pm
BruceCheE May 17, 2014 @ 6:54am 
i had no addons installed. beta and the normal version aren´t working for me. i reinstalled the game and steam, but i didn´t help. now i deleted the left4dead 2 folder in the steamapps folger and reanstalling l4d2 again. hope it will work.
For me too, beta and non beta crashing. I disabled all customizations and it keeps crashing. Seems that happens only in Windows 8.1.
BruceCheE May 17, 2014 @ 7:39am 
i´m on windows 7 x64
Left 4 Dead 2 and TF2 crashes because steam. L4D2 just crashes but TF2 stays in sound looping and you need press Ctrl + Alt + del.
Goop May 17, 2014 @ 7:57am 
I'm also having issues the last 3 days with L4D2 hanging in game (sound looping). Tried lowering sound quality...did all the usual stuff and nothing. 2 days ago I was able to rollback updates and it seemed okay but then something auto updated on me last night and screwed it all up again. And no roll back this time.
Last edited by Goop; May 17, 2014 @ 7:57am
BruceCheE May 18, 2014 @ 7:48am 
problems are gone since a fresh windows installation. i think it had something to do with the windows security updates from the 15th
V-Pariah May 18, 2014 @ 9:47am 
Hmm, yeah.

I posted in that CS:GO thread, but I'll post here as well. If you do decide to install updates again (as a test), I have a possible solution.

For me, last night, I could play on non-beta Steam client after uninstalling Geforce Experience (for NVidia users). It seems to require Steam to be closed in order for Experience to uninstall, so the solution probably has some merit.

I also ran Steam as an admin. I'm not sure if that had merit, but it's worth trying I guess. Anyways, good luck!
BruceCheE May 18, 2014 @ 1:44pm 
i can tell you tomorrow if the security updates are responsible for that. all i can say is that i had this problems since the 15th. on my new installation it works fine so far. let´s se if it works when windows has installed all the updates again including the ones from the 15th.
Alienkiller32 May 18, 2014 @ 7:57pm 
have you tried restarting you computer
win™ May 19, 2014 @ 3:38pm 
Does it crash when you load a maP?
Or when you start the game.
Last edited by win™; May 19, 2014 @ 3:39pm
Knight-Crawler May 19, 2014 @ 3:41pm 
The game is crashing while I play the single player mode it all of the suddent closes.. I'm using windows 7 ultimate
< >
Showing 1-15 of 19 comments
Per page: 15 30 50

Date Posted: May 16, 2014 @ 3:22pm
Posts: 19