Left 4 Dead 2

Left 4 Dead 2

View Stats:
Chuck McDanger Jan 30, 2014 @ 4:42pm
Loading screen game launching failure!
Every time i go to load a game, no matter what game mode, it loads half way and then exits out of the game with no message or anything. Ive reinstalled 3 times and hasn't fixed it. It ran on my old PC fine but now that i have a new one it just wont play. help.
< >
Showing 1-9 of 9 comments
rontonik Jan 30, 2014 @ 7:47pm 
Try to delete ClientRegistry.blob file.It is in the primary folder C:\Program files\ Steam. Move it for any case to other place though. Restart Steam and wait it updates. This solved problems with some games I had when verify cache was useless.
Chuck McDanger Jan 31, 2014 @ 9:57am 
It didnt work, but then again my game didnt update. should i wait till it updates by itself?
Matadim Jan 31, 2014 @ 11:06am 
That happens to me too....

rontonik Jan 31, 2014 @ 1:17pm 
A pity that my advice did not help you, me and some other people I told to do this solved the problem you have. I said wait Steam updates after you moved or delete ClientRegistry.blob , not the game. The game is already updated as you just re- installed it. Even though try to verify cache.
That other things I found on net : How to fix random crashes of L4D2 to the desktop.
There are two possible solutions that might do the trick. First one would be to turn off the gore in the game – to do so right click on the Left4Dead2 executable and click properties. Click on Set Launch Options… and add -lv at the end of the line.
Another solution, offered by a moderator on the Steam forums, is to close Steam and go to the steamapps folder in the Steam installation folder. Delete the files “left 4 dead 2 client.ncf” and “left 4 dead 2 common.ncf”, restart Steam, right click on L4D2 and install.

Left 4 Dead 2 doesn’t run after the installation
Strangely, this is the most reported problem. It usually affects people running Vista or Windows 7 because the game requires Steam Service to run – and fixing it could fix the problem. Fortunately, a Valve representative teaches us how to fix this problem via the official forums. This is what to do:

a) First fix: Exit Steam and open Command Prompt in windows then run “c:\Program Files\Steam\bin\SteamService.exe” /repair. Start Steam and run the game. Hopefully it works.
b) If it doesn’t, try this new trick: Exit Steam and delete the file SteamService.exe (located in the Steam installation folder) then restart Steam.
c) If this doesn’t fix the problem either, you could try a last thing: exit Steam, Head over to Control Panel → Programs and Features, right click on Steam and click Repair. It will take a while but it will probably worth the wait.

I am not sure if the problem with Steam service, if you can run other games. These are options offered on net. Try.
Make copy of your files for any case.
Chuck McDanger Jan 31, 2014 @ 5:19pm 
First off one thing i noticed is that when i remove ClientRegistry.blob after i exit out of steam, when i log back on it doesnt update and the file appears again. Turning off the gore in game didnt seem to work either. When i went to remove the common.ncf and the client.ncf, i removed the common but after searching for a while i could not find the client.ncf. The only games i havent been able to run is Star wars battlefront 2 for some reason, and the same thing happens when it just exits as its loading the game. Other than that i can run everything on high. Specs: WIndows 8 x64, AMD 6 Core, Raedon HD 7750, 8gb RAM.
rontonik Jan 31, 2014 @ 8:22pm 
Good, you said that you have Windows 8. I read that many people report that they can not play this game, especially with AMD and that others can play without problems. Did you do verify cache also as I said, even though you re-installed it, do it anyway ! It helped some and was useless for others. Also check the video settings of game in menu, as they are reseted now to default, set trilineal filtering, medium matiz, disable multi-core, disable Vsync, memory page to medium or low...etc...try. Also read these http://steamcommunity.com/app/550/discussions/0/846940249041064949/
That is all I could do for you. Good luck.
Santa Jan 31, 2014 @ 8:26pm 
is good
Chuck McDanger Feb 2, 2014 @ 5:43pm 
FIXED! Windows 8 and some versions of 7 are missing realtek drivers that are essential for some games. This fixed all the games that i couldnt run before. Heres a link to the official site to download the drivers for whoever needs it.
rontonik Feb 3, 2014 @ 7:16am 
Great! I am very glad that you solved it. I would never imagine that the problem was related to audio driver...hmm. Weird things of new OS.
< >
Showing 1-9 of 9 comments
Per page: 15 30 50

Date Posted: Jan 30, 2014 @ 4:42pm
Posts: 9