Left 4 Dead 2

Left 4 Dead 2

View Stats:
Ultraviolet Jul 12, 2014 @ 12:56pm
Graphics Glitch showing blocky colors in "white" bloom areas on L4D2. GTX 770
Hi. Ever since I built my new PC, I've been having this issue with L4D2 only. Areas of bright white, including flames, white shirts, lots of the sky, flashlights, show blocky teal, red, blue, or green. Sometimes it will fade away after I look at it for a second or from a different angle. It's pretty annoying. I think it may be caused by bloom or something? Any help would be appreciated. I've included a few images.

Looking at the glitch. [i.imgur.com]
After the glitch fades.[i.imgur.com]
How it looks in flames. [i.imgur.com]

My system information:

Processor Information:
Vendor: AuthenticAMD
CPU Family: 0x15
CPU Model: 0x2
CPU Stepping: 0x0
CPU Type: 0x0
Speed: 4018 Mhz
8 logical processors
4 physical processors
HyperThreading: Supported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Supported
SSE41: Supported
SSE42: Supported

Network Information:
Network Speed:

Operating System Version:
Windows 8.1 (64 bit)
NTFS: Supported
Crypto Provider Codes: Supported 311 0x0 0x0 0x0

Video Card:
Driver: NVIDIA GeForce GTX 770

DirectX Driver Name: nvd3dum.dll
Driver Version:
DirectX Driver Version:
Driver Date: 4 Mar 2014
OpenGL Version: 4.4
Desktop Color Depth: 32 bits per pixel
Monitor Refresh Rate: 59 Hz
DirectX Card: NVIDIA GeForce GTX 770
VendorID: 0x10de
DeviceID: 0x1184
Number of Monitors: 1
Number of Logical Video Cards: 1
No SLI or Crossfire Detected
Primary Display Resolution: 1440 x 900
Desktop Resolution: 1440 x 900
Primary Display Size: 16.06" x 10.04" (18.94" diag)
40.8cm x 25.5cm (48.1cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 2047 MB
Supported MSAA Modes: 2x 4x 8x

Sound card:
Audio device: Speakers (VIA High Definition A

RAM: 8154 Mb

UI Language: English
Microphone: Not set
Media Type: DVD
Total Hard Disk Space Available: 1067684 Mb
Largest Free Hard Disk Block: 770212 Mb
OS Install Date: Dec 31 1969
Game Controller: None detected

Installed software:
7 Days to Die
7-Zip 9.20 (x64 edition)
Adobe Photoshop CS6
Assassins Creed IV Black Flag
avast! Free Antivirus
BattleBlock Theater
Battlefield™ Hardline Beta
Battlefield 3™
Battlelog Web Plugins
Borderlands 2
Castle Crashers
Counter-Strike: Global Offensive
Dead Island: Epidemic
Dungeons & Dragons: Chronicles of Mystara
Easy Tune 6 B13.0323.1
Farm for your Life
Google Chrome
Google Drive
Google Update Helper
Guild Wars 2
Guns of Icarus Online
How to Survive
IrfanView (remove only)
Java 7 Update 60 (64-bit)
League of Legends
Leapforce Extension Native Host
Left 4 Dead 2
Microsoft Mouse and Keyboard Center
Microsoft Silverlight
Microsoft Visual C++ 2005 Redistributable
Microsoft Visual C++ 2005 Redistributable (x64)
Microsoft Visual C++ 2008 Redistributable - x64 9.0.30729.4148
Microsoft Visual C++ 2008 Redistributable - x86 9.0.30729.17
Microsoft Visual C++ 2008 Redistributable - x86 9.0.30729.4148
Microsoft Visual C++ 2010 x64 Redistributable - 10.0.40219
Microsoft Visual C++ 2010 x86 Redistributable - 10.0.40219
Microsoft Visual C++ 2012 Redistributable (x64) - 11.0.60610
Microsoft Visual C++ 2012 x64 Additional Runtime - 11.0.60610
Microsoft Visual C++ 2012 x64 Minimum Runtime - 11.0.60610
Microsoft XNA Framework Redistributable 4.0 Refresh
ModifyRegistry version 0.1
NVIDIA 3D Vision Controller Driver 335.21
NVIDIA 3D Vision Driver 335.23
NVIDIA Control Panel 335.23
NVIDIA GeForce Experience 2.0
NVIDIA Graphics Driver 335.23
NVIDIA HD Audio Driver
NVIDIA Install Application
NVIDIA LED Visualizer 1.0
NVIDIA Network Service
NVIDIA PhysX System Software 9.13.1220
NVIDIA ShadowPlay 12.4.55
NVIDIA Stereoscopic 3D Driver
NVIDIA Update 12.4.55
NVIDIA Update Core
NVIDIA Virtual Audio 1.2.22
ON_OFF Charge B12.1025.1
Pando Media Booster
PDF Settings CS6
PlanetSide 2
Plants vs. Zombies™
Project Zomboid
PunkBuster Services
Realtek Ethernet Controller Driver
Red Orchestra 2: Heroes of Stalingrad - Single Player
SHIELD Streaming
Sid Meier's Civilization V
Skype™ 6.16
Skype Click to Call
System Requirements Lab CYRI
System Requirements Lab Detection
TeamSpeak 3 Client
The Forest
Tomb Raider
Torchlight II
VIA Platform Device Manager
Wacom Tablet
WebTablet FB Plugin 32 bit
WebTablet FB Plugin 64 bit

< >
Showing 1-6 of 6 comments
DaydreamerDood Jul 12, 2014 @ 1:17pm 
I know this probably won't help you much but I read in another thread someone having graphical errors because of Windows 8.1 maybe it's the same here?
lost in tortillas Jul 12, 2014 @ 3:42pm 
i have windows 8.1 and the same error but i verifyde the intergratey of the game it seemed to do the trick
Weaver Jul 12, 2014 @ 5:48pm 
Assuming you've followed all sorts of advice(reinstall older drivers, reinstall DX, check game cache, blow on GPU pins(serious)). You can generate an event trace log[nvidia.custhelp.com] and post that and we can take a closer look at how the GPU is acting. Based on your specs and config, I can't think of a simple reason why your lens-flare looks like that other than a direct problem with the GPU handling calls or a physical one. If you have a Mobo with another PCI-E slot: try switching over and see if the problem persists.
Last edited by Weaver; Jul 12, 2014 @ 5:57pm
Ultraviolet Jul 13, 2014 @ 12:47pm 
I got my game to work properly after deciding to verify the integrity of game cache once more. I did this before, but for some reason it worked this time where apparently it hadn't before. For anyone wanting to try it, right click the game in your library, and click "Properties". From there go to "Local Files" and "Verify Integrity of Game Cache".

This probably didn't actually change anything, as it was already disabled, but I also accessed my NVIDIA Control Panel and enabled, then disabled again "Stereoscopic 3D".

Thanks for all the solutions posted here!
I have this problem too and verified my game cache once. didn't fix anything. Think I'll verify again..
lambda (Banned) Jan 30, 2017 @ 10:46am 
i think it looks amazing to be honest
< >
Showing 1-6 of 6 comments
Per page: 15 30 50

Date Posted: Jul 12, 2014 @ 12:56pm
Posts: 6