Left 4 Dead 2

Left 4 Dead 2

View Stats:
Can't open console
Basiclly:
-I did activate it
-I cannot find the setting to bind it (its just not there)
-Standert keys for it dosent work

Also please dont assume im a noob at this. All of my source games expect this one work for me with console (Portal 2, TF2, Half life 2, gmod...)
Last edited by Freemankiller ☣; Aug 30, 2017 @ 6:13am
Originally posted by Everice:
try to put -console in the launch option. go to lib > right click at l4d > properties > look for Set Launch Option

after that, you can close properties window and launch the game, the console will pop up right after loading screen. you can use command "bind" "any button" "toggleconsole"( bind "x" "toggleconsole"). then quit the game and re-open and try to use bound button to call a console
< >
Showing 1-7 of 7 comments
The author of this thread has indicated that this post answers the original topic.
Everice Aug 30, 2017 @ 5:56am 
try to put -console in the launch option. go to lib > right click at l4d > properties > look for Set Launch Option

after that, you can close properties window and launch the game, the console will pop up right after loading screen. you can use command "bind" "any button" "toggleconsole"( bind "x" "toggleconsole"). then quit the game and re-open and try to use bound button to call a console
Freemankiller ☣ Aug 30, 2017 @ 6:17am 
Thanks
Samwise Aug 30, 2017 @ 3:15pm 
Launch L4D2 and go to settings->enable developer console. Go back to Steam interface and right click L4D2 in game library and choose launch properties. Write "-console". Next time console should appear when you start the game.


When you start l4d2 with -console type in : bind "F6" "toggleconsole"

The bind key can be other key as well. After binding it start a campaign map and try if your chosen key works.YOU CAN'T USE THE KEY TO OPEN CONSOLE IN START MENU, ONLY IN GAME.

Pro tip, change fiew model fov. The game has terrible setting for that like characters hold guns in their faces. This setting will change that. I suggest 66.

The command is: cl_viewmodelfovsurvivor xx

The xx being number you want. THE DEFAULT IS 51 OR 53!
ByeByeBabylon Sep 13, 2021 @ 3:18pm 
Originally posted by Samwise:
Launch L4D2 and go to settings->enable developer console. Go back to Steam interface and right click L4D2 in game library and choose launch properties. Write "-console". Next time console should appear when you start the game.


When you start l4d2 with -console type in : bind "F6" "toggleconsole"

The bind key can be other key as well. After binding it start a campaign map and try if your chosen key works.YOU CAN'T USE THE KEY TO OPEN CONSOLE IN START MENU, ONLY IN GAME.

Pro tip, change fiew model fov. The game has terrible setting for that like characters hold guns in their faces. This setting will change that. I suggest 66.

The command is: cl_viewmodelfovsurvivor xx

The xx being number you want. THE DEFAULT IS 51 OR 53!

Oh thanks!
Freemankiller ☣ Sep 14, 2021 @ 6:23am 
Originally posted by ByeByeBabylon:
Originally posted by Samwise:
Launch L4D2 and go to settings->enable developer console. Go back to Steam interface and right click L4D2 in game library and choose launch properties. Write "-console". Next time console should appear when you start the game.


When you start l4d2 with -console type in : bind "F6" "toggleconsole"

The bind key can be other key as well. After binding it start a campaign map and try if your chosen key works.YOU CAN'T USE THE KEY TO OPEN CONSOLE IN START MENU, ONLY IN GAME.

Pro tip, change fiew model fov. The game has terrible setting for that like characters hold guns in their faces. This setting will change that. I suggest 66.

The command is: cl_viewmodelfovsurvivor xx

The xx being number you want. THE DEFAULT IS 51 OR 53!

Oh thanks!
Legend
Mortimer Sep 14, 2021 @ 6:27am 
Originally posted by L4D2 = CHEATING VIRGIN WEEBS:
holy sh!t that 2017 necro people really are desperate

Ah, this worthless mandrill finally got banned. Good riddance.



Originally posted by Freemankiller ☣:
Basiclly:
-I did activate it
-I cannot find the setting to bind it (its just not there)
-Standert keys for it dosent work

Also please dont assume im a noob at this. All of my source games expect this one work for me with console (Portal 2, TF2, Half life 2, gmod...)

ONE WORD OF CAUTION, Freemankiller. The console fails to activate on the main menu (when you use the bound key (for example, F9)) from time to time. As such, I recommend you try using the key in-game. There are some "Game Menu" mods in the workshop which add a console button (amongst other things). Be careful, because some workshop mods that simply read "Console Button" were not updated after "The Last Stand" update, and they cause some really strange and bizarre issues (like reverting the ENTIRE main menu to its pre-TLS update).
Freemankiller ☣ Sep 14, 2021 @ 6:31am 
Originally posted by Umbra:
Originally posted by L4D2 = CHEATING VIRGIN WEEBS:
holy sh!t that 2017 necro people really are desperate

Ah, this worthless mandrill finally got banned. Good riddance.



Originally posted by Freemankiller ☣:
Basiclly:
-I did activate it
-I cannot find the setting to bind it (its just not there)
-Standert keys for it dosent work

Also please dont assume im a noob at this. All of my source games expect this one work for me with console (Portal 2, TF2, Half life 2, gmod...)

ONE WORD OF CAUTION, Freemankiller. The console fails to activate on the main menu (when you use the bound key (for example, F9)) from time to time. As such, I recommend you try using the key in-game. There are some "Game Menu" mods in the workshop which add a console button (amongst other things). Be careful, because some workshop mods that simply read "Console Button" were not updated after "The Last Stand" update, and they cause some really strange and bizarre issues (like reverting the ENTIRE main menu to its pre-TLS update).
Thanks, very good to know!
< >
Showing 1-7 of 7 comments
Per page: 1530 50

Date Posted: Aug 30, 2017 @ 5:06am
Posts: 7