Train Sim World®

Train Sim World®

View Stats:
An Unreal process has crashed: UE4-TS2Prototype
I've played Train Sim World since it was released. Because I was so hyped for this game and my computer was a piece of crap, I bought a $200 graphics card just to play this game. I used to be able to play this game when ever I wanted until one day the game crashed when I opened it. It was after the New Year update but I played it just fine for a little while. For a week it crashed every time I tried to launch it. I don't think there was any major software updates to my computer. I uninstalled and reinstalled the game to see if that helped but it didn't. I'm really excited for the Amtrak DLC but I won't buy it if I can't play the game. Are there any tips you can give me? Any suggestions? Things I should do?
< >
Showing 1-7 of 7 comments
cszolee79 Feb 24, 2018 @ 7:01am 
So... what graphichs card did you buy? Is it overclocked? Is it properly cooled? UE4 loves to crash when the GPU is just a tiny bit wobbly. Lowering graphics settings or power limit / mhz for the GPU usually helps (at least with NVidia).
EmMaster Gaming Feb 24, 2018 @ 1:55pm 
I have a 1050 ti but it worked perfectly fine until just recently. It has it's own fan that's not blocked by anything.
æterna Feb 24, 2018 @ 3:59pm 
When you crashed to desktop, open Notepad and use Ctrl+V combination on your keyboard to paste the error code. Probably it is access violation. You can search for similar cases on Google to understand what is wrong.

When the same thing like that happened to me, I tried everything with no success. I found out the cause of the access violation is this file in my case:

C:\Program Files (x86)\Steam\steamapps\common\Train Sim World\WindowsNoEditor\Engine\Binaries\ThirdParty\Steamworks\Steamv139\Win64\steam_api64.dll

I deleted it manually and veried the game files again and somehow it's been fixed. No crashes since then, been a month, touch wood. :P
stringbean6 Mar 6, 2018 @ 3:04pm 
I've just started getting the box message as the OP.

My game played fine yesterday. Then today, 06/03/18, Windows 10 had a Cumulative Update bringing Windows up to the latest version.

This has now produced the box error message as the OP. I've uninstalled via Steam and then re-installed and still cannot play the game. I've even Verified game files but no joy.

I've sent a support ticket to DTG at 9am this morning, I've heard nothing from them for the whole day.

Did Windows Update cause this? Nobody else seems to be reporting anything here on Steam so is it just me? I've done nothing to the PC and all my other Steam games work fine.

Windows 10 (1709)

GPU: GTX-1080TI (Not Overclocked)

CPU: I7 - 7700k @4.20GHz. (Not Overclocked)

16Gb RAM.

Games on seperate SSD from Windows.

cszolee79 Mar 7, 2018 @ 10:13am 
Read somewhere that uninstalling and reinstalling Visual C++ 2015 might fix fatal error problems.
stringbean6 Mar 7, 2018 @ 10:19am 
Originally posted by cszolee79:

Read somewhere that uninstalling and reinstalling Visual C++ 2015 might fix fatal error problems.

Thanks for your advice. I have tried that but no joy. I just cannot understand why my TSW is doing this. I'm still waiting to hear from DTG. It's been 24 hours now since I sent my support ticket in.

By the way, I'm not getting A Fatal Error. Just the message box when I click the play button Steam which says 'An Unreal process has crashed: UE4-TS2Prototype'
Last edited by stringbean6; Mar 7, 2018 @ 10:21am
rwaday Mar 7, 2018 @ 1:09pm 
You might try doing a clean install of your GPU drivers.Windows updates are known for screwing these up. Happened to me twice.
< >
Showing 1-7 of 7 comments
Per page: 15 30 50

Date Posted: Feb 23, 2018 @ 7:46pm
Posts: 7