SYNTHETIK

SYNTHETIK

 This topic has been pinned, so it's probably important
Shrike  [developer] Mar 27, 2018 @ 7:16pm
▶ ▶ ▶ ▶ HELP - Frequently asked issues ◀ ◀ ◀ ◀
I cant start the game or have graphical issues
Try updating your graphics drivers, if that dosnt help, download Direct X9c, launch as admin or in compatibility mode by rightclicking your exe, try changing window/fullscreen mode with Alt+Enter

If you use a laptop, make sure to not use integrated graphics to run the game. Check your driver settings and set your preferred card correctly.

Try verify integrity of Steam cache in the Steam game settings - That is not the same as reinstalling. Often Windows needs an update, also try that.

Compatibility mode or running as Admin (right click the game exe on steam folder) can also help

Some people also reported Riva Tuner (from MSI afterburner or other overclocking software)
to block the game. Mabyt try disable non windows anti virus software or (suspicion only) other software that may do overlays over games, like Asus Suites or such. (Discord is fine)


New: Someone had a similar issue and resolved it like this:
Narrowed it down its enough to delete GameOverlayRender64.dll from Steam folder.
Downside is that Steam reacquires file. In case anyone else has the same problem you need to:
- create shortcut of Synhetik.exe
- exit Steam
- delete GameOverlayRender64.dll from Steam folder
- run game from created shortcut


(if below Windows 10) Here is the Direct X9c runtime in case all else does not work
(Don't worry, It will not overwrite a newer one)
https://www.microsoft.com/en-US/download/details.aspx?id=34429


I get a D3D Error
Verify integrity of game cache in steam game settings (or update drivers if that dosn't help)

I get a black screen when starting
A couple users have reported a issue with the bloom effect, to disable that without going to the main menu is > Go to C:\Users\USERNAME\AppData\Local\Synthetik

Then open the settings.sav with the notepad, search for "bloomon" and
write a 0 instead of 1, save and start the game. (Maybe you need to disable steam cloud so it dosnt overwrite it)

I get strange lines on my screen
Check if you have Anisotropic filtering forced in your driver, else disabling vivid lighting/glow in the settings can also help. There will be a noticeable performance upgrade in Mai

I have input lag or lags / freezes
Try change your FPS calculation method on top left of the menu and try switching to fullscreen
with alt+enter or out

Also check if you have G-Sync enabled, this may cause issues with the Engine

Some people reported freezes on Nvidia overlay. Overlays are always suspicious.

My fps is very low
Make sure to not run the game on integrated graphics, turn down settings, make sure your hardware is good enough, try playing in Fullscreen mode with Alt+Enter, update graphic drivers

If you use a laptop, make sure to not use integrated graphics to run the game. Check your driver settings and set your preferred card correctly.

Some times the CPU dosnt recognize that it needs performance and it stays in idle for that try setting your Power Plan under Windows to "Performance"

Try switch the ingame FPS modes to something hard locked, maybe try Vsync as well

To prevent lags from loading textures, installing the game on a SSD helps a lot also

I lost all my progress!
Go to C:\Users\User\AppData\Local\Synthetik and take one of your backup.sav files and overwrite your save.sav file (may require turning off steam cloud for that)
Make sure to try the SaveBackupDaily.sav (or savetemp.sav)
first that should always work unless you have logged in days after.
(just rename the file to save.sav, keep a backup on desktop if you are unsure)
Don't log in again before you have done this


My progress won't delete
Make sure to disable steam cloud under right click game settings, at the bottom


My progress wont save or I cant progress in some way (class challenges)
Check if your savefile (save.sav & statistics.sav) is writing disabled by right clicking them and check the settings (read only) C:\Users\User\AppData\Local\Synthetik


Special Mouse buttons are not bindable
The engine does not support special mouse buttons I'm afraid

My 3D sound is not working right
Make sure to check the new windows settings for "Spatial Sound" in your taskbar, you may need to turn that off, aside try other games and try updating sound drivers

I have issues with my keybindings, Controllers or chat
Try resetting your keybindings in the settings, which will solve most issues that occur from patching

My power tokens are missing
Try resetting your power tokens in the settings

Anti Virus error and my game crashes on exit
Apparently that is an engine issue, check out this thread:
http://gmc.yoyogames.com/index.php?showtopic=561358&st=0&p=4146944&fromsearch=1&#entry4146944




-- INTERNET --

I can not create a online lobby
Most likely does the relay server have a issue and will be restarted soon.
(If you notice that and other people see the same, maybe try messaging us on discord or over the website if its not solved for some time)

I can not connect to other lobbies or a friend
The game uses a relay server, so opening ports is not required.
If you have issues connecting to the other player, try disable P2P connect and/or LAN connect in the settings to directly play over the relay server. Check if you can connect/Host for other players to see if the issue is with you or the other player.

(Make sure to not have any firewall in the background blocking you (check for the Windows firewall popup window))

I can not get online at all
Check on the discord if the server is not briefly down, and check the usual things (background software, firewall, Riva tuner maybe)

If nothing helps, it is likely your ISP not routing properly, in that case using a VPN
software will circumvent this and it should connect. So far all people who has this have reported that this solved their issue.


Check if you have the latest version installed and not using a crack


---------------------------------------------------------------------------
MANY ISSUES ARE SOLVED WITH UP-TO-DATE GRAPHIC DRIVERS!
(Or verify Integrity of Steam cache setting in Steam Game Tabs)

Sometimes new drivers are buggy too however, historically I personally had to often switch to older drivers for games to work properly, especially with AMD cards, so that can also be a last possibility.


Last edited by Shrike; Jun 27 @ 2:11pm
< >
Showing 1-15 of 33 comments
Yonk Jun 30, 2019 @ 3:02pm 
Special Mouse buttons are not bindable
The engine does not support special mouse buttons I'm afraid

Please solve it.
Shrike  [developer] Jul 1, 2019 @ 2:45am 
Can't be solved, engine makers need to solve it. We told them however
Fnord Sep 19, 2019 @ 10:13pm 
I have an issue where left click is registering as being spammed when I start the game and is making the game unplayable and often opens an endless string of web pages. Was playing fine, tried restarting the computer can't get it to resolve now.
Shrike  [developer] Sep 20, 2019 @ 2:38am 
try resetting your settings file in %appdata% under Synthetik

Otherwise the typical stuff, verify integrity of game cache probably or update graphic driver
Last edited by Shrike; Sep 20, 2019 @ 2:38am
About RivaTuner. Trying to turn off "Stealth Mode" may help.
I have purchase the DLCs and play the Legion event. What can I do?
Shrike  [developer] Jan 28 @ 2:37pm 
whats the question?
Originally posted by Shrike:
whats the question?

Well I cant seem to be able to play the legion dlc even though I have the pack
Shrike  [developer] Jan 28 @ 5:48pm 
Legion Rising is a standalone game (the game this forum here belongs to), I think you either dont have it installed or bought something else. The base Synthetik game is Synthetik: Legion Rising so you likely already play that
Last edited by Shrike; Jan 28 @ 5:49pm
"My progress won't delete
Make sure to disable steam cloud under right click game settings, at the bottom"

Instructions not clear. Got head stuck in floppy drive.
All jokes aside could you please give more detailed instructions about how to remove steam cloud? This might resolve my following issue if steam cloud is even active.

Anyhow I have a issue related with this in some way. Today I logged in with another steam account that has this game and downloaded the game and also played a little just to see if this PC could run the game smooth enough to be playable.
Now I have bought this game on this new steam account (because I want to play together from 2 different PC's to be more clear) but whenever the game is started on this PC it has the progress of my own (the other) steam account.

Wouldn't complain if it was just that but we cant seem to play together and keep getting disconnected at the same time after 1 or 2 rooms we clear and also any progress made like exp or what not doesnt get added/counted.

Already tried uninstalling the game and reinstalling but with no succes of resolving this issue. Also log-out in-game doesn't help as that is just go offline for the game I think.

There is also the fear of losing my own progress if I click on the reset progress in options in-game on this steam account as I understand that for some reason I am logging in on my own account while being on this other steam account and that is causing the disconnect issue's we are having.
Shrike  [developer] Mar 1 @ 5:01pm 
We had one guy have his save file being write disabled, maybe check that

the save location is explained above

Which server region are you playing? Maybe try another region and let me know if DCs still happen, I have a suspicion its always one region
Last edited by Shrike; Mar 1 @ 5:01pm
Hey I just SYNTHETIK: Arena Premium Upgrade (DLC), and I dont have the option to download it or play it.
When I press Play it just starts basic game without the upgrade.
help please
Shrike  [developer] Mar 5 @ 11:47am 
you need to change the game mode near the play button on top in legion rising
Last edited by Shrike; Mar 5 @ 11:47am
mg Mar 17 @ 7:05pm 
Originally posted by Shrike:
you need to change the game mode near the play button on top in legion rising
Can we add to this FAQ what folder to look into for crash logs?
Hey, when play with friend found some bug with tactical observer weapon, i take 3 or 4 curses of ignorant and this rifle start unstoppable upgrade process.
screenshot: https://steamcommunity.com/sharedfiles/filedetails/?id=2039931611
sorry for my english
< >
Showing 1-15 of 33 comments
Per page: 15 30 50