ToeJam & Earl: Back in the Groove

ToeJam & Earl: Back in the Groove

View Stats:
PC: need vsync option to avoid high menu FPS
do we really need 90000 fps for the menu screen?

its great this game is multi-thread capable but it was burning a hole in my cpu just idle at the menu screen

FIX:

enable VSYNC option for PC
this would probally fix the white video problem also.....i dont know

i have nvidia on linux, let me look if i can force set vsync for this game
< >
Showing 1-12 of 12 comments
catbox Mar 2 @ 1:18am 
maybe its just my custom setup i cant even enable vsync on GLXGEARS
+1 for a fps limiter option
On Windows 7 forcing Vsync in nvidia's control panel doesn't seem to work...
gamzrck Mar 2 @ 1:44am 
+
catbox Mar 2 @ 2:50am 
ubuntu 14.04 LTS kernel 4.4
nvidia 384

nvidia specifically states:

Nvidia prime synchronization (optimus) requires kernel 4.5

unable to upgrade naturally within repos, im already on the HWE LTS support with kernel 4.4

kernel 4.5 requires Xorg-Server-1.19 (IE ubuntu 16.04)

....

PRIME Syncronization not able to work.

cant set vsync through any known method


test your GLXGEARS

> vblank_mode=0 glxgears #vsync off 9000fps
> vblank_mode=3 glxgears #vsync on 9000fps (should be 60fps)


check modesetting
> sudo cat /sys/module/nvidia_drm/parameters/modeset
# Y modesetting, N nomodesetting

> gedit /etc/modprobe.d/nvidia-drm-nomodeset.conf
options nvidia-drm modeset=1
# update-initramfs -u
# reboot


> xrandr --verbose |grep PRIME Sync
# should be: 1

because its not kernel 4.4, xserver 1.19 there is no prime vsync for my "optimus" configuration



*** yes im on a laptop...

the game runs beautifully otherwise
no screentearing
regular 100+ FPS in game
its the menu screen and the white video that is the problem
Last edited by catbox; Mar 4 @ 9:37am
catbox Mar 2 @ 2:58pm 
to avoid an OS upgrade i found

LIBSTRANGLE

this forces a FPS limiter for OpenGL and Vulkan games

works flawlessly in TJE, GLXGEARS etc.

https://gitlab.com/torkel104/libstrangle


*note*
does not fix white video screen problems when set to 60fps or 30fps
Waggy Mar 2 @ 4:36pm 
Menu v-sync please.
catbox Mar 2 @ 5:12pm 
Problem:
900-1000 FPS on main menu. This causes overheating and spins up the fans

ingame:
120-200fps no problem playing game, heat is not a big issue
~200fps while in elevator

solution:
fps limiter or vsync to set main menu


addendum:
stop making console games and porting them to PC
Last edited by catbox; Mar 2 @ 5:18pm
My pc makes crazy loud sounds when i am at the menu (probably due to insalnely high fps there), however i can't see the fps with nividia shadowplay as well, allthough i am running the game in fullscreen.
catbox Mar 3 @ 1:04pm 
steam overlay top left corner
Last edited by catbox; Mar 3 @ 1:05pm
Yeah I had this too. Rivatuner/MSI Afterburner worked to manually clamp it to 60fps. Radeon settings didn't work for me though.
+1 for vsync.
This is overheating my GPU.
Nap  [developer] Apr 11 @ 9:31am 
Looking into it
< >
Showing 1-12 of 12 comments
Per page: 15 30 50