Streets of Rogue

Streets of Rogue

View Stats:
Madguy  [developer] Jul 18, 2017 @ 6:56pm
Multiplayer issues and how YOU can help!
Multiplayer bugs can be a tricky thing. It's very hard for me to track down some of the issues people have, because I simply can't make them happen myself. A lot of it has to do with people's specific connections, and that's not something I can easily reproduce.

So, here's what YOU can do to help.

If you get a significant game-breaking bug -- As in, got a weird disconnection issue between levels, or something like that:

- IMMEDIATELY make a copy of the output_log.txt file. (see here for instructions on how to do this)
- If possible, have the host of the game do the same. Having the host's log is potentially more useful than the client's, but it's good to have both.
- Post the logs on pastebin.com or wherever you want.
- Post a link in this thread.
- Let me know EXACTLY what happened in as much detail as you can give.
Last edited by Madguy; Feb 22 @ 4:44pm
< >
Showing 1-15 of 53 comments
Chickensalad Jul 18, 2017 @ 8:15pm 
Was hosting online game as slaver

New player 1 connected, worked fine

New player 2 connected worked

player 2 disconnects

Get to end of level game wont continure untill all players reach exit, even though me and player 1 reached end

Have to wait the 60 seconds for kick

Start next level player 1 disconnects

Get to end of level have to wait for kick as "all players have not reached exit"

alt f4ed

https://pastebin.com/TLKJLSzP
Last edited by Chickensalad; Jul 18, 2017 @ 8:16pm
Machuga14 Jul 18, 2017 @ 9:06pm 
Hey, my friend and I have been having a consistent issue since the update to 29F.

We are playing Multiplayer, with exactly 2 people (but it's set to have 4 people; I don't know if that could be the problem, but as a programmer, I'm aware almost anything could be the issue).

Another setting we have turned on is the server is Public, and Password Protected (We are not using LAN)

The issue is that as soon as we finish a floor, the HOST is able to proceed to the next level immediately after it finishes generating the level, but the CLIENT (we only had 2 people) would be stuck with a black screen stating that it's building floor (X - Y), and it will stick at exactly 0%, with the 60-second timer counting down displaying periodic messages, before it hits 0, and stops. The CLIENT is never again able to connect to the host, even when killing the program with TASK MANAGER, relaunching, and attempting to join the game through the Online Lobby. It appears that once this occurs, the connection between the CLIENT and HOST is killed permanently until the host relaunches the game as well. (However, I don't know if it's specifically the CLIENT-HOST connection for just that one CLIENT, or if it's actually because the network platform for the HOST becomes destabilizied and unable to maintain any connection, preventing anyone from joining the game).

My friend who is experiencing the issue with me is HungryBlocko, at: https://steamcommunity.com/id/hungryblocko


I was the CLIENT, my friend was the HOST for these logs, however, we have experienced this issue going both ways.


Here's the CLIENT Pastebin file: https://pastebin.com/zR6g4YbN

Here's the HOST Pastebin file: https://pastebin.com/t7NKTwHm

Note: I put a basic description of what we experienced at the top of both of these Pastebin files as well.
Vanimal Jul 18, 2017 @ 9:28pm 
https://pastebin.com/Qn0S79qt

I was hosting when it crashed due to bug.
What I think happened was that I tried to revive my Open online co-op partner (2/4) at the exact same time
that I died. We were then both ghosts able to wander around. I hit "End Game" we both exploded
and picked new characters. We still could not create a new game. I could see him pick Vampire again.
I chose "whatever" but the game didn't start. We both tried to go back and pick different characters
but to no avail. The game would not start. Finally I "Quit Game".
Last edited by Vanimal; Jul 18, 2017 @ 9:30pm
Madguy  [developer] Jul 18, 2017 @ 10:18pm 
@Vanimal I'm missing some information on this one. You say "We still not could create a game"? Also, you chose "whatever"? What does that mean? What was the exact sequence of events here? It said he picked a character, and so did you, but nothing happened when you had both picked characters?
Madguy  [developer] Jul 18, 2017 @ 10:27pm 
@Machuga14 this didn't happen at all before 29f? I don't think the change I made would have caused the issue I'm seeing in these logs. That said, I'll make a change to the one thing that maybe-might have had something to do with it.
Last edited by Madguy; Jul 18, 2017 @ 11:04pm
Machuga14 Jul 19, 2017 @ 12:34am 
@Madguy, I never saw this in 29e (I bought the game on Sunday, so My earliest build was 29e).

3 friends and I bought this game on Sunday, and played for a few hours, with about 10 different plays, one of which we ended up getting to floor 3 - [Something]. During this whole time, we never encountered this issue.

Today, my friend HungryBlocko and I started playing about 30 minutes before 29f came out, but suddenly experienced an issue where neither of us could connect to each other; We both quit, and downloaded 29f almost immediately (because it came out while we were playing). We restarted (after finishing downloading 29f, which was a small update).

Right after we had restarted with 29f, we were never able to play through an entire floor together and manage to stick together through the loading screen to the next floor... Whoever was the host would successfully get to the next floor, and whoever was the client would be stuck in the loading screen stating something along the lines of "generating floor X of Y" or whatever the exact string is that's being displayed there...

We spent at least a 2 more hours getting this over and over again, and my friend even ended up rebooting his computer, which didn't seem to alleviate the issue.

The friend I was playing with today, HungryBlock, happened to be one of the group of three that I had no problems with (network connectivity-wise, anyway) on Sunday evening when we all bought the game.


What I appear to observe, is that once the HOST loads into the next level, the HOST encounters issues with serializing the level data across the network, either because something occurs which makes the HOST skip over it, or somehow the connection aborts roughly; maybe bad data is sent or something... But ultimately, finishing a level and loading the next level ALWAYS caused this issue for us all night.

There's no issue when going from the Staging area (whatever you call the place you can purchase new traits / set up mutators / etc...) to the game, and there's no issue when joining during a level already running, but it doesn't appear to work at all once there's the need to transition from one level to the next.

I don't know how much more information I can provide; I can try playing the game duo with other people (tomorrow; it's late now), and see if the issue still persists; I don't know if this issue is affecting other people, or if it exists between me and HungryBlock because of a strange interaction between our drivers/network setup / ISP's / ETC...
Last edited by Machuga14; Jul 19, 2017 @ 12:39am
Madguy  [developer] Jul 19, 2017 @ 12:45am 
@Machuga14, I just uploaded another version, 29f1, where I made the change I mentioned in my last post, along with a few other small experimental things. Perhaps that will fix the issue. If you're still getting it on 29f1, then it's unrelated to my changes. Thanks a bunch for putting so much effort into this.

I think what was happening, based on the logs, was that the call to change levels was not getting sent from the host to client. So the client just sits at 0%. It is literally 1 line of code with built-in Unity functions that makes this server-to-client command happen, so the fact that it's not getting sent, when everything else leading up to it appears to be getting sent fine, is a little baffling. I had made some changes to the code around this area, but nothing that should have caused this. Then again, I've seen weirder things that only a select number of people could achieve.

Also, is this correct?
- Client joins game on Home Base, can get to level 1, can't get to level 2.
- Client joins game on level 1, can't get to level 2.
Last edited by Madguy; Jul 19, 2017 @ 12:58am
Machuga14 Jul 19, 2017 @ 2:29am 
I'm glad you're being so responsive to my replies; And as a software developer myself, I know how important good feedback is when it comes to tracking down the source of bugs; God knows I have enough issues with that myself.

Also, you are correct on the steps you provided:
If the Client joins on Home Base, there's no issue getting to level 1, but CANNOT get to Level 2.
If the Client joins on level 1, CANNOT get to level 2.
If the client joins on level 2, CANNOT get to level 3
... (I assume) etc...

Tomorrow (technically, in my time, later today), I'll try out update 29f1 with the same friend I had this issue with, and I will make sure to reply later to this post about my results with 29f1; whether or not I was able to proceed beyond whatever level I joined on (or vice versa) with my friend.

anyways, it's bedtime for me... been up too late already as it is.

Fun game, by the way... I'm really enjoying it; I wish there were more great Multiplayer games out there.

Ansam Jul 19, 2017 @ 11:28am 
I played a full run on 29e with a friend, I hosted as werewolf and he joind as Gorilla. Good times.

Now 29f1 it's nearly unplayable in multiplayer. As just above, we cannot transition between levels. But I have 2 other issues.

In the first game I was hosting, we started in home base, selected endless mutator, and we went to the next stage. I joined but was stuck in a wall at the bottom leftish of the map, and my friend never loaded in past "waiting for host". I even hit End Game to try and restart, but that just softlocked the game.

https://pastebin.com/mgmbHq3v After line 151 it becomes really debuggy, and line 327 is the recurring loop.

In the second game my friend was hosting, and I struggled to load in past the loading screen a few times. Then this happened, I got to character select and after choosing Slave Master, I was forced to wait for host to select a character. Which he already had, so I simply couldn't play. I exited and retried again, same result.

https://pastebin.com/AH4QVAze

I also had a random error of Jock becoming a living dead corpse. After a charge he knockbacked and became uncontrollable. Didn't save the output file of that game. This was fixed after Jock was the only player who hadn't reached the exit.
Last edited by Ansam; Jul 19, 2017 @ 11:32am
Madguy  [developer] Jul 19, 2017 @ 12:32pm 
@Ansam: 29f1 shouldn't cause issues where there were none before. If that happens, it's coincidental. How many times did you attempt to get to the second level? If you aren't able to get to the second level, unless it happened exactly like described previously, logs would be appreciated.

This first log: Whose is it? Yours or his?

Were these logs taken directly after the issues described?

I assume this was all done without closing the game? If you have a bad multiplayer issue, it is best to close out the whole game and open again. Some things are not getting cleaned up properly, which can lead to issues down the road.
Last edited by Madguy; Jul 19, 2017 @ 12:41pm
Ansam Jul 19, 2017 @ 12:50pm 
Ultimately we tried like 4 times trying to proceed between levels, before frustration and other issues got us to give up.

Both logs are mine. The first one I was hosting, the second he was hosting. The logs were taken out after the issue occured and nothing else, but there was some time passed because I was trying to navigate to the folder.

The games were done with closing the game before. The first log happened immediately after the game was opened and I went to host, and the second log was after a crash and me trying to join the game 3 times in a row.
Madguy  [developer] Jul 19, 2017 @ 1:17pm 
Uploaded a new build (29f2) which reverts to the previous version of the NAT Punchthrough plugin I've been using since 29. This new version didn't appear to change much for the positive, so I'm reverting back for the time being.
Last edited by Madguy; Jul 19, 2017 @ 1:19pm
Ansam Jul 19, 2017 @ 2:07pm 
Just tried hosting and having the same friend join. It worked well for the first level. I went thief, he went Hacker, we played normally starting at floor 1-1. Trying to load 1-2 seemed good at first, except he got stuck at 25%. He exited and tried to join again, and again. He ended up getting kicked after selecting his character.

https://pastebin.com/B3hRsQnh

Fun fact; every game that's been updated today, we've been having different issues with. From game crashes in singleplayer to engine mismatch errors in other games.

EDIT: Wait a moment, we just checked integrity and both had a failed file.
Last edited by Ansam; Jul 19, 2017 @ 2:09pm
Madguy  [developer] Jul 19, 2017 @ 2:13pm 
You don't happen to have his log, do you, since he's the one who got stuck?
Ansam Jul 19, 2017 @ 2:21pm 
No I don't have his log. Anyway, we just made it past the loading barrier after verifying file integrity and reacquiring one file. Despite steam updating, verifying seemed to be nescesary. It works now.
Last edited by Ansam; Jul 19, 2017 @ 2:22pm
< >
Showing 1-15 of 53 comments
Per page: 15 30 50

Date Posted: Jul 18, 2017 @ 6:56pm
Posts: 53