Streets of Rogue

Streets of Rogue

View Stats:
Madguy  [developer] Apr 29, 2017 @ 9:14am
Linux Bugs and Workarounds
"Can't Click" Workaround
Apparently, some Linux users are unable to click things on the main menu. The primary issue is something to do with the latest version of Unity, and it's not something I can fix. For the time being, there are a couple of workarounds.

Workaround #1 (thanks to GamingOnLinux[]):
You can either run the game in Windowed mode all the time, or if your game is stuck in fullscreen add this to the launch options in Steam:
-screen-fullscreen 0
That will force it into Windowed mode. Then, once in-game, you can set it to fullscreen and it will work fine.

Workaround #2 (thanks to one of my players Robert for this):
Put the game in windowed mode in prefs file (change 1 to 0)
/home/(user)/.config/unity3d/Streets of Rogue/Streets of Rogue/prefs
<pref name="Screenmanager Is Fullscreen mode" type="int">0</pref>

Last edited by Madguy; Aug 10, 2017 @ 5:39pm
< >
Showing 1-15 of 66 comments
stalker May 6, 2017 @ 11:31am 
sabayon linux
still "cant click"(
Ozuf May 8, 2017 @ 1:51pm 
Same issue but this was not happening before one of the latest two releases (22 or 23).
Last edited by Ozuf; May 8, 2017 @ 1:57pm
Ozuf May 8, 2017 @ 1:55pm 
Can confirm that the suggested workaround fixes the issue. The game should not be running while editing the file or it will just be overwritten again.
Last edited by Ozuf; May 8, 2017 @ 1:58pm
Madguy  [developer] May 8, 2017 @ 2:11pm 
The issue began occurring in Alpha 23, likely as a result of updating the game's engine to Unity 5.6.
Goliathfan May 10, 2017 @ 2:04pm 
Was also affected by this problem, can confirm the workaround also works for Arch 4.10.13-1.
bubucaos May 15, 2017 @ 7:25am 
Me too
zwobot May 16, 2017 @ 11:45am 
I can click in the menu by mouse, but 360 controller is not working.
Last edited by zwobot; May 16, 2017 @ 11:48am
La Douche Chaude May 17, 2017 @ 2:46pm 
Thank you, resolves the issue on Ubuntu 16.04 LTS
FIREARMS UNITED May 31, 2017 @ 1:26pm 
Originally posted by La ♥♥♥♥♥♥ Chaude:
Thank you, resolves the issue on Ubuntu 16.04 LTS

This is strange. I'm on Ubuntu 17.04 and I have no problems at all. I guess this has less to do with Unity (the Engine) and more with X, Wayland or the Display Manager (GNome, KDE or else).
Baumstumpf_no1 Jun 5, 2017 @ 1:47pm 
Same issue with Black Ice on KDE neon (base Ubuntu 16.04). I can play when i change in windowed mode or you use a controller. ... i don't change in the prefs file (still 0).
Dźwiedziu Jun 11, 2017 @ 5:08am 
I've got the issue at start, when I've selected to use a controller. The catch was me having a Steam Controller, which was not recognized as one.
dogu Jun 22, 2017 @ 8:27pm 
Cheers, this worked. I did however have to manually set the screen resolution in the same file as well though, as both were initially set to 0 by default and my window would be tiny and entirely blank.
Conway1527 Jun 29, 2017 @ 3:46pm 
This worked great for me under GNOME on Arch.
Tchey Jun 30, 2017 @ 9:45am 
Other way to deal with Unity bugs on Linux is to add a command line to the Launch Option in Steam game's property.

One of them, depending on the games. So, try your luck.

LC_ALL=C.UTF-8 (this one is the most common i need)

LC_ALL=C %command% -force-glcore
LC_ALL=C.UTF-8 %command%
LC_ALL=en_US %command%
LC_ALL=C %command%_64
Dźwiedziu Jun 30, 2017 @ 10:52am 
Originally posted by Tchey:
One of those two is good enough.
< >
Showing 1-15 of 66 comments
Per page: 15 30 50