The Fall Part 2: Unbound

The Fall Part 2: Unbound

View Stats:
radn May 31, 2018 @ 2:26am
Space bar not working on Linux
Hello,

I am trying to play not only on my Windows box but also on my Linux one. However, in Linux the space bar simply does not get recognized by the game. Is this something known in Unity3d engine or could the cause be something else?

The space bar *does* work in Linux in general, it just does not get recognized within the game, thus making it unplayable in Linux.
< >
Showing 1-15 of 15 comments
Cheeseness May 31, 2018 @ 2:30am 
Hi hi! I'm not having any luck reproducing your problem here on Fedora.

Could you give some more details on what distro, desktop environment, and system locale you're using? Have you changed any of the controls from their defaults in the Main Menu->Settings->Keyboard Controls?
radn May 31, 2018 @ 2:35am 
Hi,

thanks for your reply. I am using Debian with KDE. The system locale is in US English, and I have both the EN_US and ES_ES (Spanish) keyboards configured, but I usually play in English.

I did not change the controls from their defaults when this failed. Then I tried to go there and assign the "Space" key back to jump and select, but it is not recognized.

I know I could use a different key (all the other keys I tried work, so I can assign for example "LeftControl" to those actions, but Space was more convenient...

I don't think I have anything configured on my Linux that "captures" the Space key (in fact, I am writing this from linux at the moment).

Any ideas are welcome! Thanks in advance!
Cheeseness May 31, 2018 @ 2:42am 
This one's a head scratcher for me. Everything's behaving fine here for my main machine and the other test machines I ran the game on before release. I also haven't heard of problems from any of the linux users I know who've played the game.

Would you mind popping the contents of this file up somewhere like pastebin.com (you'll need to escape the spaces in the path if you're accessing it via a terminal)?
/home/cheeseness/.config/unity3d/Over The Moon/The Fall/prefs
radn May 31, 2018 @ 3:00am 
Hi!

Very strange... I got the prefs for you (actually from ~/.config/unity3D/Over The Moon/TheFallPart2Unbound/prefs), and saw that I had "hasChangedInputs" to 1, despite I tried to cancel the inputs changed. I changed this back to 0, and when I tried, space works again... odd! But now it works!

Original prefs: https://pastebin.com/PPrjPDex

Changed by me to work: https://pastebin.com/YxRBkknK

So I guess this is solved... I don't understand how or why, since I did not change the keys, but it seems to work now...
Cheeseness May 31, 2018 @ 3:13am 
Oh, sorry. I grabbed the path for part 1 >_<

You mentioned that you had tried changing Jump/Activate to something else. This would have caused the hasChangedInputs value to be 1, but clicking the defaults button in-game (which would have been my next suggestion) should have set it back to 0.

Beyond that, I'm really not sure what could have caused the problem, but I am glad to hear that you're up and running!

If it happens again, let us know.
radn May 31, 2018 @ 6:14am 
Hi again,

It is somehow solved, as I am/was able to play and use space successfully. However, I was in-game and had to go away, so I paused (Esc) and switched windows with Alt+Tab. I also left the computer unattended for some time, so the screen locked. Now I went back and space no longer works... so I interacted with one of the terminals in-game and now I cannot choose neither the "next" or "disengage", as space bar was my select button as well...

Somehow, the issue seems related to space not being captured anymore by the game (for some reason), as I am writing this message with spaces with no issues, after pressing Shift+Tab in-game to access Steam's interface.

Any other ideas?
radn May 31, 2018 @ 6:23am 
Hi (once) again,

I closed the game and started again, and Space does not work anymore. I tried using the "trick" as before by changing the value of hasChangedInputs to 1 and starting the game; Space was still not working, so I closed the game, changed it back to 0, and started the game again. Still no luck, so I think I am back to square one :(
Cheeseness May 31, 2018 @ 6:23am 
So when this first happened had you possibly Alt+Tabbed out of the game?

If you pause and unpause does that make things come right? I've seen occurrences of mouse grab not behaving properly when Alt+Tabbing without pausing first.

I wonder whether the game has received the key down event for Alt, but not the key up event and is ignoring the space bar because it thinks you're pressing Alt+Space?
Cheeseness May 31, 2018 @ 6:25am 
Hmm, that blows away those theories then. If you click the defaults button in the key config window, does that make things behave?

Edit: Could you also grab us a copy of your Player.log (it's next to where the prefs file is)?
Last edited by Cheeseness; May 31, 2018 @ 6:44am
radn Jun 1, 2018 @ 1:48am 
Hi,

the latest update is that is seems a bit random... I observed that if I start the game with the keyboard in the Spanish layout, it does not work, and switching to the US keyboard with the game open does not fix it. If I start the game with the keyboard in US English, then it usually works, and it does not matter whether I switch the layout to Spanish afterwards, it keeps working.

The Player.log can be found in: https://pastebin.com/m05j353D

Some strange behaviour sometimes if I switch to other windows in a separate monitor (specially to a virtual machine in VirtualBox) and back, since then the game stops capturing the mouse, and if I move the mouse too much to the side of the screen, it leaves the game and appears in the other monitor, causing the game to loose focus, but I think that is a separate issue :)

Thanks!
Cheeseness Jun 1, 2018 @ 3:44am 
Originally posted by radn:
the latest update is that is seems a bit random... I observed that if I start the game with the keyboard in the Spanish layout, it does not work, and switching to the US keyboard with the game open does not fix it. If I start the game with the keyboard in US English, then it usually works, and it does not matter whether I switch the layout to Spanish afterwards, it keeps working.

The Player.log can be found in: https://pastebin.com/m05j353D
That does make it sound like it might be locale related. Is the Player.log there from a play session where this has occurred (the game log gets overwritten each time the game is launched).

I'd be interested to know whether setting this launch option affects the space bar behaviour you're seeing (right click on the game in your Steam library, select Properties, click the Set Launch Options button and paste this):
LANG=C %command%

Originally posted by radn:
Some strange behaviour sometimes if I switch to other windows in a separate monitor (specially to a virtual machine in VirtualBox) and back, since then the game stops capturing the mouse, and if I move the mouse too much to the side of the screen, it leaves the game and appears in the other monitor, causing the game to loose focus, but I think that is a separate issue :)
That's the issue I was referring to that's caused by Alt+Tabbing out of the game without pausing first - for better or worse, we figure that it's reasonable to expect players to pause first, and pausing/unpausing should make it reliably re-capture the cursor.
[PUNK]Gunman Jul 3, 2018 @ 2:31am 
I as well have the problem of a non-functioning spacebar ingame.

System locale: german
Keyboard setting: german/us

Tried running the game with and without LANG=C, with germany keyboard and us keyboard, does not matter, changed the settings for jump to Left-Shift which lets me proceed to the first fight where I have to hit spacebar to acknowledge the hint on the screen. I can recall no problems with your first game, I am rather disappointed in this one right now.

Alt-Tab breaks the game for me, no matter if paused or not, it just stalls with music running but unresponsive.
Cheeseness Jul 3, 2018 @ 3:10am 
When you tried the `LANG=C %command%` launch option, did you happen to move/rename the folder that the game saves data into so that no saved data/user preferences from the default locale are present?
~/.config/unity3d/Over The Moon/TheFallPart2Unbound
If doing that helps at all, then it would be good to get a copy of your original prefs and TheFallPart2SavedData.txt files for us to take a look at (you can email those to john@overthemoongames.com along with a link to this thread or stick them somewhere like pastebin and link that here).

Regarding Alt+Tabbing, I don't have much to say other than it's working here and I'm not having any luck reproducing that issue. Have you confirmed whether or not the problem occurs for you in windowed mode, and would you mind getting a log from a play session where this has occurred just in case there are any clues hiding in there.

It might also be helpful to know your distro, desktop environment (including version number), window manager and hardware in case there are any commonalities we can draw between your report radn's (and any future reports we end up with). I'm sure that once we have an understanding of what the issue is, we will be able to find a solution, but right now, we need more information.
[PUNK]Gunman Jul 5, 2018 @ 12:49pm 
Originally I ran it with LANG=C right from the start because it never caused problems when I used it but sometimes resulted in weird stuff when I ommitted it (localisation with decimal delimiter problem ...). Anyway it seems to be the first time it actually resulted in a problem. It let me do the first 2-3 prompts where a spacebar press is expected but as soon as I got to the "press space to jump" part it failed.

Now I purged the game directory (turned cloud saves off) and ran it without LANG override and it seems to work without a problem, maybe I'll try to recreate the first run with LANG=C again but right now I'm just happy it runs this far.

On a different note: I'm one of those poor sods with optimus technology in their machine. I use primusrun to force games unto the discrete graphic card but somehow I'm not sure if "The Fall 2" actually uses my discrete card or falls back to the intel one. Could you shed some light? Logs are not really giving much away in that regard.
[LENI]Chon Sep 30, 2019 @ 5:22am 
I've had the same problem on a lot of game using debian + KDE.
spacebar worked with 'fr' layout but because others keys tend to behave strangely, I used to use 'us' or 'gb' layout (before having this problem).

My workarround now is to set my keyboard layout with the command in a terminal

setxkbmap -layout us

I hope that will help anybody who encounter this problem and find this thread
< >
Showing 1-15 of 15 comments
Per page: 15 30 50