Hypnorain

Hypnorain

View Stats:
Hypnorain > General Discussions > Topic Details
clippa Jul 7, 2016 @ 12:03pm
(FIXED) Controls broken in demo
Hiya, I tried the demo here - http://kircode.com/hypnorain/

Tried with 2 seperate arcade sticks, one directinput and the other xinput, neither work.
Using joytokey doesn't work, I set the keyboard directional controls to the povhat but it still doesn't work in game.
Tried a 360 pad and the character was constantly flying upwards.
Last edited by clippa; Jul 8, 2016 @ 1:41pm
< >
Showing 1-15 of 15 comments
KEYREAL  [developer] Jul 8, 2016 @ 5:36am 
Hi, this is unusual, the game is designed to work with standard DirectInput and XInput devices. Was tested with multiple gamepads. If joytokey doesn't work, that might be a problem with your controllers. What device are you using and does it work with other games?
clippa Jul 8, 2016 @ 6:10am 
The sticks I tried were the "QanBa Q4RAF" and the "Hori RAP EX-SE"
I play a lot of doujin shmups so I'm used to using joytokey and never have any problems.
The 360 pad works with all other games.
KEYREAL  [developer] Jul 8, 2016 @ 7:01am 
Try launching the game and plug in your device while in the main menu. A message should appear in the bottom left corner of the window. Does the message appear and what does it say?
Maya Jul 8, 2016 @ 7:03am 
I can't even get this to work with my Xbox controller either. Keeps flying upwards, like the OP mentioned.
Last edited by Maya; Jul 8, 2016 @ 7:06am
KEYREAL  [developer] Jul 8, 2016 @ 7:26am 
I'll look into this, which controller exactly are you using?
KEYREAL  [developer] Jul 8, 2016 @ 7:34am 
A quick guess is that it might be related to a sensitive deadzone in the case of X360 controllers. Does your controller driver come with some sort of configuration utility? If possible, try adjusting the deadzone of your controller and see if it works.
Maya Jul 8, 2016 @ 8:04am 
this is a authentic Microsoft xbox 360 controller. It's not the controller that has the issue, as I use it on a regular basis in my other games.
clippa Jul 8, 2016 @ 10:33am 
Originally posted by keyreal:
Try launching the game and plug in your device while in the main menu. A message should appear in the bottom left corner of the window. Does the message appear and what does it say?

No message with either sticks. 360 pad works

https://s31.postimg.org/81zrsqc5n/pad2.jpg

but like you say, the deadzones are none existant so you just end up going in random directions.

Changing the deadzones in the driver even to the least sensitive doesn't seem to work, the game overrides it.

https://s32.postimg.org/ti3qxk1t1/pad.jpg

Doujin shmups that have zero pad/stick support are always fine because there are no conflicts when you're emulating the keyboard.
Would it be possible to add an option in the menu to disable all pad/stick support, that might let people who can't get it to work emulate the keyboard with third party software more succesfully, povhat switches on sticks might work and we could choose our own deadzones for analogue controllers.
KEYREAL  [developer] Jul 8, 2016 @ 10:35am 
I'm almost certain that this is a deadzone issue.

After some use, Xbox controllers tend to wear out and the analog sticks get loose. This means that without touching anything, they will still send input to the game. This problem is commonly known as "stick drifting". The reason why your controller works fine in other games is because they employ a higher deadzone value, which makes your stick movements slightly less responsive.

I'm going to add a deadzone slider which will let the player adjust how sensitive the sticks should be. I'll try to finish it today, maybe tomorrow. I'll post here again when it's done.
clippa Jul 8, 2016 @ 10:38am 
When I'm emulating directional controls on an analogue stick with joytokey, I always choose 30% deadzone and that seems to be perfect. You could maybe set the default to that.
Last edited by clippa; Jul 8, 2016 @ 10:39am
KEYREAL  [developer] Jul 8, 2016 @ 10:43am 
Figures, the current deadzone is 5%. I'll add a deadzone slider and set the default to somewhere around 20-30%. Thanks for the feedback.
KEYREAL  [developer] Jul 8, 2016 @ 1:25pm 
I've updated the demo and the game. There's now a new option in gamepad settings, which lets you choose the deadzone (ranged from 0.05 to 0.7). Default value is 0.3. Let me know if that fixed the issue for you.

Thanks for the feedback and I hope you enjoy the game!
clippa Jul 8, 2016 @ 1:40pm 
Recognised my qanba stick straight off the bat. Tried with the 360 pad and it works perfectly now, thanks for the quick fix :D
KEYREAL  [developer] Jul 8, 2016 @ 1:48pm 
:)
Maya Jul 8, 2016 @ 3:43pm 
Thank you, this has also fixed the menu issue I was having (had to use mouse).
< >
Showing 1-15 of 15 comments
Per page: 15 30 50

Hypnorain > General Discussions > Topic Details
Date Posted: Jul 7, 2016 @ 12:03pm
Posts: 15