Natural Selection 2

Natural Selection 2

View Stats:
Wizard Nov 25, 2012 @ 8:49am
Server and client do not match?
This keeps coming up everytime i try and join a game anyone else getting this or just me?
< >
Showing 1-4 of 4 comments
Volcano Nov 25, 2012 @ 1:21pm 
What's your client version? Try disabling some mods
Bobby Kenobii Nov 26, 2012 @ 3:41am 
Me too, i cant join any server D:, and i dont have any mods installed, just installed the game.
Billy Nov 26, 2012 @ 3:57am 
perhaps you opted for beta access? This way you will play the upcoming build, but at the moment i think that is not public and there are no servers.
Just go for options and disable beta opt-in. it will re-download some parts (think a couple of MB)
Numberz12 Nov 26, 2012 @ 4:29am 
If what Billy said does not work I believe there are a few fixes for this. Note I have never had this problem but I did a quick search for some solutions.

(NOTE: You may only have to do thie 1st fix. SHOULD it not work, then attempt the next fixes either together or seperately. Probably should try doing them at the same time. Then after try verifying the game cache)

Also be sure you do not have any mods installed as those do seem to cause conflicts especially mods that modify the server list.

#1 Go to the game in your Steam gamelist > right click it > click properties > Click Local files tab > Click the button to verify game cache and wait for it to download the new files.

#2 Nagivate to %appdata%/Roaming/Natural Selection 2/ and completely delete that folder. After you do this verify your game cache as number 1.

#3 Navigate to C:\Program Files (x86)\Steam\steamapps\common\Natural Selection 2\core\lua
There will be a file called Actor.lua delete that file then same as above verify the game cache.

#4 Should all these fixes fail you may have to completely uninstall the game from your computer ( meaning deleting all folders and files related to ns2 both in the steam folder and in the appdata folder) Then completely reinstalling the game afterwards.

It seems the game had a problem in earlier builds deleting old files and it seems most of the old files clutter up and do not update causing the client and server differ problem. I posted a few fixes about this problem in another thread but I did not actively attempt to search the problem until now and these are the fixes I got from the unknown worlds forums.

Here is my first post on the problem it's the 7th comment.

http://steamcommunity.com/app/4920/discussions/0/864951657883694461/
Last edited by Numberz12; Nov 26, 2012 @ 4:36am
< >
Showing 1-4 of 4 comments
Per page: 15 30 50

Date Posted: Nov 25, 2012 @ 8:49am
Posts: 4