Natural Selection 2

Natural Selection 2

Reaverbot 2014年3月14日下午5:46
Mouse click not working.
Pretty much what the title says. While I can scroll over options on the menu, I can't select them when I click. Any advice?
< >
正在显示第 1 - 10 条,共 10 条留言
The Elite X1 2014年3月14日下午5:51 
Same here. WTF is going on?! Never had this happen before.
aurorable1 2014年3月16日上午11:57 
I'm having the same problem, but just in the mod menu. WTF???
Kmacg 2014年3月16日下午12:20 
This seems to be a bug, I get it sometimes, but can always fix it by restarting
Goron 2014年3月17日上午9:30 
Same here now, though restarting the game doesnt seem to fix it :/
NfSpG 2014年3月19日上午6:51 
i have this same problem,please help
Warforce17 2014年3月19日上午10:00 
Quoted from Obraxis:
Hi there.

I've noticed a number of people on the Tech forums have various different issues, which could be fixed by following these next steps:

Disable all mods from within NS2 first, and unsubscribe from any in your Mods list. (You must go through steam to properly unsubscribe!)


Delete NS2 from Steam. Then do a manual NS2 Cleanup (this is not done when Steam deletes NS2 from your Library) like follows:

1) Delete NS2 from Steam the normal way.
2) Go to your hidden folder where settings are saved C:\Users\YOURUSERNAMEHERE\AppData\Roaming and Delete the 'Natural Selection 2' folder.
3) Go to your SteamApps\common Directory and make sure you delete 'natural selection 2'
4) Restart your PC (to be on the safe side)
5) Reinstall NS2 fresh from a new download.

Try those steps. Chances are, your NS2 is now working fine! :D

If that does not help then post a thread with your issue, with as much evidence as possible (screenshots/video) and also run techsupport.exe in your NS2 Steam Directory. Then upload it somewhere for us to see & report back.

Thanks all!


Also try to start the game in window mode, click on options and select your desired resolution and start normal again. There was once a bug there your mouse icon was not correctly displayed. This fixed it for me.
最后由 Warforce17 编辑于; 2014年3月19日上午10:04
Andy_Pipkin 2014年3月19日下午2:38 
I had this a couple of times as wel...everytime, I "fixed" it, by alt-tabbing out of the game, and then R-click on the NS2 icon in the windows-taskbar, and select Close.
A restart fixed it, untill the next same random-like issue.
Have same problem here. It appear often when I move mouse during the menu loading.
When I don't move my mouse during loading, this problem is very rare.
MumblesCrzy 2014年6月29日下午4:12 
I'm also seeing this issue. Followed all the solutions on this forum and nothing seems to work. Not sure what to do at this point.
galactor 2017年6月23日下午8:57 
I cant see my mouse pointer in ns2 but it still works it is just not visible
< >
正在显示第 1 - 10 条,共 10 条留言
每页显示数: 15 30 50

发帖日期: 2014年3月14日下午5:46
回复数: 10