Cossacks II: Battle for Europe

Cossacks II: Battle for Europe

View Stats:
ßā[)_ኜ Aug 19, 2013 @ 12:24pm
Cossacks2 caused an assertion error!!!
My Laptop is:

Windows 8
Processor - Intel (R) Core (TM) i5-3230 M CPU @ 2.60 GHz 2.60GHz
System Type - 64 - Bit operating system, x64 - Based processor

Just bought the Cossacks2: Battle for Europe. Instaled it but to no luck it keeps getting an error. Tried several ways to address the problem but to no avail.

Problem is:

Cossacks2 caused an assertion error!!!
File: kLog.cpp
Expression: The graphics mode is not supported.

This is exactly what shows on my computer every time i try to launch the game. What i dont understand is that how can i get this kind of error about the graphics mode when in fact DOTA 2 requires higher graphics but works great.

Would really appreciate any suggestions, much more a solution to my problem. Thank you!
< >
Showing 1-15 of 17 comments
lepthy Nov 20, 2013 @ 1:13pm 
hi if you wanna solve the problems on win7 and 8
-go to steam
-right clic the game
-properties
-browse local files
-right clic engine.exe
-properties
-compatibility
-run compatibility troubleshooter

-test & save & enjoy
ßā[)_ኜ Apr 25, 2014 @ 11:33am 
hi ty for ur advice but i already try i cant see the engine.axe there is no engine.axe in my local file any idea? thanks:d2bloodseeker:
Theodor Schmidt Aug 9, 2014 @ 5:16am 
this did not work
Theodor Schmidt Aug 11, 2014 @ 5:15am 
Problem: Assertion Error Graphics mode not supported. Happens before game opens properly.
Fix: Lower you MAIN PC resolution to 1280x720.
ßā[)_ኜ Aug 11, 2014 @ 8:37am 
is this works?
Theodor Schmidt Aug 13, 2014 @ 2:29am 
Yes it should do. The campaign and main menu screens are not compatible with modern resolutions. The game fails to temperarily change the resolution when opening. All you have to do is right click and then click screen resolution
ßā[)_ኜ Aug 13, 2014 @ 8:50am 
were should i change my pc resolution,? after i lunch the game or ill change it before i start the game?
ßā[)_ኜ Aug 13, 2014 @ 9:31am 
im done trying., but its still thesame., cant fix it...
ßā[)_ኜ Aug 13, 2014 @ 10:01am 
it says. YOU HAVE CHANGE THE GAME DATA.
Theodor Schmidt Aug 14, 2014 @ 3:16am 
before launching your game. Where does that show. I get it as well and I can play my game fine
ßā[)_ኜ Aug 14, 2014 @ 9:49am 
the warning shows., after the first loading., when i open the cossacks.,
Theodor Schmidt Aug 15, 2014 @ 5:15am 
same here, are you still able to play the game? If you wish to play multiplayer with someone use a program such as gameranger or tunngle
Dave'Bearman Jul 21, 2015 @ 2:03pm 
Hey, I had the same issue and fixed it and I have windows 8. Go to your program files with the game in it, look for a file called engine, which is actually the game launcher. Then right click properties and change the compatibility to windows 95, and it should work :) Good luck!
ReVoLT Jan 10, 2016 @ 3:45am 
I had the same issue, so I changed compatibility to windows 95 and worked. But as soon as loading screen has finished loading, it says: "You have changed game data. Internet game will not be possible." and simply exits the game. How can this be fixed?
Ps. I got Windows 10
Last edited by ReVoLT; Jan 10, 2016 @ 3:46am
dried nuts. Aug 29, 2016 @ 7:04pm 
I want a REFUND FOR BATTLE FOR EUROPE! AND BACK TO WAR!
I got win10 and got similar problem the
>Intro doesnt load
>when i did the compatibility troubleshooter nth different just says 'internet game will not be possible'
>and finaly when i could start the skirmish game its SOO SLOW AND LAGGY i mean i got a GTX 960M graphics card how could a game like cossacks be so slow?

This game is SOO POORLY MADE either in terms of programming OR interms of instructing customers how to make it compatible to any PC..
Last edited by dried nuts.; Aug 29, 2016 @ 7:05pm
< >
Showing 1-15 of 17 comments
Per page: 15 30 50