Citadel: Forged With Fire

Citadel: Forged With Fire

View Stats:
Admin password?
So far, the game is amazing. I'm having a blast, HOWEVER. How do I set the admin password in the server config? Password only changes the server pass, "AdminPassword" didn't do anything either.

*EDIT: I'm an idiot, it works fine.
Last edited by AW - Vibeavelli; Jul 28, 2017 @ 8:58am
< >
Showing 1-12 of 12 comments
AW - Vibeavelli Jul 26, 2017 @ 6:17pm 
Also a setting for permanent tames would be sick. ;)
Denis Jul 26, 2017 @ 6:22pm 
Altering "AdminPassword" and then using /admin_login in-game should do it. No luck?
John Bigalow Jul 26, 2017 @ 6:29pm 
Sorry to highjack this post... but what's the default adminpassword for custom created servers? can't seem to see it in the options / advanced options when you create a new server
Strife1one1 Jul 26, 2017 @ 6:31pm 
I have the same question as John. Doing the local server option I dont see the password listed in the game.ini to be able to change it.
Strife1one1 Jul 26, 2017 @ 6:43pm 
Originally posted by AW:
So far, the game is amazing. I'm having a blast, HOWEVER. How do I set the admin password in the server config? Password only changes the server pass, "AdminPassword" didn't do anything either.

Figured it out. Need to go to: C:\Users\*your username*\AppData\Local\Citadel\Saved\Config\WindowsNoEditor

open game.ini
add the following above the lines already in the ini and separate it by a blank line.

[/script/citadel.socialmanager]
Password=
AW - Vibeavelli Jul 26, 2017 @ 7:19pm 
Originally posted by Strife1one1:
Originally posted by AW:
So far, the game is amazing. I'm having a blast, HOWEVER. How do I set the admin password in the server config? Password only changes the server pass, "AdminPassword" didn't do anything either.

Figured it out. Need to go to: C:\Users\*your username*\AppData\Local\Citadel\Saved\Config\WindowsNoEditor

open game.ini
add the following above the lines already in the ini and separate it by a blank line.[/script/citadel.socialmanager]
Password=

I'm doing it for a dedicated server.
John Bigalow Jul 26, 2017 @ 7:22pm 
AW should be the same steps... you have to find your game.ini file on your dedicated server.
If there is no line like this
"[/script/citadel.socialmanager]
Password= "
Just add it and if there is then you can simply just change your password there...

Remember the server needs to be off otherwise you can't change it
AW - Vibeavelli Jul 27, 2017 @ 5:30am 
Originally posted by John Bigalow:
AW should be the same steps... you have to find your game.ini file on your dedicated server.
If there is no line like this
"[/script/citadel.socialmanager]
Password= "
Just add it and if there is then you can simply just change your password there...

Remember the server needs to be off otherwise you can't change it

I'm well aware of this, but password= just changes the password to get into the server. Not the admin password.

And AdminPassword= doesn't work for me either.

I don't need to be logged in as admin right now, but it will matter significantly more important when I build the server machine for Citadel and actually host it 24/7.
Last edited by AW - Vibeavelli; Jul 27, 2017 @ 5:31am
Aiz Jul 29, 2017 @ 1:33am 
Originally posted by AW:
Originally posted by John Bigalow:
AW should be the same steps... you have to find your game.ini file on your dedicated server.
If there is no line like this
"[/script/citadel.socialmanager]
Password= "
Just add it and if there is then you can simply just change your password there...

Remember the server needs to be off otherwise you can't change it

I'm well aware of this, but password= just changes the password to get into the server. Not the admin password.

And AdminPassword= doesn't work for me either.

I don't need to be logged in as admin right now, but it will matter significantly more important when I build the server machine for Citadel and actually host it 24/7.
You have to add the script part as well.
Maneki_Neko Jul 29, 2017 @ 1:52am 
Originally posted by AW:
Originally posted by John Bigalow:
AW should be the same steps... you have to find your game.ini file on your dedicated server.
If there is no line like this
"[/script/citadel.socialmanager]
Password= "
Just add it and if there is then you can simply just change your password there...

Remember the server needs to be off otherwise you can't change it

I'm well aware of this, but password= just changes the password to get into the server. Not the admin password.

And AdminPassword= doesn't work for me either.

I don't need to be logged in as admin right now, but it will matter significantly more important when I build the server machine for Citadel and actually host it 24/7.


you are incorrect.
[/script/citadel.socialmanager] Password=ADMINPASSWORD
is the admin password.

[/game/ui/qualitymenu/blueprints/bp_gameinstancewithsettings.bp_gameinstancewithsettings_c] WorldCreationSettings=(ServerName="SEVERNAME",ServerType=PVE,PlayerLimit=1,bPrivate=True,Password="SERVERPASSWORD",

the snippit of the option lines below the above controls the actual server name/password.

close the game, close the server, add the items as indicated by the handy dadny helpful folks here then turn on the server and the game and try it, instead of assuming it doesnt work. when it does. (p.s. dont forget to save and close the game.ini file so the open pointer doesnt lock the file from being read by the server ;-) ) :steamhappy:
Bloodstormz Sep 6, 2017 @ 2:48pm 
what you set in the admin panel when creating the server should be what is there in the INI. someone needs to fix that re-re crapola.
Bloodstormz Sep 20, 2017 @ 2:07pm 
Nice upgrade to the custom server menu's still missing admin password option. Had to go back into the ini file and set it with [/script/citadel.socialmanager] Password=

Also For admins if your doing the custom Build option the ini is in a different location than the other join LAN server option.
C:\Users\"Username"\AppData\Local\Citadel\SteamCMD\userdata\anonymous\config
Last edited by Bloodstormz; Sep 20, 2017 @ 2:11pm
< >
Showing 1-12 of 12 comments
Per page: 1530 50

Date Posted: Jul 26, 2017 @ 5:58pm
Posts: 12