Anno 2070

Anno 2070

Anno 2070 > General Discussions > Topic Details
sisvil Nov 30, 2015 @ 7:34am
ANNO 2070 login : error : the connection to the server has been lost
Have bought ANNO 2070 today and tried to play, however each time I start the game following appears when trying to log in to uPlay server:

ERROR : The connection to the server has been lost.

If anybody has solution please share.
Thanks
< >
Showing 1-15 of 53 comments
Sig Nov 30, 2015 @ 7:41am 
yeah...same problem here...:steamsad:
Wasavi Nov 30, 2015 @ 7:45am 
same here...:bonehead:
WillBMoore Nov 30, 2015 @ 7:48am 
same here
vansen Nov 30, 2015 @ 7:50am 
me2
Mado Nov 30, 2015 @ 7:56am 
Same here!

I use the Ubisoft support hotline. The (really nice) guy sent me (after some other attempts) a offline patch via email.

I told him about all the other users with this problem. He said, that the devs of the game know of the login problem. But Anno 2070 is bit old so the hope is really small that something is change...

Edit:
A other possible solution (which are mentioned in the support email) is to reinstall the Ucrap Launcher and install and start it with admin rights. But this didn't works for me.
Last edited by Mado; Nov 30, 2015 @ 8:20am
VettriST Nov 30, 2015 @ 8:16am 
same here :|
olel Nov 30, 2015 @ 8:33am 
Ditto. Server issue?

Edit: Well I'm able to login and play in offline mode. However I can't make progress on the world event.
Last edited by olel; Nov 30, 2015 @ 8:42am
kajinge Nov 30, 2015 @ 8:38am 
Another one bites the dust; same here :( Tried reinstalling the game launcher to no avail. The offline patch mentioned; anywhere to grab it without contacting support and waste hours of waiting?
bilibala Nov 30, 2015 @ 8:45am 
same here

Mado Nov 30, 2015 @ 8:54am 
Even the offline patch didn't works for me. A error appears "Anno 2070 is still installed and up to date" (or something like this). Nothing more. Still no login.
Last edited by Mado; Nov 30, 2015 @ 8:54am
Torham Nov 30, 2015 @ 8:56am 
same here. Trying to find solution, but its difficult, as half of search results are in german. If all fails, I guess I will just have to ask for a refund...
Mado Nov 30, 2015 @ 9:00am 
Here is the link from the support email to the offline patch (~ 970 MB):

http://static2.cdn.ubi.com/patches/anno2070/Anno2070_Offlinepatcher_2_00.zip

Maybe this is a international version, maybe only the german version (because I'm german and use the german Ubisoft support).

But give it a try.
Last edited by Mado; Nov 30, 2015 @ 9:05am
klehman775 Nov 30, 2015 @ 9:00am 
I am also getting connection issue as well and plus getting the Uplay "acheivments" as well without even playing the game
SteveS Nov 30, 2015 @ 9:08am 
For what it's worth the servers worked perfectly fine before this. So this isn't a usual occurrence.
Torham Nov 30, 2015 @ 9:11am 
Originally posted by Steve84:
For what it's worth the servers worked perfectly fine before this. So this isn't a usual occurrence.

So you had the game before today, and it was working? If so, that would mean a server issue, rather than bad steam - Uplay interface. That would also mean that noone should be able to play it, not just the new buyers...
< >
Showing 1-15 of 53 comments
Per page: 15 30 50

Anno 2070 > General Discussions > Topic Details
Date Posted: Nov 30, 2015 @ 7:34am
Posts: 53