Call of Duty: WWII

Call of Duty: WWII

View Stats:
Audio crackling and popping
Anyone else getting weird Audio crackling issues in game? If anyone has an idea how i can fix let me know! ALSO im using the Logitech G933 artemis headset EDIT: As of the newest update on
2/15/18 they still have not fixed this issue. Please devs fix this!
Last edited by Spikethelizardlegend27; Feb 15, 2018 @ 9:32pm
< >
Showing 1-15 of 85 comments
Screwiez Nov 3, 2017 @ 8:29pm 
same probs hyperx cloud 2
Maniac86 Nov 3, 2017 @ 8:56pm 
Logi 633 Headset, lots of audio popping and stuttering, audio is fine through my monitor speakers AND through my surround sound when using my living room steam link.
Pablitos Way Nov 3, 2017 @ 9:13pm 
I get this as well Corsair Void wireless. You know this has been a pretty common problem with COD games on launch. They eventually fix it with a patch. But why so often? Get it right FFS! Pretty pathetic for a Multi billion dollar company.
Originally posted by Pablitos Way:
I get this as well Corsair Void wireless. You know this has been a pretty common problem with COD games on launch. They eventually fix it with a patch. But why so often? Get it right FFS! Pretty pathetic for a Multi billion dollar company.
ya i know its annoying but if i gets fixed im alright atleast its good to know that its a common problem meaning it should be fixed sooner :)
Originally posted by Maniac86:
Logi 633 Headset, lots of audio popping and stuttering, audio is fine through my monitor speakers AND through my surround sound when using my living room steam link.
Interesting seems to be an issue specifically with sorround headsets. Hopefully they will fix it soon :)
Originally posted by Screwiez:
same probs hyperx cloud 2
Hope they fix it soon :0
King Andronikos Nov 3, 2017 @ 10:38pm 
Originally posted by Maniac86:
Logi 633 Headset, lots of audio popping and stuttering, audio is fine through my monitor speakers AND through my surround sound when using my living room steam link.

Same headset, same issue.
analtornado666 Nov 4, 2017 @ 12:50am 
Works fine on my HD800S through a Schiit Magni 2/Modi 2 stack. Maybe it's only wireless headphone that are effected?

Edit: Nevermind, the HyperX Cloud 2 is wired. I also tried it with my wife's Corsair Void wireless, and it seemed fine at first, but definitely started crackling after playing a bit.
Last edited by analtornado666; Nov 4, 2017 @ 1:16am
SpecH82T Nov 4, 2017 @ 3:49am 
I have the same problems with my Logitech G933 headset
Uroth Nov 4, 2017 @ 6:00am 
The old trick for all Call of duty games seems to still work.

Right Click the speaker icon in the taskbar.
Playback Devices
Select your default device and press Properties.
Under one of the tabs, you should have a dropdown for Default Format.
Change its value to 44100Hz.
Originally posted by Uroth:
The old trick for all Call of duty games seems to still work.

Right Click the speaker icon in the taskbar.
Playback Devices
Select your default device and press Properties.
Under one of the tabs, you should have a dropdown for Default Format.
Change its value to 44100Hz.
I did try it no luck sadly not sure what else to try =/
Originally posted by Hannibal Burgers:
Works fine on my HD800S through a Schiit Magni 2/Modi 2 stack. Maybe it's only wireless headphone that are effected?

Edit: Nevermind, the HyperX Cloud 2 is wired. I also tried it with my wife's Corsair Void wireless, and it seemed fine at first, but definitely started crackling after playing a bit.
Seems like its starting to be a very common problem. Hopefully Sledgehammer does something about this right away!
Kuha Nov 5, 2017 @ 5:37am 
For me setting the audio to 24 bit 48000Khz from Windows fixed the issue.
Originally posted by Kuha:
For me setting the audio to 24 bit 48000Khz from Windows fixed the issue.
interesting i would like to try that but sadly according to windows mine only goes up to 16 bit =/
The Teflon Don Nov 6, 2017 @ 2:22pm 


Originally posted by Spikethelizardlegend27:
Originally posted by Uroth:
The old trick for all Call of duty games seems to still work.

Right Click the speaker icon in the taskbar.
Playback Devices
Select your default device and press Properties.
Under one of the tabs, you should have a dropdown for Default Format.
Change its value to 44100Hz.
I did try it no luck sadly not sure what else to try =/




try 48000- it worked for me (bad autio is like a pain for me)
< >
Showing 1-15 of 85 comments
Per page: 15 30 50

Date Posted: Nov 3, 2017 @ 5:44pm
Posts: 85